Mailing List Archive

Project Kronos - 6-9% constant cpu usage on qemu-dm processes
Hi,

While testing a windows 2008 server VM on xapi/debian, I found out that
the qemu-dm process is continuously taking around 6 to 9% of cpu usage
in dom0.

I compared it with a xenserver 5.6 fp2, and there is no such "load" on it.

Could this be a bug? How could I find out why it is taking cpu when the
vm is idle ?

Thanks a lot for your help.

S├ębastien

ps: top output

Tasks: 175 total, 1 running, 174 sleeping, 0 stopped, 0 zombie
Cpu0 : 0.2%us, 1.0%sy, 0.0%ni, 98.8%id, 0.0%wa, 0.0%hi, 0.0%si,
0.0%st
Cpu1 : 0.0%us, 0.0%sy, 0.0%ni,100.0%id, 0.0%wa, 0.0%hi, 0.0%si,
0.0%st
Cpu2 : 0.2%us, 0.0%sy, 0.0%ni, 99.8%id, 0.0%wa, 0.0%hi, 0.0%si,
0.0%st
Cpu3 : 0.0%us, 0.0%sy, 0.0%ni,100.0%id, 0.0%wa, 0.0%hi, 0.0%si,
0.0%st
Cpu4 : 0.0%us, 0.0%sy, 0.0%ni,100.0%id, 0.0%wa, 0.0%hi, 0.0%si,
0.0%st
Cpu5 : 0.0%us, 0.0%sy, 0.0%ni,100.0%id, 0.0%wa, 0.0%hi, 0.0%si,
0.0%st
Cpu6 : 0.0%us, 0.0%sy, 0.0%ni,100.0%id, 0.0%wa, 0.0%hi, 0.0%si,
0.0%st
Cpu7 : 0.0%us, 0.0%sy, 0.0%ni,100.0%id, 0.0%wa, 0.0%hi, 0.0%si,
0.0%st
Mem: 835288k total, 582076k used, 253212k free, 27016k buffers
Swap: 1048572k total, 12176k used, 1036396k free, 237656k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
8235 root 20 0 32112 5324 1792 S 8 0.6 0:31.48 qemu-dm
4356 root 20 0 238m 25m 7760 S 0 3.1 0:41.25 xapi
[cropped]


_______________________________________________
xen-api mailing list
xen-api@lists.xensource.com
http://lists.xensource.com/mailman/listinfo/xen-api