Mailing List Archive

background image for table
Hi

I would like to set a background image for a table in wikisyntax
(without changing CSS).

I tried:
{| style="background-image:url(http://mydomain.tld/myimage.jpg)"
| Data1
| Data2
|}

but it doesn't work. When i look at the generated html code there is no
attribute generated for <table>. Other attributes (e.g.
background-color:yellow) work perfectly. As soon as i put a
background-image:url(pathtoimage) statement, all other attributes disapear.

Whats wrong here?

Greetings
Ponte


_______________________________________________
MediaWiki-l mailing list
MediaWiki-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Re: background image for table [ In reply to ]
Any style value using url() is explicitly removed.

(see Sanitizer::checkCss() )

Jared

>
> Hi
>
> I would like to set a background image for a table in wikisyntax
> (without changing CSS).
>
> I tried:
> {| style="background-image:url(http://mydomain.tld/myimage.jpg)"
> | Data1
> | Data2
> |}
>
> but it doesn't work. When i look at the generated html code
> there is no
> attribute generated for <table>. Other attributes (e.g.
> background-color:yellow) work perfectly. As soon as i put a
> background-image:url(pathtoimage) statement, all other
> attributes disapear.
>
> Whats wrong here?
>
> Greetings
> Ponte


_______________________________________________
MediaWiki-l mailing list
MediaWiki-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Re: background image for table [ In reply to ]
Thats because of security reasons?
So i have to modify CSS then?

Ponte


Jared Williams schrieb:
> Any style value using url() is explicitly removed.
>
> (see Sanitizer::checkCss() )
>
> Jared
>
>
>> Hi
>>
>> I would like to set a background image for a table in wikisyntax
>> (without changing CSS).
>>
>> I tried:
>> {| style="background-image:url(http://mydomain.tld/myimage.jpg)"
>> | Data1
>> | Data2
>> |}
>>
>> but it doesn't work. When i look at the generated html code
>> there is no
>> attribute generated for <table>. Other attributes (e.g.
>> background-color:yellow) work perfectly. As soon as i put a
>> background-image:url(pathtoimage) statement, all other
>> attributes disapear.
>>
>> Whats wrong here?
>>
>> Greetings
>> Ponte
>>
>
>
> _______________________________________________
> MediaWiki-l mailing list
> MediaWiki-l@lists.wikimedia.org
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>


--
GrĂ¼nder und Webmaster von expliki.org

_______________________________________________
MediaWiki-l mailing list
MediaWiki-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Re: background image for table [ In reply to ]
ponte@expliki.org wrote:

> I would like to set a background image for a table in wikisyntax
> (without changing CSS).

FWIW, remember that not all browsers handle table background images
consistently (or, I would say - correctly).

Mike




_______________________________________________
MediaWiki-l mailing list
MediaWiki-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Re: background image for table [ In reply to ]
ponte wrote:
> Thats because of security reasons?
> So i have to modify CSS then?
>
> Ponte

Yes. It's undesirable that anyone loading the page loads an arbitrary
url. You can use class="tablebackground" and define at
mediawiki:Common.css that class as having
background-image:url(http://mydomain.tld/myimage.jpg)


_______________________________________________
MediaWiki-l mailing list
MediaWiki-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l