Mailing List Archive

#42: Support gzip / deflate
#42: Support gzip / deflate
-------------------------+--------------------------------------------------
Reporter: des | Owner: phk
Type: enhancement | Status: new
Priority: normal | Milestone:
Component: varnishd | Version: trunk
Severity: normal | Keywords:
-------------------------+--------------------------------------------------
Varnish should have the ability to store and serve a compressed version of
a document even if the backend server delivered it uncompressed. This
requires some care, as some older browsers (notably the Netscape 4 series)
claim to support compression but don't.

A good starting point for information on how to do this in a robust manner
would be Apache's mod_deflate:
http://httpd.apache.org/docs/2.0/mod/mod_deflate.html

--
Ticket URL: <http://varnish.projects.linpro.no/ticket/42>
Varnish <http://varnish.projects.linpro.no/>
The Varnish HTTP Accelerator
#42: Support gzip / deflate [ In reply to ]
#42: Support gzip / deflate
-------------------------+--------------------------------------------------
Reporter: des | Owner: phk
Type: enhancement | Status: new
Priority: normal | Milestone: Varnish 2.0
Component: varnishd | Version: trunk
Severity: normal | Resolution:
Keywords: |
-------------------------+--------------------------------------------------
Changes (by des):

* milestone: => Varnish 2.0

Comment:

Highly desirable for 2.0.

--
Ticket URL: <http://varnish.projects.linpro.no/ticket/42>
Varnish <http://varnish.projects.linpro.no/>
The Varnish HTTP Accelerator
#42: Support gzip / deflate [ In reply to ]
#42: Support gzip / deflate
-------------------------+--------------------------------------------------
Reporter: des | Owner: phk
Type: enhancement | Status: new
Priority: normal | Milestone: Varnish 2.0
Component: varnishd | Version: trunk
Severity: normal | Resolution:
Keywords: |
-------------------------+--------------------------------------------------
Comment (by des):

21:59 < phk> With respect to deflate, you need to have ESI in mind while
doing
that, as you will be using the same object
duplicity/selection stuff.
21:59 < phk> You should also put the "Vary:" header on the 1.1 list, it's
necessary for Deflate.
21:59 < EvilDES> phk: deflate can be done orthogonally by hashing on Vary
headers
in addition to Host + URL
21:59 < phk> no, that's the wrong way.
22:00 < phk> we only hash URL+HOST
22:00 < phk> the hashheader you get then has a list of objects for that
combination.
22:00 < phk> these objects can differ in TTL, encoding, transfer encoding
or
anything else you care to think about.
22:00 < EvilDES> OK.
22:00 < phk> and as you walk the list, you find one you like, or you
create a new
22:01 < phk> and get it from the backend.
22:01 < phk> There is no way to sanely hash the vary header as it is
defined.

--
Ticket URL: <http://varnish.projects.linpro.no/ticket/42>
Varnish <http://varnish.projects.linpro.no/>
The Varnish HTTP Accelerator
#42: Support gzip / deflate [ In reply to ]
#42: Support gzip / deflate
-------------------------+--------------------------------------------------
Reporter: des | Owner: phk
Type: enhancement | Status: new
Priority: normal | Milestone: Varnish 2.0
Component: varnishd | Version: trunk
Severity: normal | Resolution:
Keywords: |
-------------------------+--------------------------------------------------
Comment (by des):

Argggh!

21:59 < phk> With respect to deflate, you need to have ESI in mind while
doing that, as you will be using the same object duplicity/selection
stuff.

21:59 < phk> You should also put the "Vary:" header on the 1.1 list, it's
necessary for Deflate.

21:59 < EvilDES> phk: deflate can be done orthogonally by hashing on Vary
headers in addition to Host + URL

21:59 < phk> no, that's the wrong way.

22:00 < phk> we only hash URL+HOST

22:00 < phk> the hashheader you get then has a list of objects for that
combination.

22:00 < phk> these objects can differ in TTL, encoding, transfer encoding
or anything else you care to think about.

22:00 < EvilDES> OK.

22:00 < phk> and as you walk the list, you find one you like, or you
create a new

22:01 < phk> and get it from the backend.

22:01 < phk> There is no way to sanely hash the vary header as it is
defined.

--
Ticket URL: <http://varnish.projects.linpro.no/ticket/42>
Varnish <http://varnish.projects.linpro.no/>
The Varnish HTTP Accelerator
Re: #42: Support gzip / deflate [ In reply to ]
#42: Support gzip / deflate
-------------------------+----------------------------------------
Reporter: des | Owner: phk
Type: enhancement | Status: closed
Priority: normal | Milestone: Varnish 2.0 code complete
Component: varnishd | Version: trunk
Severity: normal | Resolution: wontfix
Keywords: |
-------------------------+----------------------------------------

Comment (by keretamalam):

I am about to leave and cannot look into this further right now, but I do
want to mention that relying on pkg-config itself is not a problem (as you
said, we also use it later), the problem is that on some systems, the .pc
file for pkg-config is supplying wrong information (whereas on yours, it's
botan-config that is wrong), so that's why I'm trying to make it work with
both (while one of them is bad).
[http://maskodoq.blogspot.com/2014/03/unit-link-terbaik-di-indonesia.html
Unit Link Terbaik di Indonesia Commonwealth Life Investra Link]
[http://maskodoq.blogspot.com/2013/07/CiptoJunaedy.html Cipto Junaedy]
[http://etnisjawa.blogspot.com/2013/08/apakah-cipto-junaedy-bohong.html
Cipto Junaedy]

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/42#comment:6>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs