Mailing List Archive

#1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI enabled
#1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI
enabled
---------------------+------------------------------------------------------
Reporter: derjohn | Type: defect
Status: new | Priority: normal
Milestone: | Component: build
Version: 3.0.2 | Severity: normal
Keywords: |
---------------------+------------------------------------------------------
Hello,
in our setup we have a varnish in front of several Tomcat7. When Tomcat7
delivers static content, it uses chunked tranfers.

We'hit by a bug in that combination. The user gets the static content
(e.g. jquery.js) and receives a 200 status, but the content sometimes (!)
is not transferred completely. E.G. there jquery.js get truncated after
some kilobytes. My observation was, that this happens mostly (only?) if
the backend is reused.

In the logs I see such error msgs, which correlate to the error:

19 Debug c Hit send timeout, wrote = 11680/21115; retrying
19 Debug c Write error, retval = -1, len = 9435, errno = Resource
temporarily unavailable

To test I use a simple script like that and look if the outputs is always
the same or not:

for i in $(seq 1 1000); do curl -s -x "" -k
'http://$HOST/...011_jquery-1.7.1.js' | md5sum ; done

I tried varnish 3.0.2 and some newer trunks, the effect is still the same.

The same setup runs with the same config with varnish2.1.5 fine. (I had to
adapt the config parts of ESI enabling, as the syntax changed from 2.x to
3.x).

rgds,
derjohn

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1112>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI enabled [ In reply to ]
#1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI
enabled
---------------------+------------------------------------------------------
Reporter: derjohn | Type: defect
Status: new | Priority: normal
Milestone: | Component: build
Version: 3.0.2 | Severity: normal
Keywords: |
---------------------+------------------------------------------------------

Comment(by derjohn):

My Logfile is too large to attach it ... trac throws an 413 generated by
ngnix :)

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1112#comment:1>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI enabled [ In reply to ]
#1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI
enabled
---------------------+------------------------------------------------------
Reporter: derjohn | Type: defect
Status: new | Priority: normal
Milestone: | Component: build
Version: 3.0.2 | Severity: normal
Keywords: |
---------------------+------------------------------------------------------

Comment(by martin):

Hi,

Could you provide the complete client log when the error happens please?
We don't need the full log (that would be too large yes), but the complete
client transaction around where the single line you refer to, as well as
the backend traffic log if this was a fetch would be most useful. Also
please provide some details of your stack as such, e.g. which version of
OSs and such.

Regards,
Martin Blix Grydeland

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1112#comment:2>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI enabled [ In reply to ]
#1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI
enabled
---------------------+------------------------------------------------------
Reporter: derjohn | Type: defect
Status: new | Priority: normal
Milestone: | Component: build
Version: 3.0.2 | Severity: normal
Keywords: |
---------------------+------------------------------------------------------

Comment(by teominator):

Hi,

is there any new word on this? I have a similar problem and i'm wondering
if you found some changed behavior in Tomcat 7 to cause this...

Thanks,
Teo

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1112#comment:3>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI enabled [ In reply to ]
#1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI
enabled
---------------------+------------------------------------------------------
Reporter: derjohn | Owner: scoof
Type: defect | Status: new
Priority: normal | Milestone:
Component: build | Version: 3.0.2
Severity: normal | Keywords:
---------------------+------------------------------------------------------
Changes (by scoof):

* owner: => scoof


Comment:

From discussions, it would seem that tomcat7 does not deliver chunked, and
there are no indications that this is anything other than a timeout issue.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1112#comment:4>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI enabled [ In reply to ]
#1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI
enabled
---------------------+------------------------------------------------------
Reporter: derjohn | Owner: scoof
Type: defect | Status: new
Priority: normal | Milestone:
Component: build | Version: 3.0.2
Severity: normal | Keywords:
---------------------+------------------------------------------------------
Description changed by phk:

Old description:

> Hello,
> in our setup we have a varnish in front of several Tomcat7. When Tomcat7
> delivers static content, it uses chunked tranfers.
>
> We'hit by a bug in that combination. The user gets the static content
> (e.g. jquery.js) and receives a 200 status, but the content sometimes (!)
> is not transferred completely. E.G. there jquery.js get truncated after
> some kilobytes. My observation was, that this happens mostly (only?) if
> the backend is reused.
>
> In the logs I see such error msgs, which correlate to the error:
>
> 19 Debug c Hit send timeout, wrote = 11680/21115; retrying
> 19 Debug c Write error, retval = -1, len = 9435, errno =
> Resource temporarily unavailable
>
> To test I use a simple script like that and look if the outputs is always
> the same or not:
>
> for i in $(seq 1 1000); do curl -s -x "" -k
> 'http://$HOST/...011_jquery-1.7.1.js' | md5sum ; done
>
> I tried varnish 3.0.2 and some newer trunks, the effect is still the
> same.
>
> The same setup runs with the same config with varnish2.1.5 fine. (I had
> to adapt the config parts of ESI enabling, as the syntax changed from 2.x
> to 3.x).
>
> rgds,
> derjohn

New description:

Hello,
in our setup we have a varnish in front of several Tomcat7. When Tomcat7
delivers static content, it uses chunked tranfers.

We'hit by a bug in that combination. The user gets the static content
(e.g. jquery.js) and receives a 200 status, but the content sometimes (!)
is not transferred completely. E.G. there jquery.js get truncated after
some kilobytes. My observation was, that this happens mostly (only?) if
the backend is reused.

In the logs I see such error msgs, which correlate to the error:
{{{
19 Debug c Hit send timeout, wrote = 11680/21115; retrying
19 Debug c Write error, retval = -1, len = 9435, errno = Resource
temporarily unavailable
}}}
To test I use a simple script like that and look if the outputs is always
the same or not:
{{{
for i in $(seq 1 1000); do curl -s -x "" -k
'http://$HOST/...011_jquery-1.7.1.js' | md5sum ; done
}}}
I tried varnish 3.0.2 and some newer trunks, the effect is still the same.

The same setup runs with the same config with varnish2.1.5 fine. (I had to
adapt the config parts of ESI enabling, as the syntax changed from 2.x to
3.x).

rgds,
derjohn

--

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1112#comment:5>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI enabled [ In reply to ]
#1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI
enabled
---------------------+------------------------------------------------------
Reporter: derjohn | Owner: scoof
Type: defect | Status: closed
Priority: normal | Milestone:
Component: build | Version: 3.0.2
Severity: normal | Resolution: worksforme
Keywords: |
---------------------+------------------------------------------------------
Changes (by phk):

* status: new => closed
* resolution: => worksforme


Comment:

We're closing this ticket as timed out. There is no indication of an
actual bug.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1112#comment:6>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI enabled [ In reply to ]
#1112: Varnish delivers truncated files when serving from Tomcat7 Backend and ESI
enabled
---------------------+-------------------------
Reporter: derjohn | Owner: scoof
Type: defect | Status: closed
Priority: normal | Milestone:
Component: build | Version: 3.0.2
Severity: normal | Resolution: worksforme
Keywords: |
---------------------+-------------------------

Comment (by keretamalam):

I am about to leave and cannot look into this further right now, but I do
want to mention that relying on pkg-config itself is not a problem (as you
said, we also use it later), the problem is that on some systems, the .pc
file for pkg-config is supplying wrong information (whereas on yours, it's
botan-config that is wrong), so that's why I'm trying to make it work with
both (while one of them is bad).
[http://maskodoq.blogspot.com/2014/03/unit-link-terbaik-di-indonesia.html
Unit Link Terbaik di Indonesia Commonwealth Life Investra Link]
[http://maskodoq.blogspot.com/2013/07/CiptoJunaedy.html Cipto Junaedy]
[http://etnisjawa.blogspot.com/2013/08/apakah-cipto-junaedy-bohong.html
Cipto Junaedy]

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1112#comment:7>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs