Mailing List Archive

#1095: Assert error in SMS_Finish(), storage_synth.c line 114:
#1095: Assert error in SMS_Finish(), storage_synth.c line 114:
---------------------------------+------------------------------------------
Reporter: alex.goncharov | Type: defect
Status: new | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: critical
Keywords: varnishd SMS_Finish |
---------------------------------+------------------------------------------
Just got all 5 varnish nodes down with the same message.
Due to a problem on the web server pool varnishes got tons of 503. When
problems were resolved NOC tried to ban those objects from cache using ban
obj.http.status == . Naturally it did not work, but the thing is that
varnishes went down 10 minutes after.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1095>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1095: Assert error in SMS_Finish(), storage_synth.c line 114: [ In reply to ]
#1095: Assert error in SMS_Finish(), storage_synth.c line 114:
---------------------------------+------------------------------------------
Reporter: alex.goncharov | Type: defect
Status: new | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: critical
Keywords: varnishd SMS_Finish |
---------------------------------+------------------------------------------

Comment(by alex.goncharov):

ah, right:
2.6.32-5-amd64, debian 6.0.3

/etc/default/varnish
NFILES=131072
MEMLOCK=82000
DAEMON_OPTS="-a :80 \
-f /etc/varnish/mp-varnish.vcl \
-T :6082 \
-s ram=malloc,90G \
-p thread_pool_add_delay=2 \
-p http_gzip_support=on \
-p thread_pools=24 \
-p default_ttl=7200 \
-p thread_pool_min=40 \
-p thread_pool_max=4000 \
-p session_linger=50 \
-p sess_workspace=1048576 \
-p shm_workspace=8192 \
-p 'cc_command=exec cc -fpic -shared -Wl,-x
-L/usr/include/varnish/varnishapi.h -lvarnishapi -o %o %s' "

MemTotal: 99197296 kB

at the moment of crash varnish was doing around 3k req/s with 98% hitrate.
SMA mem free ~30G, mem used according to snmp statistics 82G, swap not
used.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1095#comment:1>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1095: Assert error in SMS_Finish(), storage_synth.c line 114: [ In reply to ]
#1095: Assert error in SMS_Finish(), storage_synth.c line 114:
---------------------------------+------------------------------------------
Reporter: alex.goncharov | Type: defect
Status: new | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: critical
Keywords: varnishd SMS_Finish |
---------------------------------+------------------------------------------

Comment(by alex.goncharov):

And it's 3.0.2, can't seem to change it in a proper place

varnishd (varnish-3.0.2 revision cbf1284)

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1095#comment:2>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1095: Assert error in SMS_Finish(), storage_synth.c line 114: [ In reply to ]
#1095: Assert error in SMS_Finish(), storage_synth.c line 114:
---------------------------------+------------------------------------------
Reporter: alex.goncharov | Type: defect
Status: new | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: critical
Keywords: varnishd SMS_Finish |
---------------------------------+------------------------------------------

Comment(by martin):

You wouldn't happen to have some varnishstat output of the system at
around the time this happened?

Regards,
Martin Blix Grydeland

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1095#comment:3>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1095: Assert error in SMS_Finish(), storage_synth.c line 114: [ In reply to ]
#1095: Assert error in SMS_Finish(), storage_synth.c line 114:
---------------------------------+------------------------------------------
Reporter: alex.goncharov | Type: defect
Status: new | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: critical
Keywords: varnishd SMS_Finish |
---------------------------------+------------------------------------------

Comment(by alex.goncharov):

Unfortunately no, just rrd graphs.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1095#comment:4>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1095: Assert error in SMS_Finish(), storage_synth.c line 114: [ In reply to ]
#1095: Assert error in SMS_Finish(), storage_synth.c line 114:
---------------------------------+------------------------------------------
Reporter: alex.goncharov | Type: defect
Status: new | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: critical
Keywords: varnishd SMS_Finish |
---------------------------------+------------------------------------------

Comment(by phk):

The basic problem is a malloc() failure, so check your ulimits and
similar.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1095#comment:5>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1095: Assert error in SMS_Finish(), storage_synth.c line 114: [ In reply to ]
#1095: Assert error in SMS_Finish(), storage_synth.c line 114:
-----------------------------+----------------------------------------------
Reporter: alex.goncharov | Type: defect
Status: closed | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: critical
Resolution: worksforme | Keywords: varnishd SMS_Finish
-----------------------------+----------------------------------------------
Changes (by phk):

* status: new => closed
* resolution: => worksforme


Comment:

I'm timing this ticket out: There is no indication that this is anything
but out of memory.

Feel free to reopen if evidence to the contrary appears.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1095#comment:6>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #1095: Assert error in SMS_Finish(), storage_synth.c line 114: [ In reply to ]
#1095: Assert error in SMS_Finish(), storage_synth.c line 114:
---------------------------------+-------------------------
Reporter: alex.goncharov | Owner:
Type: defect | Status: closed
Priority: normal | Milestone:
Component: varnishd | Version: 3.0.0
Severity: critical | Resolution: worksforme
Keywords: varnishd SMS_Finish |
---------------------------------+-------------------------

Comment (by keretamalam):

I am about to leave and cannot look into this further right now, but I do
want to mention that relying on pkg-config itself is not a problem (as you
said, we also use it later), the problem is that on some systems, the .pc
file for pkg-config is supplying wrong information (whereas on yours, it's
botan-config that is wrong), so that's why I'm trying to make it work with
both (while one of them is bad).
[http://maskodoq.blogspot.com/2014/03/unit-link-terbaik-di-indonesia.html
Unit Link Terbaik di Indonesia Commonwealth Life Investra Link]
[http://maskodoq.blogspot.com/2013/07/CiptoJunaedy.html Cipto Junaedy]
[http://etnisjawa.blogspot.com/2013/08/apakah-cipto-junaedy-bohong.html
Cipto Junaedy]

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1095#comment:7>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs