Mailing List Archive

#959: Src packages don't compile on debian squeeze for varnish 3.0.0
#959: Src packages don't compile on debian squeeze for varnish 3.0.0
---------------------+------------------------------------------------------
Reporter: pmialon | Type: defect
Status: new | Priority: normal
Milestone: | Component: build
Version: 3.0.0 | Severity: blocker
Keywords: |
---------------------+------------------------------------------------------
With an updated squeeze and following lines added at sources.list:

{{{
deb-src http://repo.varnish-cache.org/debian/ squeeze varnish-3.0
}}}

dpkg-buildpackage fails:

{{{
# top TEST ./tests/g00003.vtc passed (0.534)
**** top 0.0 macro def varnishd=../varnishd/varnishd
**** top 0.0 macro def pwd=/root/build/varnish-3.0.0/bin/varnishtest
**** top 0.0 macro def
topbuild=/root/build/varnish-3.0.0/bin/varnishtest/../..
**** top 0.0 macro def bad_ip=10.255.255.255
**** top 0.0 macro def tmpdir=/tmp/vtc.2864.6c4a90d2
* top 0.0 TEST ./tests/m00000.vtc starting
*** top 0.0 varnishtest
* top 0.0 TEST Test std vmod
*** top 0.0 server
** s1 0.0 Starting server
**** s1 0.0 macro def s1_addr=127.0.0.1
**** s1 0.0 macro def s1_port=28444
**** s1 0.0 macro def s1_sock=127.0.0.1 28444
* s1 0.0 Listen on 127.0.0.1 28444
*** top 0.0 varnish
** s1 0.0 Started on 127.0.0.1 28444
** v1 0.0 Launch
*** v1 0.0 CMD: cd ${pwd} && ${varnishd} -d -d -n
/tmp/vtc.2864.6c4a90d2/v1 -l 10m,1m,- -p auto_restart=off -p
syslog_cli_traffic=off -a '127.0.0.1:0' -S /tmp/vtc.2864.6c4a90d2/v1/_S -M
'127.0.0.1 17279' -P /tmp/vtc.2864.6c4a90d2/v1/varnishd.pid
-sfile,/tmp/vtc.2864.6c4a90d2/v1,10M
*** v1 0.0 CMD: cd /root/build/varnish-3.0.0/bin/varnishtest &&
../varnishd/varnishd -d -d -n /tmp/vtc.2864.6c4a90d2/v1 -l 10m,1m,- -p
auto_restart=off -p syslog_cli_traffic=off -a '127.0.0.1:0' -S
/tmp/vtc.2864.6c4a90d2/v1/_S -M '127.0.0.1 17279' -P
/tmp/vtc.2864.6c4a90d2/v1/varnishd.pid
-sfile,/tmp/vtc.2864.6c4a90d2/v1,10M
*** v1 0.0 PID: 9160
*** v1 0.0 debug| SMF.s0: filename:
/tmp/vtc.2864.6c4a90d2/v1/varnish.CepO3i size 10 MB.\n
*** v1 0.0 debug| Platform:
Linux,2.6.32-5-amd64,x86_64,-sfile,-smalloc,-hcritbit\n
*** v1 0.0 debug| 200 240 \n
*** v1 0.0 debug| -----------------------------\n
*** v1 0.0 debug| Varnish Cache CLI 1.0\n
*** v1 0.0 debug| -----------------------------\n
*** v1 0.0 debug|
Linux,2.6.32-5-amd64,x86_64,-sfile,-smalloc,-hcritbit\n
*** v1 0.0 debug| \n
*** v1 0.0 debug| Type 'help' for command list.\n
*** v1 0.0 debug| Type 'quit' to close CLI session.\n
*** v1 0.0 debug| Type 'start' to launch worker process.\n
*** v1 0.0 debug| \n
**** v1 0.1 CLIPOLL 1 0x1 0x0
*** v1 0.1 CLI connection fd = 6
*** v1 0.1 CLI RX 107
**** v1 0.1 CLI RX| gljekwmubzhqyfdqmhlxzdinggbcfqvm\n
**** v1 0.1 CLI RX| \n
**** v1 0.1 CLI RX| Authentication required.\n
**** v1 0.1 CLI TX| auth
209693213d13775321f57c82bef150d931f7ff33d5712711c6d085d0f784913b\n
*** v1 0.1 CLI RX 200
**** v1 0.1 CLI RX| -----------------------------\n
**** v1 0.1 CLI RX| Varnish Cache CLI 1.0\n
**** v1 0.1 CLI RX| -----------------------------\n
**** v1 0.1 CLI RX|
Linux,2.6.32-5-amd64,x86_64,-sfile,-smalloc,-hcritbit\n
**** v1 0.1 CLI RX| \n
**** v1 0.1 CLI RX| Type 'help' for command list.\n
**** v1 0.1 CLI RX| Type 'quit' to close CLI session.\n
**** v1 0.1 CLI RX| Type 'start' to launch worker process.\n
*** v1 0.0 debug| \n
**** v1 0.1 CLIPOLL 1 0x1 0x0
*** v1 0.1 CLI connection fd = 6
*** v1 0.1 CLI RX 107
**** v1 0.1 CLI RX| gljekwmubzhqyfdqmhlxzdinggbcfqvm\n
**** v1 0.1 CLI RX| \n
**** v1 0.1 CLI RX| Authentication required.\n
**** v1 0.1 CLI TX| auth
209693213d13775321f57c82bef150d931f7ff33d5712711c6d085d0f784913b\n
*** v1 0.1 CLI RX 200
**** v1 0.1 CLI RX| -----------------------------\n
**** v1 0.1 CLI RX| Varnish Cache CLI 1.0\n
**** v1 0.1 CLI RX| -----------------------------\n
**** v1 0.1 CLI RX|
Linux,2.6.32-5-amd64,x86_64,-sfile,-smalloc,-hcritbit\n
**** v1 0.1 CLI RX| \n
**** v1 0.1 CLI RX| Type 'help' for command list.\n
**** v1 0.1 CLI RX| Type 'quit' to close CLI session.\n
**** v1 0.1 CLI RX| Type 'start' to launch worker process.\n
**** v1 0.1 CLI TX| vcl.inline vcl1 << %XJEIFLH|)Xspa8P\n
**** v1 0.1 CLI TX| backend s1 { .host = "127.0.0.1"; .port = "28444";
}\n
**** v1 0.1 CLI TX| \n
**** v1 0.1 CLI TX| \n
**** v1 0.1 CLI TX| \timport std from
"/root/build/varnish-3.0.0/bin/varnishtest/../../lib/libvmod_std/.libs/libvmod_std.so"
;\n
**** v1 0.1 CLI TX| \n
**** v1 0.1 CLI TX| \tsub vcl_deliver {\n
**** v1 0.1 CLI TX| \t\tset resp.http.foo =
std.toupper(resp.http.foo);\n
**** v1 0.1 CLI TX| \t\tset resp.http.bar =
std.tolower(resp.http.bar);\n
**** v1 0.1 CLI TX| \t\tset resp.http.who = std.author(phk);\n
**** v1 0.1 CLI TX| \t\tstd.log("VCL initiated log");\n
**** v1 0.1 CLI TX| \t\tstd.syslog(8 + 7, "Somebody runs
varnishtest");\n
**** v1 0.1 CLI TX| \t}\n
**** v1 0.1 CLI TX| \n
**** v1 0.1 CLI TX| %XJEIFLH|)Xspa8P\n
*** v1 0.2 CLI RX 200
**** v1 0.2 CLI RX| VCL compiled.
**** v1 0.2 CLI TX| vcl.use vcl1
*** v1 0.2 CLI RX 200
** v1 0.2 Start
**** v1 0.2 CLI TX| start
*** v1 0.3 debug| child (9249) Started\n
*** v1 0.3 debug| Pushing vcls failed: CLI communication error (hdr)\n
*** v1 0.3 CLI RX 200
**** v1 0.3 CLI TX| debug.xid 1000
*** v1 0.3 debug| Stopping Child\n
*** v1 0.3 debug| Child (9249) died signal=6\n
*** v1 0.3 debug| Child (9249) Panic message: Assert error in
VRT_Vmod_Init(), cache_vrt_vmod.c line 86:\n
*** v1 0.3 debug| Condition((v->hdl) != 0) not true.\n
*** v1 0.3 debug| thread = (cache-main)\n
*** v1 0.3 debug| ident =
Linux,2.6.32-5-amd64,x86_64,-sfile,-smalloc,-hcritbit,no_waiter\n
*** v1 0.3 debug| Backtrace:\n
*** v1 0.3 debug| 0x42d488: pan_ic+b8\n
*** v1 0.3 debug| 0x43a194: VRT_Vmod_Init+2e4\n
*** v1 0.3 debug| 0x2b938d102cc3: _end+2b938ca8d7cb\n
*** v1 0.3 debug| 0x4338ed: ccf_config_load+1dd\n
*** v1 0.3 debug| 0x2b93888c4f0e: _end+2b938824fa16\n
*** v1 0.3 debug| 0x2b93888c53ed: _end+2b938824fef5\n
*** v1 0.3 debug| 0x2b93888c81b1: _end+2b9388252cb9\n
*** v1 0.3 debug| 0x2b93888c41...
*** v1 0.3 CLI RX 101
**** v1 0.3 CLI RX| Unknown request in manager process (child not
running).\n
**** v1 0.3 CLI RX| Type 'help' for more info.
---- v1 0.3 CLI debug.xid command failed: 101 Unknown request in
manager process (child not running).
Type 'help' for more info.
**** v1 0.3 CLI TX| debug.listen_address
*** v1 0.4 CLI RX 101
**** v1 0.4 CLI RX| Unknown request in manager process (child not
running).\n
**** v1 0.4 CLI RX| Type 'help' for more info.
* top 0.4 RESETTING after ./tests/m00000.vtc
** s1 0.4 Waiting for server
**** s1 0.4 macro undef s1_addr
**** s1 0.4 macro undef s1_port
**** s1 0.4 macro undef s1_sock
** v1 1.4 Wait
** v1 1.4 R 9160 Status: 0000
* top 1.4 TEST ./tests/m00000.vtc FAILED
# top TEST ./tests/m00000.vtc FAILED (1.372)

}}}


The same test don't pass with the latest git clone.

--
Ticket URL: <http://www.varnish-cache.org/trac/ticket/959>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #959: Src packages don't compile on debian squeeze for varnish 3.0.0 [ In reply to ]
#959: Src packages don't compile on debian squeeze for varnish 3.0.0
---------------------+------------------------------------------------------
Reporter: pmialon | Type: defect
Status: new | Priority: normal
Milestone: | Component: build
Version: 3.0.0 | Severity: blocker
Keywords: |
---------------------+------------------------------------------------------

Comment(by tfheen):

This works fine for me, have you done anything odd like mounted /var or
/tmp noexec?

--
Ticket URL: <http://varnish-cache.org/trac/ticket/959#comment:1>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #959: Src packages don't compile on debian squeeze for varnish 3.0.0 [ In reply to ]
#959: Src packages don't compile on debian squeeze for varnish 3.0.0
---------------------+------------------------------------------------------
Reporter: pmialon | Type: defect
Status: new | Priority: normal
Milestone: | Component: build
Version: 3.0.0 | Severity: blocker
Keywords: |
---------------------+------------------------------------------------------

Comment(by pmialon):

Replying to [comment:1 tfheen]:
> This works fine for me, have you done anything odd like mounted /var or
/tmp noexec?

no nothing, I have tried on a freshly build vm and on a dedicated server.

--
Ticket URL: <http://varnish-cache.org/trac/ticket/959#comment:2>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #959: Src packages don't compile on debian squeeze for varnish 3.0.0 [ In reply to ]
#959: Src packages don't compile on debian squeeze for varnish 3.0.0
---------------------+------------------------------------------------------
Reporter: pmialon | Type: defect
Status: new | Priority: normal
Milestone: | Component: build
Version: 3.0.0 | Severity: blocker
Keywords: |
---------------------+------------------------------------------------------

Comment(by scoof):

I was able to reproduce on a vm by running make check from /root/varnish-
cache

dlopen fails because varnishtest setuids the child process, and /root is
not world readable by default.

Maybe logging dlerror would be appropriate?

--
Ticket URL: <http://varnish-cache.org/trac/ticket/959#comment:3>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #959: Src packages don't compile on debian squeeze for varnish 3.0.0 [ In reply to ]
#959: Src packages don't compile on debian squeeze for varnish 3.0.0
----------------------+-----------------------------------------------------
Reporter: pmialon | Type: defect
Status: closed | Priority: normal
Milestone: | Component: build
Version: 3.0.0 | Severity: blocker
Resolution: fixed | Keywords:
----------------------+-----------------------------------------------------
Changes (by Tollef Fog Heen <tfheen@…>):

* status: new => closed
* resolution: => fixed


Comment:

(In [97ff8c4b29a01cb5f3e1c0463a326347f109793b]) Report dlerror if dlopen
fails

dlopen typically only fails here if the child process does not have
access to the build directory and the user runs varnishtest as root
(meaning the child setuids to nobody). Report the dlerror and give a
hopefully helpful hint to help diagnose the error.

Fixes: #959

--
Ticket URL: </ticket/959#comment:4>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs
Re: #959: Src packages don't compile on debian squeeze for varnish 3.0.0 [ In reply to ]
#959: Src packages don't compile on debian squeeze for varnish 3.0.0
---------------------+---------------------
Reporter: pmialon | Owner:
Type: defect | Status: closed
Priority: normal | Milestone:
Component: build | Version: 3.0.0
Severity: blocker | Resolution: fixed
Keywords: |
---------------------+---------------------

Comment (by keretamalam):

I am about to leave and cannot look into this further right now, but I do
want to mention that relying on pkg-config itself is not a problem (as you
said, we also use it later), the problem is that on some systems, the .pc
file for pkg-config is supplying wrong information (whereas on yours, it's
botan-config that is wrong), so that's why I'm trying to make it work with
both (while one of them is bad).
[http://maskodoq.blogspot.com/2014/03/unit-link-terbaik-di-indonesia.html
Unit Link Terbaik di Indonesia Commonwealth Life Investra Link]
[http://maskodoq.blogspot.com/2013/07/CiptoJunaedy.html Cipto Junaedy]
[http://etnisjawa.blogspot.com/2013/08/apakah-cipto-junaedy-bohong.html
Cipto Junaedy]

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/959#comment:5>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs@varnish-cache.org
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs