Mailing List Archive

trac 1.2.3 + plugin Stractistics 0.6.dev
An error is returned with accessing Stractistics in the nav bar

url: http://<host>/>project>/stractistics




AttributeError: 'Environment' object has no attribute 'get_db_cnx'



raceback (most recent call last):
File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 647, in
_dispatch_request
dispatcher.dispatch(req)
File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 248, in
dispatch
resp = chosen_handler.process_request(req)
File
"/usr/lib/python2.7/site-packages/STractistics-0.6dev-py2.7.egg/stractistics/web_ui.py",
line 85, in process_request
db = self.env.get_db_cnx()
AttributeError: 'Environment' object has no attribute 'get_db_cnx'
(139650773723264) Trac[uuuu:perm] DEBUG: DefaultPermissionPolicy allows
admin performing TRAC_ADMIN on None
(139650773723264) Trac[uuuu:wikitopdf] DEBUG: Using HTMLDOC version 1.8.28



PS: Stractistic install from :
https://trac-hacks.org/svn/stractisticsplugin

--
You received this message because you are subscribed to the Google Groups "Trac Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to trac-users+unsubscribe@googlegroups.com.
To post to this group, send email to trac-users@googlegroups.com.
Visit this group at https://groups.google.com/group/trac-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/trac-users/aacbc7d7-fef0-4112-9a4c-d3252149da4e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Re: trac 1.2.3 + plugin Stractistics 0.6.dev [ In reply to ]
On Wed, Jun 12, 2019 at 4:37 AM 'Jacques Cornily' via Trac Users <
trac-users@googlegroups.com> wrote:

>
> An error is returned with accessing Stractistics in the nav bar
>
> url: http://<host>/>project>/stractistics
>
>
>
>
> AttributeError: 'Environment' object has no attribute 'get_db_cnx'
>
>
>
> raceback (most recent call last):
> File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 647, in
> _dispatch_request
> dispatcher.dispatch(req)
> File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 248, in
> dispatch
> resp = chosen_handler.process_request(req)
> File
> "/usr/lib/python2.7/site-packages/STractistics-0.6dev-py2.7.egg/stractistics/web_ui.py",
> line 85, in process_request
> db = self.env.get_db_cnx()
> AttributeError: 'Environment' object has no attribute 'get_db_cnx'
> (139650773723264) Trac[uuuu:perm] DEBUG: DefaultPermissionPolicy allows
> admin performing TRAC_ADMIN on None
> (139650773723264) Trac[uuuu:wikitopdf] DEBUG: Using HTMLDOC version 1.8.28
>
>
>
> PS: Stractistic install from :
> https://trac-hacks.org/svn/stractisticsplugin
>

The plugin is not compatible with Trac 1.2. It needs to be adapted to use
the 1.2 database API.
You could create a ticket for the issue:
https://trac-hacks.org/wiki/StractisticsPlugin#BugsFeatureRequests

- Ryan

--
You received this message because you are subscribed to the Google Groups "Trac Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to trac-users+unsubscribe@googlegroups.com.
To post to this group, send email to trac-users@googlegroups.com.
Visit this group at https://groups.google.com/group/trac-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/trac-users/CA%2BBGpn8vQKH2bcc%2B2n1xf015oJ9yvtyZuQrpRKYR6rYJ0HCXOg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Re: trac 1.2.3 + plugin Stractistics 0.6.dev [ In reply to ]
On Wednesday, June 12, 2019 at 6:21:24 AM UTC-4, RjOllos wrote:
>
>
>
> On Wed, Jun 12, 2019 at 4:37 AM 'Jacques Cornily' via Trac Users <
> trac-users@googlegroups.com> wrote:
>
>>
>> An error is returned with accessing Stractistics in the nav bar
>>
>> url: http://<host>/>project>/stractistics
>>
>>
>>
>>
>> AttributeError: 'Environment' object has no attribute 'get_db_cnx'
>>
>>
>>
>> raceback (most recent call last):
>> File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 647, in
>> _dispatch_request
>> dispatcher.dispatch(req)
>> File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 248, in
>> dispatch
>> resp = chosen_handler.process_request(req)
>> File
>> "/usr/lib/python2.7/site-packages/STractistics-0.6dev-py2.7.egg/stractistics/web_ui.py",
>> line 85, in process_request
>> db = self.env.get_db_cnx()
>> AttributeError: 'Environment' object has no attribute 'get_db_cnx'
>> (139650773723264) Trac[uuuu:perm] DEBUG: DefaultPermissionPolicy allows
>> admin performing TRAC_ADMIN on None
>> (139650773723264) Trac[uuuu:wikitopdf] DEBUG: Using HTMLDOC version 1.8.28
>>
>>
>>
>> PS: Stractistic install from :
>> https://trac-hacks.org/svn/stractisticsplugin
>>
>
> The plugin is not compatible with Trac 1.2. It needs to be adapted to use
> the 1.2 database API.
> You could create a ticket for the issue:
> https://trac-hacks.org/wiki/StractisticsPlugin#BugsFeatureRequests
>
> - Ryan
>

Implemented a fix with minimal testing:
https://trac-hacks.org/ticket/13563

- Ryan

--
You received this message because you are subscribed to the Google Groups "Trac Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to trac-users+unsubscribe@googlegroups.com.
To post to this group, send email to trac-users@googlegroups.com.
Visit this group at https://groups.google.com/group/trac-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/trac-users/8eefcdae-6ff8-4793-ae65-61b068b7666d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Re: trac 1.2.3 + plugin Stractistics 0.6.dev [ In reply to ]
On Wednesday, June 12, 2019 at 11:02:33 AM UTC-7, RjOllos wrote:
>
>
>
> On Wednesday, June 12, 2019 at 6:21:24 AM UTC-4, RjOllos wrote:
>>
>>
>>
>> On Wed, Jun 12, 2019 at 4:37 AM 'Jacques Cornily' via Trac Users <
>> trac-users@googlegroups.com> wrote:
>>
>>>
>>> An error is returned with accessing Stractistics in the nav bar
>>>
>>> url: http://<host>/>project>/stractistics
>>>
>>>
>>>
>>>
>>> AttributeError: 'Environment' object has no attribute 'get_db_cnx'
>>>
>>>
>>>
>>> raceback (most recent call last):
>>> File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 647, in
>>> _dispatch_request
>>> dispatcher.dispatch(req)
>>> File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 248, in
>>> dispatch
>>> resp = chosen_handler.process_request(req)
>>> File
>>> "/usr/lib/python2.7/site-packages/STractistics-0.6dev-py2.7.egg/stractistics/web_ui.py",
>>> line 85, in process_request
>>> db = self.env.get_db_cnx()
>>> AttributeError: 'Environment' object has no attribute 'get_db_cnx'
>>> (139650773723264) Trac[uuuu:perm] DEBUG: DefaultPermissionPolicy allows
>>> admin performing TRAC_ADMIN on None
>>> (139650773723264) Trac[uuuu:wikitopdf] DEBUG: Using HTMLDOC version
>>> 1.8.28
>>>
>>>
>>>
>>> PS: Stractistic install from :
>>> https://trac-hacks.org/svn/stractisticsplugin
>>>
>>
>> The plugin is not compatible with Trac 1.2. It needs to be adapted to use
>> the 1.2 database API.
>> You could create a ticket for the issue:
>> https://trac-hacks.org/wiki/StractisticsPlugin#BugsFeatureRequests
>>
>> - Ryan
>>
>
> Implemented a fix with minimal testing:
> https://trac-hacks.org/ticket/13563
>
> - Ryan
>

Please let me know if you've tested the changes and confirmed it's working.

- Ryan

--
You received this message because you are subscribed to the Google Groups "Trac Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to trac-users+unsubscribe@googlegroups.com.
To post to this group, send email to trac-users@googlegroups.com.
Visit this group at https://groups.google.com/group/trac-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/trac-users/82db0457-cd93-4bbc-9ba2-bc3915884a78%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.