Mailing List Archive

Version 3.4.2, Debian Stretch
Hi,

sorry if this has been asked before. I am new to this list and couldn’t find a solution I liked. :-)

Is there a spamassassin 3.4.2 package available for Debian Stretch? I need the the RelayCountryPlugin with GeoIP2.

Regards,
Vitali
Re: Version 3.4.2, Debian Stretch [ In reply to ]
On Thu, 25 Oct 2018 at 15:12, Vitali Quiering <vitali@quiering.com> wrote:

> sorry if this has been asked before. I am new to this list and couldn’t
> find a solution I liked. :-)
> Is there a spamassassin 3.4.2 package available for Debian Stretch? I need
> the the RelayCountryPlugin with GeoIP2.


Only in sid and buster at the moment. Ubuntu 18.04 is similarly affected.
Re: Version 3.4.2, Debian Stretch [ In reply to ]
Is not compatible with debian stretch or just not available as a package? Is it tested and considered stable?

Regards,
Vitali

> Am 25.10.2018 um 16:26 schrieb Dominic Raferd <dominic@timedicer.co.uk>:
>
> On Thu, 25 Oct 2018 at 15:12, Vitali Quiering <vitali@quiering.com <mailto:vitali@quiering.com>> wrote:
> sorry if this has been asked before. I am new to this list and couldn’t find a solution I liked. :-)
> Is there a spamassassin 3.4.2 package available for Debian Stretch? I need the the RelayCountryPlugin with GeoIP2.
>
> Only in sid and buster at the moment. Ubuntu 18.04 is similarly affected.
Re: Version 3.4.2, Debian Stretch [ In reply to ]
On Thu, 25 Oct 2018 at 21:16, Vitali Quiering <vitali@quiering.com> wrote:

> Is not compatible with debian stretch or just not available as a package?
> Is it tested and considered stable?
>
> Regards,
> Vitali
>
> Am 25.10.2018 um 16:26 schrieb Dominic Raferd <dominic@timedicer.co.uk>:
>
> On Thu, 25 Oct 2018 at 15:12, Vitali Quiering <vitali@quiering.com> wrote:
>
>> sorry if this has been asked before. I am new to this list and couldn’t
>> find a solution I liked. :-)
>> Is there a spamassassin 3.4.2 package available for Debian Stretch? I
>> need the the RelayCountryPlugin with GeoIP2.
>
>
> Only in sid and buster at the moment. Ubuntu 18.04 is similarly affected.
>
>
I am confident it will be compatible, just the package for these platforms
has not been built yet.
Re: Version 3.4.2, Debian Stretch [ In reply to ]
The Debian package is not well maintained anymore unfortunately. But
it's very easy to compile SpamAssassin yourself on Debian Stretch:

1. Remove old package but leave configuration:
apt remove spamassassin

2. Install dependencies:
apt install libpcre3-dev libdigest-sha-perl libhtml-parser-perl
libnet-dns-perl libnet-ident-perl libio-socket-ssl-perl libio-zlib-perl
libarchive-tar-perl libgdbm-dev libhtml-tree-perl libwww-perl
libnetaddr-ip-perl libio-socket-inet6-perl libmail-dkim-perl
libdigest-sha-perl libmail-spf-perl libdbi-perl libencode-detect-perl
re2c libgeo-ip-perl libio-socket-ip-perl libnet-patricia-perl make
libdbd-mysql-perl

3. Download 3.4.2 package and unpack in /usr/local/src or somewhere
else:

4. Compile and install:
perl Makefile.PL
make
make install
sa-update


Best,
Jan
Re: Version 3.4.2, Debian Stretch [ In reply to ]
On 26.10.18 10:04, Jan M?nnich wrote:
>The Debian package is not well maintained anymore unfortunately.

who told you that? 3.4.2 is in unstable sinde Oct 01, testing since Oct 03.

> But it's very easy to compile SpamAssassin yourself on Debian Stretch:

this leads to problems, you must prepared to do builds for yourself always.
Simply do NOT do this, not on debian.

If you really want built, download source package from sid and try building
on stretch/jessie.

--
Matus UHLAR - fantomas, uhlar@fantomas.sk ; http://www.fantomas.sk/
Warning: I wish NOT to receive e-mail advertising to this address.
Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
LSD will make your ECS screen display 16.7 million colors