Mailing List Archive

Qmail receives messages, but does not deliver them.
My qmail will receive a mail with no problems, but it will not deliver it to
its recipients.

This is what I have tried so far:

- Reading through the documentation on the website and LWQ.
- Fixing the mail queue with a queue-repair.
- Fixing the mail queue with qfix.
- Clearing the mailing queue.

I have also asked different mail lists with this error.

This is the message I get in my log:

@400000004c10f164384be35c new msg 5619970
> @400000004c10f164384c3564 info msg 5619970: bytes 97032 from <
> username@example.com> qp 15254 uid 1046
> @400000004c10f165013ab85c starting delivery 15: msg 5619970 to local
> username@example.gov
> @400000004c10f165013abc44 status: local 1/10 remote 0/20
> @400000004c10f165015b7efc delivery 15: deferral:
> /bin/sh:_-c:_line_0:_unexpected_EOF_while_looking_for_matching_`''//bin/sh:_-c:_l
> ine_1:_syntax_error:_unexpected_end_of_file/
> @400000004c10f165015b86cc status: local 0/10 remote 0/20


The site I need help for is example.gov. The site example.com is a random
site on the Internet.

My guess is that the sintax error is the problem. I have no clue on where it
would be located, or what to look for from this error, though.

Thank you.

--
"Ing. Inf. Víctor Rafael Rivarola Soerensen" <vrrivaro@gmail.com>
Telefonos:
+595-21-612806
+595-991-204350
Re: Qmail receives messages, but does not deliver them. [ In reply to ]
On 6/10/10 10:29 AM, Ing. Inf. Victor Rafael Rivarola Soerensen wrote:
> My qmail will receive a mail with no problems, but it will not deliver it to
> its recipients.
>
> This is what I have tried so far:
>
> - Reading through the documentation on the website and LWQ.
> - Fixing the mail queue with a queue-repair.
> - Fixing the mail queue with qfix.
> - Clearing the mailing queue.
>
> I have also asked different mail lists with this error.
>
> This is the message I get in my log:
>
> @400000004c10f164384be35c new msg 5619970
>> @400000004c10f164384c3564 info msg 5619970: bytes 97032 from<
>> username@example.com> qp 15254 uid 1046
>> @400000004c10f165013ab85c starting delivery 15: msg 5619970 to local
>> username@example.gov
>> @400000004c10f165013abc44 status: local 1/10 remote 0/20
>> @400000004c10f165015b7efc delivery 15: deferral:
>> /bin/sh:_-c:_line_0:_unexpected_EOF_while_looking_for_matching_`''//bin/sh:_-c:_l
>> ine_1:_syntax_error:_unexpected_end_of_file/
>> @400000004c10f165015b86cc status: local 0/10 remote 0/20
>
>
> The site I need help for is example.gov. The site example.com is a random
> site on the Internet.
>
> My guess is that the sintax error is the problem. I have no clue on where it
> would be located, or what to look for from this error, though.
>
> Thank you.
>

It appears you are missing an ending single quote (') in your run script.

Regards,

--
Glen Barber