Mailing List Archive

Swift Install "Check that you can HEAD the account" step fails
Hi,

I am using the instructions on this page:?http://swift.openstack.org/howto_installmultinode.html. I assume this works for Diablo release of Swift as well.

I am on STEP 2 "Check that you can HEAD the account" of the "Create Swift admin account and test" step i.e.:?

curl-k -v -H 'X-Auth-Token: <token-from-x-auth-token-above>' <url-from-x-storage-url-above>

I did this and replaced the token & URL as per below. However the command failed.?


Any ideas how I can fix this?

Thanks, in advance.

Regards,

Amar
===

curl -k -v -H 'X-Auth-Token: AUTH_tk9dac19fd2c87484bb7c9e779b0478968'?https://$PROXY_LOCAL_NET_IP:8080/v1/AUTH_system/


* About to connect() to 10.10.10.61 port 8080 (#0)
*? Trying 10.10.10.61... connected
* Connected to 10.10.10.61 (10.10.10.61) port 8080 (#0)
* successfully set certificate verify locations:
*? CAfile: none
? CApath: /etc/ssl/certs
* SSLv3, TLS handshake, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, CERT (11):
* SSLv3, TLS handshake, Server finished (14):
* SSLv3, TLS handshake, Client key exchange (16):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSL connection using AES256-SHA
* Server certificate:
*? ? ? subject: C=US; ST=CA; L=San Francisco; O=UL; emailAddress=xxx at yyy.com
*? ? ? start date:?2011-10-02 09:03:42 GMT
*? ? ? expire date:?2011-11-01 09:03:42 GMT
* SSL: unable to obtain common name from peer certificate
> GET /v1/AUTH_system/ HTTP/1.1
> User-Agent: curl/7.19.7 (x86_64-pc-linux-gnu) libcurl/7.19.7 OpenSSL/0.9.8k zlib/1.2.3.3 libidn/1.15
> Host: 10.10.10.61:8080
> Accept: */*
> X-Auth-Token: AUTH_tk9dac19fd2c87484bb7c9e779b0478968
>
< HTTP/1.1 401 Unauthorized
< Content-Length: 358
< Content-Type: text/html; charset=UTF-8
< Date:?Mon, 03 Oct 2011 21:13:58 GMT
<
<html>
<head>
<title>401 Unauthorized</title>
</head>
<body>
<h1>401 Unauthorized</h1>
? This server could not verify that you are authorized to access the document you requested. Either you supplied the wrong credentials (e.g., bad password), or your browser does not understand how to supply the credentials required.<br /><br />
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20111003/07f15d4d/attachment.html>