Mailing List Archive

qt5 dependancy issue
I'm having to rebuild one of my FE's, using centos7 with epel and nux-dextop (wiki recommended iirc).
'yum install mythtv-frontend' attempts to install some qt5 components but I'm failing on version mismatch.

Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
Requires: qt5-qtdeclarative(x86-64) = 5.6.2
Installed: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (@base)
qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
Requires: qt5-qtbase(x86-64) = 5.6.2
Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@base)
qt5-qtbase(x86-64) = 5.9.2-3.el7

looks like it's wanting 5.6.2, but 5.9.2 is newer.

what would be the correct way forward to resolve this, --skip-broken, temporarily disable one of the repos (which one; base or epel?) and/or exclude qt5 from base repos and rely soly on epel?


_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: qt5 dependancy issue [ In reply to ]
On 11/05/18 09:44, Tim Draper wrote:
> I'm having to rebuild one of my FE's, using centos7 with epel and nux-dextop (wiki recommended iirc).
> 'yum install mythtv-frontend' attempts to install some qt5 components but I'm failing on version mismatch.
>
> Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
> Requires: qt5-qtdeclarative(x86-64) = 5.6.2
> Installed: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (@base)
> qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
> Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
> Requires: qt5-qtbase(x86-64) = 5.6.2
> Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@base)
> qt5-qtbase(x86-64) = 5.9.2-3.el7
>
> looks like it's wanting 5.6.2, but 5.9.2 is newer.
>
> what would be the correct way forward to resolve this, --skip-broken, temporarily disable one of the repos (which one; base or epel?) and/or exclude qt5 from base repos and rely soly on epel?
>
The same question was asked here yesterday by Ashu and an answer was
given. I have 5.6.2-1 installed, apparently from the SL7rolling repo
some time ago, and yumex has not offered to change it. I don't have
SL7rolling enabled now and I'm not seeing 5.9...

There was a rather inconclusive BZ about it last year.

https://bugzilla.redhat.com/show_bug.cgi?id=1478131

_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: qt5 dependancy issue [ In reply to ]
---- On Fri, 11 May 2018 11:06:26 +0100 John Pilkington <johnpilk222@gmail.com> wrote ----
> On 11/05/18 09:44, Tim Draper wrote:
> > I'm having to rebuild one of my FE's, using centos7 with epel and nux-dextop (wiki recommended iirc).
> > 'yum install mythtv-frontend' attempts to install some qt5 components but I'm failing on version mismatch.
> >
> > Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
> > Requires: qt5-qtdeclarative(x86-64) = 5.6.2
> > Installed: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (@base)
> > qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
> > Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
> > Requires: qt5-qtbase(x86-64) = 5.6.2
> > Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@base)
> > qt5-qtbase(x86-64) = 5.9.2-3.el7
> >
> > looks like it's wanting 5.6.2, but 5.9.2 is newer.
> >
> > what would be the correct way forward to resolve this, --skip-broken, temporarily disable one of the repos (which one; base or epel?) and/or exclude qt5 from base repos and rely soly on epel?
> >
> The same question was asked here yesterday by Ashu and an answer was
> given. I have 5.6.2-1 installed, apparently from the SL7rolling repo
> some time ago, and yumex has not offered to change it. I don't have
> SL7rolling enabled now and I'm not seeing 5.9...
>
> There was a rather inconclusive BZ about it last year.
>
> https://bugzilla.redhat.com/show_bug.cgi?id=1478131
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users@mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org
>
thanks, i'm taking this over to Ash's thread. (cant believe i missed it!)

_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: qt5 dependancy issue [ In reply to ]
On 11/05/2018 8:51 PM, Tim Draper wrote:
>
>
> ---- On Fri, 11 May 2018 11:06:26 +0100 John Pilkington <johnpilk222@gmail.com> wrote ----
> > On 11/05/18 09:44, Tim Draper wrote:
> > > I'm having to rebuild one of my FE's, using centos7 with epel and nux-dextop (wiki recommended iirc).
> > > 'yum install mythtv-frontend' attempts to install some qt5 components but I'm failing on version mismatch.
> > >
> > > Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
> > > Requires: qt5-qtdeclarative(x86-64) = 5.6.2
> > > Installed: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (@base)
> > > qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
> > > Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
> > > Requires: qt5-qtbase(x86-64) = 5.6.2
> > > Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@base)
> > > qt5-qtbase(x86-64) = 5.9.2-3.el7
> > >
> > > looks like it's wanting 5.6.2, but 5.9.2 is newer.
> > >
> > > what would be the correct way forward to resolve this, --skip-broken, temporarily disable one of the repos (which one; base or epel?) and/or exclude qt5 from base repos and rely soly on epel?
> > >
> > The same question was asked here yesterday by Ashu and an answer was
> > given. I have 5.6.2-1 installed, apparently from the SL7rolling repo
> > some time ago, and yumex has not offered to change it. I don't have
> > SL7rolling enabled now and I'm not seeing 5.9...
> >
> > There was a rather inconclusive BZ about it last year.
> >
> > https://bugzilla.redhat.com/show_bug.cgi?id=1478131
> >
> > _______________________________________________
> > mythtv-users mailing list
> > mythtv-users@mythtv.org
> > http://lists.mythtv.org/mailman/listinfo/mythtv-users
> > http://wiki.mythtv.org/Mailing_List_etiquette
> > MythTV Forums: https://forum.mythtv.org
> >
> thanks, i'm taking this over to Ash's thread. (cant believe i missed it!)
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users@mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org

qt5-qtwebkit-5.9.2-1.el7.x86_64
is in epel test I have been using it to compile my el7 rpms recently. I've also added it to my rpms for convenience.

Stephen

_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: qt5 dependancy issue [ In reply to ]
On 12/05/18 05:55, Stephen Collier wrote:
> On 11/05/2018 8:51 PM, Tim Draper wrote:
>>
>>
>>   ---- On Fri, 11 May 2018 11:06:26 +0100 John Pilkington
>> <johnpilk222@gmail.com> wrote ----
>>   > On 11/05/18 09:44, Tim Draper wrote:
>>   > > I'm having to rebuild one of my FE's, using centos7 with epel
>> and nux-dextop (wiki recommended iirc).
>>   > > 'yum install mythtv-frontend' attempts to install some qt5
>> components but I'm failing on version mismatch.
>>   > >
>>   > > Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
>>   > >             Requires: qt5-qtdeclarative(x86-64) = 5.6.2
>>   > >             Installed: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (@base)
>>   > >                 qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
>>   > > Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
>>   > >             Requires: qt5-qtbase(x86-64) = 5.6.2
>>   > >             Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@base)
>>   > >                 qt5-qtbase(x86-64) = 5.9.2-3.el7
>>   > >
>>   > > looks like it's wanting 5.6.2, but 5.9.2 is newer.
>>   > >
>>   > > what would be the correct way forward to resolve this,
>> --skip-broken, temporarily disable one of the repos (which one; base
>> or epel?) and/or exclude qt5 from base repos and rely soly on epel?
>>   > >
>>   > The same question was asked here yesterday by Ashu and an answer was
>>   > given.  I have 5.6.2-1 installed, apparently from the SL7rolling repo
>>   > some time ago, and yumex has not offered to change it.  I don't have
>>   > SL7rolling enabled now and I'm not seeing 5.9...
>>   >
>>   > There was a rather inconclusive BZ about it last year.
>>   >
>>   > https://bugzilla.redhat.com/show_bug.cgi?id=1478131
>>   >

>>   >
>> thanks, i'm taking this over to Ash's thread. (cant believe i missed it!)
>>

> qt5-qtwebkit-5.9.2-1.el7.x86_64
>  is in epel test I have been using it to compile my el7 rpms recently.
> I've also added it to my rpms for convenience.
>
> Stephen

I'm now seeing it in epel.

I think the qt5.6 vs qt5.9 issue is mainly about timing. There is a
delay between the release of rhel7.x and the appearance of the CentOS or
SL rebuilds, and epel is usually kept in sync with rhel. Some SL7
users, including me, weren't seeing the 7.5 packages anyway.

I have just rebuilt my 30-pre-579 mythtv-master packages (from before
the ffmpeg refactor) for the new SL7x environment, using mock in F26,
and was able to install them under SL7.4. They pulled in qt5.9 and
several other packages; after that 'yum update' installed or updated 532
more packages from SL7x and so far all seems good...

John P

_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: qt5 dependancy issue [ In reply to ]
On 15/5/18 5:42 pm, John Pilkington wrote:
> On 12/05/18 05:55, Stephen Collier wrote:
>> On 11/05/2018 8:51 PM, Tim Draper wrote:
>>>
>>>
>>>   ---- On Fri, 11 May 2018 11:06:26 +0100 John Pilkington
>>> <johnpilk222@gmail.com> wrote ----
>>>   > On 11/05/18 09:44, Tim Draper wrote:
>>>   > > I'm having to rebuild one of my FE's, using centos7 with epel
>>> and nux-dextop (wiki recommended iirc).
>>>   > > 'yum install mythtv-frontend' attempts to install some qt5
>>> components but I'm failing on version mismatch.
>>>   > >
>>>   > > Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
>>>   > >             Requires: qt5-qtdeclarative(x86-64) = 5.6.2
>>>   > >             Installed: qt5-qtdeclarative-5.9.2-1.el7.x86_64
>>> (@base)
>>>   > >                 qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
>>>   > > Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
>>>   > >             Requires: qt5-qtbase(x86-64) = 5.6.2
>>>   > >             Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@base)
>>>   > >                 qt5-qtbase(x86-64) = 5.9.2-3.el7
>>>   > >
>>>   > > looks like it's wanting 5.6.2, but 5.9.2 is newer.
>>>   > >
>>>   > > what would be the correct way forward to resolve this,
>>> --skip-broken, temporarily disable one of the repos (which one; base
>>> or epel?) and/or exclude qt5 from base repos and rely soly on epel?
>>>   > >
>>>   > The same question was asked here yesterday by Ashu and an answer
>>> was
>>>   > given.  I have 5.6.2-1 installed, apparently from the SL7rolling
>>> repo
>>>   > some time ago, and yumex has not offered to change it. I don't have
>>>   > SL7rolling enabled now and I'm not seeing 5.9...
>>>   >
>>>   > There was a rather inconclusive BZ about it last year.
>>>   >
>>>   > https://bugzilla.redhat.com/show_bug.cgi?id=1478131
>>>   >
>
>>>   >
>>> thanks, i'm taking this over to Ash's thread. (cant believe i missed
>>> it!)
>>>
>
>> qt5-qtwebkit-5.9.2-1.el7.x86_64
>>   is in epel test I have been using it to compile my el7 rpms
>> recently. I've also added it to my rpms for convenience.
>>
>> Stephen
>
> I'm now seeing it in epel.
>
> I think the qt5.6 vs qt5.9 issue is mainly about timing.  There is a
> delay between the release of rhel7.x and the appearance of the CentOS
> or SL rebuilds, and epel is usually kept in sync with rhel.  Some SL7
> users, including me, weren't seeing the 7.5 packages anyway.
>
> I have just rebuilt my 30-pre-579 mythtv-master packages (from before
> the ffmpeg refactor) for the new SL7x environment, using mock in F26,
> and was able to install them under SL7.4.  They pulled in qt5.9 and
> several other packages; after that 'yum update' installed or updated
> 532 more packages from SL7x and so far all seems good...
>
> John P
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users@mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org

Glad its all working- the underlying issue was that gt4-gtwebkit-5.9
does not compile with a standard el7 gcc. It needed a more recent
complier hence why epel were more cautious at releasing it. At least
thats my understanding.

_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org