Mailing List Archive

Qt 5.9
I see that on my Gentoo systems (x86), Qt 5.9.4 has gone stable. I
just wanted to verify as to whether that's OK for MythTV 29.1, or
whether there are any known issues etc.

One other question...and I should probably know this but I can
recall...does an upgrade from Qt 5.7.1 to Qt 5.9.4 require a recompile
of MythTV?

Thanks!
Tom
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: Qt 5.9 [ In reply to ]
On 07/04/18 15:11, Tom Dexter wrote:
> I see that on my Gentoo systems (x86), Qt 5.9.4 has gone stable. I
> just wanted to verify as to whether that's OK for MythTV 29.1, or
> whether there are any known issues etc.
>
> One other question...and I should probably know this but I can
> recall...does an upgrade from Qt 5.7.1 to Qt 5.9.4 require a recompile
> of MythTV?
>
> Thanks!
> Tom

Yep, I've been running Qt 5.9.4 on F27 for a while.

It's best to recompile if you can.

Regards
Stuart


_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: Qt 5.9 [ In reply to ]
On Mon, Apr 9, 2018 at 7:00 AM, Stuart Auchterlonie
<stuarta@squashedfrog.net> wrote:
> On 07/04/18 15:11, Tom Dexter wrote:
>>
>> I see that on my Gentoo systems (x86), Qt 5.9.4 has gone stable. I
>> just wanted to verify as to whether that's OK for MythTV 29.1, or
>> whether there are any known issues etc.
>>
>> One other question...and I should probably know this but I can
>> recall...does an upgrade from Qt 5.7.1 to Qt 5.9.4 require a recompile
>> of MythTV?
>>
>> Thanks!
>> Tom
>
>
> Yep, I've been running Qt 5.9.4 on F27 for a while.
>
> It's best to recompile if you can.
>
> Regards
> Stuart
>

Thanks! Looking back, when I was on 0.28, the Qt upgrade from 5.6 to
5.7 automatically triggered a recompile of mythtv based on the Gentoo
ebuilds. For some reason it doesn't seem to think it needs to do that
for this update with my 29.1 ebuild. I may have to ask about that on
the Gentoo forum from someone who knows those ebuild internals. Thanks
again!

Tom
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: Qt 5.9 [ In reply to ]
On Mon, Apr 9, 2018 at 7:00 AM, Stuart Auchterlonie
<stuarta@squashedfrog.net> wrote:
>
> It's best to recompile if you can.
>
> Regards
> Stuart
>

Quick question on this one: From what I'm finding, a recompile for
that version upgrade should only be needed it private headers are
being used(?). Is that correct, and does MythTV use them at all?

Thanks!
Tom
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: Qt 5.9 [ In reply to ]
On 10/04/18 21:13, Tom Dexter wrote:
> On Mon, Apr 9, 2018 at 7:00 AM, Stuart Auchterlonie
> <stuarta@squashedfrog.net> wrote:
>>
>> It's best to recompile if you can.
>>
>> Regards
>> Stuart
>>
>
> Quick question on this one: From what I'm finding, a recompile for
> that version upgrade should only be needed it private headers are
> being used(?). Is that correct, and does MythTV use them at all?
>

We shouldn't be using any private headers from Qt,
and i'm not aware of any being used.

You definitely won't need a rebuild within the same
Qt minor version. eg Qt 5.9.3 -> 5.9.4.

The switch between Qt 5.7 -> 5.9 "in theory" you could
get away without a rebuild if the ABI doesn't change.

However it's between the minor releases that Qt deprecates
(but not removes) functionality, which is why the recommendation is
always to rebuild on a minor version change.


Regards
Stuart
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: Qt 5.9 [ In reply to ]
On Thu, Apr 12, 2018 at 6:50 AM, Stuart Auchterlonie
<stuarta@squashedfrog.net> wrote:
> On 10/04/18 21:13, Tom Dexter wrote:
>>
>>
>> Quick question on this one: From what I'm finding, a recompile for
>> that version upgrade should only be needed it private headers are
>> being used(?). Is that correct, and does MythTV use them at all?
>>
>
> We shouldn't be using any private headers from Qt,
> and i'm not aware of any being used.
>
> You definitely won't need a rebuild within the same
> Qt minor version. eg Qt 5.9.3 -> 5.9.4.
>
> The switch between Qt 5.7 -> 5.9 "in theory" you could
> get away without a rebuild if the ABI doesn't change.
>
> However it's between the minor releases that Qt deprecates
> (but not removes) functionality, which is why the recommendation is
> always to rebuild on a minor version change.
>
>
>
> Regards
> Stuart

Thanks for the clarification. I'm going to recompile after the update
and will change the Gentoo ebuild to do so in the future.

Thanks again!
Tom
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org