Mailing List Archive

HDMI Audio no front right/left channels
Hi,

I upgraded my mythtv system to v 28 (regretfully) and now cant get 5.1
audio over HDMI to work correctly. I am running ubuntu 16.04 on a ECS Liva
mini-pc.

Here is the audio setup:
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC282 Analog [ALC282 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0


When i run test command:
speaker-test -c 6 -r 48000 -D hw:0,3


i get white noise on center, rear right, rear left and LFE. I get nothing
on the front left and right speakers.

In Mythtv I am selecting ALSA:hw:CARD=PCH,DEV=3 (tired all options as well)
and enabling 5.1 speakers and Dobly Digital.

When i look at my Marantz amp i see dobly digital as sound info as Dobly
Digital.

also interestingly when i goto audio settings while watching the command
line i see:
ALSA lib pcm_dsnoop.c:545:(snd_pcm_dsnoop_open) The dsnoop plugin supports
only capture stream
ALSA lib pcm_dsnoop.c:545:(snd_pcm_dsnoop_open) The dsnoop plugin supports
only capture stream
2018-02-05 22:56:19.786346 E ALSA: snd_pcm_open("dsnoop:CARD=PCH,DEV=0"):
Invalid argument
2018-02-05 22:56:19.791330 E ALSA: snd_pcm_open("dsnoop:CARD=PCH,DEV=3"):
Invalid argument
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect:
Connection refused

ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
2018-02-05 22:56:20.022026 E ALSA: snd_pcm_open("pulse"): Connection
refused
2018-02-05 22:56:20.028381 E ALSA:
snd_pcm_open("surround21:CARD=PCH,DEV=0"): Invalid argument
2018-02-05 22:56:20.063161 E ALSA:
snd_pcm_open("surround41:CARD=PCH,DEV=0"): Invalid argument
2018-02-05 22:56:20.067783 E ALSA:
snd_pcm_open("surround50:CARD=PCH,DEV=0"): Invalid argument
2018-02-05 22:56:20.206484 E PulseAudio: ContextConnect, context connect
failed: Connection refused


I am at a complete loss on this one. Been using mythtv since .20 and never
had anything like this. Normally sound either works or it doesnt.

Any suggestions?
Re: HDMI Audio no front right/left channels [ In reply to ]
On 02/05/2018 11:58 PM, Mitchell Gore wrote:
> Hi,
>
> I upgraded my mythtv system to v 28 (regretfully) and now cant get 5.1
> audio over HDMI to work correctly.  I am running ubuntu 16.04 on a ECS
> Liva mini-pc.
>
> Here is the audio setup:
> **** List of PLAYBACK Hardware Devices ****
> card 0: PCH [HDA Intel PCH], device 0: ALC282 Analog [ALC282 Analog]
>   Subdevices: 1/1
>   Subdevice #0: subdevice #0
> card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
>   Subdevices: 1/1
>   Subdevice #0: subdevice #0
>
>

I'm also running Ubuntu 16.04 on all my frontends.  Most are Intel NUC's
with HDMI monitors.  I've run them on v0.28 and v29.1.  On my Setup
wizard I have selections for all the usual audio stuff, but since I have
HDMI, I also have alsa HDMI dev 0 and 1.  I also have to change my
Ubuntu Sound mixer to the same HDMI if I want Kodi or VLC to work.  I
find that Mythtv setup Speaker test with 5.1 had issues with v0.28, but
it's fine in v29.1.

Not sure why you aren't seeing HDMI.  I didn't do anything fancy on my
Ubuntu install or mythtv install.

Jim A

> When i run test command:
>  speaker-test -c 6 -r 48000 -D hw:0,3
>
> i get white noise on center, rear right, rear left and LFE.  I get
> nothing on the front left and right speakers.
>
> In Mythtv I am selecting ALSA:hw:CARD=PCH,DEV=3 (tired all options as
> well) and enabling 5.1 speakers and Dobly Digital.
>
> When i look at my Marantz amp i see dobly digital as sound info as
> Dobly Digital.
>
> also interestingly when i goto audio settings while watching the
> command line i see:
> ALSA lib pcm_dsnoop.c:545:(snd_pcm_dsnoop_open) The dsnoop plugin
> supports only capture stream
> ALSA lib pcm_dsnoop.c:545:(snd_pcm_dsnoop_open) The dsnoop plugin
> supports only capture stream
> 2018-02-05 22:56:19.786346 E  ALSA:
> snd_pcm_open("dsnoop:CARD=PCH,DEV=0"): Invalid argument
> 2018-02-05 22:56:19.791330 E  ALSA:
> snd_pcm_open("dsnoop:CARD=PCH,DEV=3"): Invalid argument
> ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect:
> Connection refused
>
> ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching
> channel map
> ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching
> channel map
> ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching
> channel map
> 2018-02-05 22:56:20.022026 E  ALSA: snd_pcm_open("pulse"): Connection
> refused
> 2018-02-05 22:56:20.028381 E  ALSA:
> snd_pcm_open("surround21:CARD=PCH,DEV=0"): Invalid argument
> 2018-02-05 22:56:20.063161 E  ALSA:
> snd_pcm_open("surround41:CARD=PCH,DEV=0"): Invalid argument
> 2018-02-05 22:56:20.067783 E  ALSA:
> snd_pcm_open("surround50:CARD=PCH,DEV=0"): Invalid argument
> 2018-02-05 22:56:20.206484 E  PulseAudio: ContextConnect, context
> connect failed: Connection refused
>
>
> I am at a complete loss on this one.  Been using mythtv since .20 and
> never had anything like this.  Normally sound either works or it doesnt.
>
> Any suggestions?
>
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users@mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org