Mailing List Archive

Is libdvb actually used?
I noticed today that Gentoo maintainers are removing
media-libs/libdvb. Apparently the current Gentoo ebuild for mythtv is
the only dependency referencing that, and the dependency is apparently
bogus:

https://bugs.gentoo.org/show_bug.cgi?id=451792

I wanted to know if anyone could verify that. I'm almost sure they're
correct...that is, that the only real requirement are the kernel
headers. I still have one remaining pcHDTV HD-5500 card that requires
DVB support.

Thanks!
Tom
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: Is libdvb actually used? [ In reply to ]
On Tue, Jan 2, 2018 at 10:53 AM, Tom Dexter <digitalaudiorock@gmail.com> wrote:
> I noticed today that Gentoo maintainers are removing
> media-libs/libdvb. Apparently the current Gentoo ebuild for mythtv is
> the only dependency referencing that, and the dependency is apparently
> bogus:
>
> https://bugs.gentoo.org/show_bug.cgi?id=451792
>
> I wanted to know if anyone could verify that. I'm almost sure they're
> correct...that is, that the only real requirement are the kernel
> headers. I still have one remaining pcHDTV HD-5500 card that requires
> DVB support.
>
> Thanks!
> Tom

I was looking and I could see based on ldd that that library wasn't
used. I removed the dependency from the ebuild and uninstalled
media-libs/libdvb completely, and the backend works fine. So that
answers that.

Tom
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: Is libdvb actually used? [ In reply to ]
On 02/01/18 20:37, Tom Dexter wrote:
> On Tue, Jan 2, 2018 at 10:53 AM, Tom Dexter <digitalaudiorock@gmail.com> wrote:
>> I noticed today that Gentoo maintainers are removing
>> media-libs/libdvb. Apparently the current Gentoo ebuild for mythtv is
>> the only dependency referencing that, and the dependency is apparently
>> bogus:
>>
>> https://bugs.gentoo.org/show_bug.cgi?id=451792
>>
>> I wanted to know if anyone could verify that. I'm almost sure they're
>> correct...that is, that the only real requirement are the kernel
>> headers. I still have one remaining pcHDTV HD-5500 card that requires
>> DVB support.
>>
>> Thanks!
>> Tom
>
> I was looking and I could see based on ldd that that library wasn't
> used. I removed the dependency from the ebuild and uninstalled
> media-libs/libdvb completely, and the backend works fine. So that
> answers that.
>

No we don't use that library at all.
We do it all ourselves



Regards
Stuart
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org