Mailing List Archive

No audio for DVD playback
Dear list,

I recently made some changes to the setup on my main frontend which have
(I think) improved the picture quality when I play recordings (principal
use case), while preserving my ability to listen to music (second use case).

However, I did not test my thirdmost imprtant use case, which is DVD
playback. Unfortunately, when my wife and I wanted to watch a DVD just
now, we found that audio isn't working. Picture's fine; no audio.

Checked the wiki [1]; not much help.

[1]:
https://www.mythtv.org/wiki/Sound_Troubleshooting#No_Audio_for_DVD_playback

In alsamixer none of the outputs are muted.

So to be clear: this used to work on the same hardware. I did not make
detailed notes of what I changed though :-(

I'm on up-to-date 0.27-fixes.

Any hints?

I don't have logs to share right now; we decided to watch something else
and know I need to share the full log from startup to failure.

Thanks, Jan
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: No audio for DVD playback [ In reply to ]
What are you using for dvd playback internal or external application ? What
linux version are you running
Re: No audio for DVD playback [ In reply to ]
On 11/11/14 20:26, Jan Ceuleers wrote:
> Dear list,
>
> I recently made some changes to the setup on my main frontend which have
> (I think) improved the picture quality when I play recordings (principal
> use case), while preserving my ability to listen to music (second use case).
>
> However, I did not test my thirdmost imprtant use case, which is DVD
> playback. Unfortunately, when my wife and I wanted to watch a DVD just
> now, we found that audio isn't working. Picture's fine; no audio.
>
> Checked the wiki [1]; not much help.
>
> [1]:
> https://www.mythtv.org/wiki/Sound_Troubleshooting#No_Audio_for_DVD_playback
>
> In alsamixer none of the outputs are muted.
>
> So to be clear: this used to work on the same hardware. I did not make
> detailed notes of what I changed though :-(
>
> I'm on up-to-date 0.27-fixes.
>
> Any hints?
>
> I don't have logs to share right now; we decided to watch something else
> and know I need to share the full log from startup to failure.

Hi Jan,

Does this occur on all DVDs or just one/some? What's your audio setup?
Did audio work on DVDs before you made the changes to the frontend?
What did you change?

Logs with -v playback --loglevel=debug would be best but I'm not aware
of any current issues.

Richard.
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: No audio for DVD playback [ In reply to ]
Hi Richard,

On 11/11/2014 09:10 PM, Richard Hulme wrote:
> Does this occur on all DVDs or just one/some? What's your audio setup?
> Did audio work on DVDs before you made the changes to the frontend?
> What did you change?

It occurs on all DVDs.

My audio setup (summarised) is as follows; if you need further info
please ask:

- ALSA:hdmi:CARD=Intel,DEV=1
- Stereo speaker configuration

This is a Zotac H55-ITX card with an Intel Core i3-540 CPU. A Samsung TV
is connected to the HDMI port; audio goes through the HDMI interface.
This works for playing back recordings and music but not for DVD playback.

Audio did work on DVDs prior to making my changes.

I'm not sure what was changed exactly, unfortunately. Part of the
problem is that I lost power to the motherboard, and it seems that the
on-board battery is no longer working because I had to reconfigure the
BIOS from the ground up. One thing I had to do was to reenable audio
over HDMI, but as I said that does not explain why it is working for
recordings and music but not DVDs.

> Logs with -v playback --loglevel=debug would be best but I'm not aware
> of any current issues.

The requested frontend log is here:

http://paste.ubuntu.com/8962758/

I really don't know how to interpret it, so I also don't know how to
paste the salient bits here.

Thanks, Jan
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: No audio for DVD playback - SOLVED [ In reply to ]
On 11/12/2014 01:21 PM, Jan Ceuleers wrote:
> My audio setup (summarised) is as follows; if you need further info
> please ask:
>
> - ALSA:hdmi:CARD=Intel,DEV=1
> - Stereo speaker configuration

I have solved this myself by (lucky shot in the dark) setting the
"Stereo PCM Only" flag in the Advanced Audio Settings. All three use
cases (recordings, music, DVD) now work.

I will add this to the wiki.

Thanks, Jan
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: No audio for DVD playback - SOLVED [ In reply to ]
On 12/11/14 13:36, Jan Ceuleers wrote:
> On 11/12/2014 01:21 PM, Jan Ceuleers wrote:
>> My audio setup (summarised) is as follows; if you need further info
>> please ask:
>>
>> - ALSA:hdmi:CARD=Intel,DEV=1
>> - Stereo speaker configuration
>
> I have solved this myself by (lucky shot in the dark) setting the
> "Stereo PCM Only" flag in the Advanced Audio Settings. All three use
> cases (recordings, music, DVD) now work.

Hi Jan,

Good to hear you got it working! I had a feeling it would have
something to do with surround sound AC3 tracks or similar as it's usual
to have them on DVDs and less usual on TV broadcasts (not that uncommon,
but just less usual). I have to admit that I wasn't aware of/had
forgotten about that setting, though.

> I will add this to the wiki.

Thanks!

Richard.
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org