Mailing List Archive

Mythtv Daylight Saving Time Change Did Not Take Effect
Hi All-

I am in the US running .24.2-fixes with schedules direct with 1 lineup for
over the air broadcast. Today, I just noticed that for the last 2 days
(since Sunday) my recordings were off by 1 hour due to the daylight savings
time change. It seemed to fix itself after Tuesday. Running a
mythfilldatabase --refresh-today fixed today's listings. Has this happened
to others? I saw that in past years it has happend to some folks using EIT
scan.

I just checked and saw that I have the "Perform EIT Scan" ticked in the
Video Source Setup screen. Would this be the culprit? I am not sure why I
have that ticked, so I will uncheck it. Any other ideas why this happens
and what I can to do so that it will not happen next time?

Thanks for all the help!

Andrew
Re: Mythtv Daylight Saving Time Change Did Not Take Effect [ In reply to ]
On 13/03/2012 3:31 p.m., Andrew McCauley wrote:
> Hi All-
>
> I am in the US running .24.2-fixes with schedules direct with 1 lineup
> for over the air broadcast. Today, I just noticed that for the last 2
> days (since Sunday) my recordings were off by 1 hour due to the daylight
> savings time change. It seemed to fix itself after Tuesday. Running a
> mythfilldatabase --refresh-today fixed today's listings. Has this
> happened to others? I saw that in past years it has happend to some
> folks using EIT scan.
>
> I just checked and saw that I have the "Perform EIT Scan" ticked in the
> Video Source Setup screen. Would this be the culprit? I am not sure
> why I have that ticked, so I will uncheck it. Any other ideas why this
> happens and what I can to do so that it will not happen next time?

This happens for me also (using the older 0.23.1.201000710-1) in the
first 12 hours following the daylight change, as I recall it happens
both ways, sometime thereafter it self corrects. Some of my national
peers report it did not happen however I don't recall them being
specific about testing in the 1st 12 hours.
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://www.mythtv.org/mailman/listinfo/mythtv-users
Re: Mythtv Daylight Saving Time Change Did Not Take Effect [ In reply to ]
On Tue, Mar 13, 2012, at 04:28 PM, tortise wrote:
> This happens for me also (using the older 0.23.1.201000710-1) in the
> first 12 hours following the daylight change, as I recall it happens
> both ways, sometime thereafter it self corrects. Some of my national
> peers report it did not happen however I don't recall them being
> specific about testing in the 1st 12 hours.

Mine worked probably right at 2am, but I have a manual record at 7am
that went off without a hitch, and no issues the rest of the time...
Using .23 as well...
--
Kris B.
krisbee@krisbee.com

_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://www.mythtv.org/mailman/listinfo/mythtv-users
Re: Mythtv Daylight Saving Time Change Did Not Take Effect [ In reply to ]
> Date: Tue, 13 Mar 2012 16:28:53 +1300
> From: tortise <tortise@paradise.net.nz>
> Subject: Re: [mythtv-users] Mythtv Daylight Saving Time Change Did Not
> Take Effect
> To: mythtv-users@mythtv.org
>
> On 13/03/2012 3:31 p.m., Andrew McCauley wrote:
> > Hi All-
> >
> > I am in the US running .24.2-fixes with schedules direct with 1 lineup
> > for over the air broadcast. Today, I just noticed that for the last 2
> > days (since Sunday) my recordings were off by 1 hour due to the daylight
> > savings time change. It seemed to fix itself after Tuesday. Running a
> > mythfilldatabase --refresh-today fixed today's listings. Has this
> > happened to others? I saw that in past years it has happend to some
> > folks using EIT scan.
> >
> > I just checked and saw that I have the "Perform EIT Scan" ticked in the
> > Video Source Setup screen. Would this be the culprit? I am not sure
> > why I have that ticked, so I will uncheck it. Any other ideas why this
> > happens and what I can to do so that it will not happen next time?
>
> This happens for me also (using the older 0.23.1.201000710-1) in the
> first 12 hours following the daylight change, as I recall it happens
> both ways, sometime thereafter it self corrects. Some of my national
> peers report it did not happen however I don't recall them being
> specific about testing in the 1st 12 hours.

With the MythTV package supplied with Mageia 1,
0.24.1-20111019.0.1.mga1, it affected my recordings nearly 24
hours after the change. Sunday evening, it erroneously started
recording at 9pm for a 10pm program. In my case, fortunately, I
have a manual schedule covering the same time for just such a
contingency, so I watched that recording instead of the one
recorded at the same time.

Robert
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://www.mythtv.org/mailman/listinfo/mythtv-users
Re: Mythtv Daylight Saving Time Change Did Not Take Effect [ In reply to ]
> Date: Tue, 13 Mar 2012 18:34:56 -0700
> To: mythtv-users@mythtv.org
> From: rm.riches@jacob21819.net
> Subject: Re: [mythtv-users] Mythtv Daylight Saving Time Change Did Not Take Effect
>
> > Date: Tue, 13 Mar 2012 16:28:53 +1300
> > From: tortise <tortise@paradise.net.nz>
> > Subject: Re: [mythtv-users] Mythtv Daylight Saving Time Change Did Not
> > Take Effect
> > To: mythtv-users@mythtv.org
> >
> > On 13/03/2012 3:31 p.m., Andrew McCauley wrote:
> > > Hi All-
> > >
> > > I am in the US running .24.2-fixes with schedules direct with 1 lineup
> > > for over the air broadcast. Today, I just noticed that for the last 2
> > > days (since Sunday) my recordings were off by 1 hour due to the daylight
> > > savings time change. It seemed to fix itself after Tuesday. Running a
> > > mythfilldatabase --refresh-today fixed today's listings. Has this
> > > happened to others? I saw that in past years it has happend to some
> > > folks using EIT scan.
> > >
> > > I just checked and saw that I have the "Perform EIT Scan" ticked in the
> > > Video Source Setup screen. Would this be the culprit? I am not sure
> > > why I have that ticked, so I will uncheck it. Any other ideas why this
> > > happens and what I can to do so that it will not happen next time?
> >
> > This happens for me also (using the older 0.23.1.201000710-1) in the
> > first 12 hours following the daylight change, as I recall it happens
> > both ways, sometime thereafter it self corrects. Some of my national
> > peers report it did not happen however I don't recall them being
> > specific about testing in the 1st 12 hours.
>
> With the MythTV package supplied with Mageia 1,
> 0.24.1-20111019.0.1.mga1, it affected my recordings nearly 24
> hours after the change. Sunday evening, it erroneously started
> recording at 9pm for a 10pm program. In my case, fortunately, I
> have a manual schedule covering the same time for just such a
> contingency, so I watched that recording instead of the one
> recorded at the same time.
>
> Robert

Almost certainly the behavior you experienced can be
traced to having "Perform EIT Scan" checked. This past fall, last
spring, etc., I experienced the same scenario with a BE that received EPG data
from Schedules Direct but also had EIT scanning enabled. I would have 24 hours
of EPG data one hour off but as time moved forward, the corrupted EPG times
also kept moving forward.

I ended up having to dump all of the EPG data from the
database, disabling EIT scanning and manually running mythfilldatabase. Since then,
the problem has NOT reappeared.
~Christian


> _______________________________________________
> mythtv-users mailing list
> mythtv-users@mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users