Mailing List Archive

Mythbuntu 10.10 lost LIRC support
MythTV,

I just upgraded to Mythbuntu 10.10, and while most things seem to be
working fine, my Hauppauge PVR-150 remote control no longer seems to be
working.

So far as I can tell, all the drivers and configuration files that I had
before the upgrade are still in place.

$ sudo /etc/init.d/lirc restart
[sudo] password for media:
* Stopping remote control daemon(s):
LIRC [ OK ]
* Loading LIRC
modules [ OK ]
* Starting remote control daemon(s) :
LIRC [ OK ]

However, when I have MythTV front end up and running, it simply doesn't
respond at all.

Any suggestions on how I can troubleshoot and repair this problem?

Any advice would be much appreciated.

--
Dave M G
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
On Sun, Oct 10, 2010 at 3:07 PM, Dave M G <martin@autotelic.com> wrote:
>  MythTV,
>
> I just upgraded to Mythbuntu 10.10, and while most things seem to be working
> fine, my Hauppauge PVR-150 remote control no longer seems to be working.
>
> So far as I can tell, all the drivers and configuration files that I had
> before the upgrade are still in place.
>
> $ sudo /etc/init.d/lirc restart
> [sudo] password for media:
>  * Stopping remote control daemon(s): LIRC                               [
> OK ]
>  * Loading LIRC modules                                                  [
> OK ]
>  * Starting remote control daemon(s) : LIRC                              [
> OK ]
>
> However, when I have MythTV front end up and running, it simply doesn't
> respond at all.
>
> Any suggestions on how I can troubleshoot and repair this problem?
>
> Any advice would be much appreciated.

If you do a dmesg, do you see a kernel oops with lirc_core? I have a
test network here, and just abandoned 2.6.25 kernels due to lirc..

It is (I guess) nice they want it included in the kernel, but it is
clearly having it's troubles...
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
Greg,

Thank you for responding.

> If you do a dmesg, do you see a kernel oops with lirc_core?

In dmesg, the only things I can see that seem to be related to my remote
control are the following lines:

[ 24.191284] tuner-simple 0-0061: creating new instance
[ 24.191292] tuner-simple 0-0061: type set to 50 (TCL 2002N)
[ 24.193129] ivtv0: Registered device video0 for encoder MPG (4096 kB)
[ 24.193299] ivtv0: Registered device video32 for encoder YUV (2048 kB)
[ 24.193435] ivtv0: Registered device vbi0 for encoder VBI (1024 kB)
[ 24.193565] ivtv0: Registered device video24 for encoder PCM (320 kB)
[ 24.193570] ivtv0: Initialized card: Hauppauge WinTV PVR-150
[ 24.195080] ivtv: End initialization
...
[ 28.715245] lirc_dev: IR Remote Control driver registered, major 250
[ 28.721107] lirc_i2c: module is from the staging directory, the
quality is unknown, you have been warned.

Does anyone have any other suggestions?

--
Dave M G

_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
On 10/10/2010 4:07 PM, Dave M G wrote:
> MythTV,
>
> I just upgraded to Mythbuntu 10.10, and while most things seem to be
> working fine, my Hauppauge PVR-150 remote control no longer seems to
> be working.
>
> So far as I can tell, all the drivers and configuration files that I
> had before the upgrade are still in place.
>
> $ sudo /etc/init.d/lirc restart
> [sudo] password for media:
> * Stopping remote control daemon(s):
> LIRC [ OK ]
> * Loading LIRC
> modules [ OK ]
> * Starting remote control daemon(s) :
> LIRC [ OK ]
>
> However, when I have MythTV front end up and running, it simply
> doesn't respond at all.
>
> Any suggestions on how I can troubleshoot and repair this problem?
>
> Any advice would be much appreciated.
>
If your remote is serial, make sure that you have /etc/serial.conf and
that it has:

/dev/ttyS0 uart none

in it. I had a similar problem a few weeks ago
(http://www.gossamer-threads.com/lists/mythtv/users/453031?search_string=mythbuntu%20lirc;#453031)
when I upgraded to Mythbuntu 10.10. I have an IR receiver from
irblaster.info and its a serial device on COM1. I've also had issues in
the past with the include statement in the /etc/lircmd.conf file. I
needs to have double quotes around the path and file following the
include statement.

Hope this helps!
Harry

_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
MythTV users,

Just some additional information.

If I run "irw" at the command line, I see no output when I click the
buttons on the remote.

I also tried running this command:

sudo apt-get install lirc-modules-source

... however, it did not change anything.

--
Dave M G
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
On Sun, Oct 10, 2010 at 3:40 PM, Dave M G <martin@autotelic.com> wrote:
> MythTV users,
>
> Just some additional information.
>
> If I run "irw" at the command line, I see no output when I click the buttons
> on the remote.
>
> I also tried running this command:
>
> sudo apt-get install lirc-modules-source
>
> ... however, it did not change anything.
>
From what I have read, that is bad.. make sure you aptitude purge the
lirc-modules-source package.. The modules are now shipped with the
kernel. You ahouls have a mceusb kernel loaded..

Do a `modprobe | grep ir` and see what show up..
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
Greg,

Thank you for replying.

>> make sure you aptitude purge the lirc-modules-source package..

Okay, I have purged the package.

> Do a `modprobe | grep ir` and see what show up..

$ modprobe | grep ir
Usage: modprobe [-v] [-V] [-C config-file] [-d <dirname> ] [-n] [-i]
[-q] [-b] [-o <modname>] [ --dump-modversions ] <modname> [parameters...]
modprobe -r [-n] [-i] [-v] <modulename> ...
modprobe -l -t <dirname> [ -a <modulename> ...]

I looked up "modprobe" on Google, and it seems I need to name a module
to probe for... what should I be looking for?

--
Dave M G
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
On Sun, Oct 10, 2010 at 10:20 PM, Dave M G <martin@autotelic.com> wrote:
> Greg,
>
> Thank you for replying.
>
>>>  make sure you aptitude purge the lirc-modules-source package..
>
> Okay, I have purged the package.
>
>> Do a `modprobe | grep ir` and see what show up..
>
> $ modprobe | grep ir
> Usage: modprobe [-v] [-V] [-C config-file] [-d <dirname> ] [-n] [-i] [-q]
> [-b] [-o <modname>] [ --dump-modversions ] <modname> [parameters...]
> modprobe -r [-n] [-i] [-v] <modulename> ...
> modprobe -l -t <dirname> [ -a <modulename> ...]
>
> I looked up "modprobe" on Google, and it seems I need to name a module to
> probe for... what should I be looking for?
>

Sorry replace modprobe with lsmod - it's football sunday :)
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
Greg,

Thank you for replying, especially during football.

Here is the output from lsmod:

$ lsmod | grep ir
lirc_i2c 5825 0
lirc_dev 9393 1 lirc_i2c
nf_conntrack_irc 3348 0
nf_conntrack 63258 7
ipt_MASQUERADE,nf_conntrack_irc,nf_conntrack_ftp,xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4

Does this say anything that points to a problem or solution?

--
Dave M G
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
On Sun, Oct 10, 2010 at 10:42 PM, Dave M G <martin@autotelic.com> wrote:
> Greg,
>
> Thank you for replying, especially during football.
>
> Here is the output from lsmod:
>
> $ lsmod | grep ir
> lirc_i2c                5825  0
> lirc_dev                9393  1 lirc_i2c
> nf_conntrack_irc        3348  0
> nf_conntrack           63258  7
> ipt_MASQUERADE,nf_conntrack_irc,nf_conntrack_ftp,xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4
>
> Does this say anything that points to a problem or solution?

can you do that again after you purge lirc-modules-source and reboot..
Those module names are from the older 0.8.6 packages.. If you are
runnign 10.10, the names should reflect ir_core, ir_{etc...}..

It looks like you still have modules loaded from the
lirc-modules-source package. I am not too sure what happens when you
actually install that package either..?

Make sure you have the lirc-modules-source package removed, and reboot
and see what modules get loaded.

-Greg
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
On Oct 10, 2010, at 11:49 PM, Greg Oliver <oliver.greg@gmail.com> wrote:

> On Sun, Oct 10, 2010 at 10:42 PM, Dave M G <martin@autotelic.com> wrote:
>> Greg,
>>
>> Thank you for replying, especially during football.
>>
>> Here is the output from lsmod:
>>
>> $ lsmod | grep ir
>> lirc_i2c 5825 0
>> lirc_dev 9393 1 lirc_i2c
>> nf_conntrack_irc 3348 0
>> nf_conntrack 63258 7
>> ipt_MASQUERADE,nf_conntrack_irc,nf_conntrack_ftp,xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4
>>
>> Does this say anything that points to a problem or solution?
>
> can you do that again after you purge lirc-modules-source and reboot..
> Those module names are from the older 0.8.6 packages.. If you are
> runnign 10.10, the names should reflect ir_core, ir_{etc...}..

Not quite. There's still lirc_dev and lirc_i2c that have been merged in the kernel as well. The ir-core parts are for drivers that have been ported, which does not include lirc_i2c.

I suspect the problem is lirc_i2c trying to be bound to a zilog chip, which is no longer possible (i.e., try lirc_zilog).

--
Jarod Wilson
jarod@wilsonet.com
>
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
On Sun, Oct 10, 2010 at 11:11 PM, Jarod Wilson <jarod@wilsonet.com> wrote:
> On Oct 10, 2010, at 11:49 PM, Greg Oliver <oliver.greg@gmail.com> wrote:
>
>> On Sun, Oct 10, 2010 at 10:42 PM, Dave M G <martin@autotelic.com> wrote:
>>> Greg,
>>>
>>> Thank you for replying, especially during football.
>>>
>>> Here is the output from lsmod:
>>>
>>> $ lsmod | grep ir
>>> lirc_i2c                5825  0
>>> lirc_dev                9393  1 lirc_i2c
>>> nf_conntrack_irc        3348  0
>>> nf_conntrack           63258  7
>>> ipt_MASQUERADE,nf_conntrack_irc,nf_conntrack_ftp,xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4
>>>
>>> Does this say anything that points to a problem or solution?
>>
>> can you do that again after you purge lirc-modules-source and reboot..
>> Those module names are from the older 0.8.6 packages..  If you are
>> runnign 10.10, the names should reflect ir_core, ir_{etc...}..
>
> Not quite. There's still lirc_dev and lirc_i2c that have been merged in the kernel as well. The ir-core parts are for drivers that have been ported, which does not include lirc_i2c.
>
> I suspect the problem is lirc_i2c trying to be bound to a zilog chip, which is no longer possible (i.e., try lirc_zilog).
>

I was hoping you would chime in!

I know personally, I am going to kernels <=2.6.34 until the kinks are
worked out :)

-Greg
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
Greg, Jarod,

Thank you for replying.

I have purged the lirc-modules-source package and rebooted, but the
situation remains the same.

I'm not sure what "try lirc_zilog" means - it doesn't seem to be a command.

The discussion is getting a little beyond me... is there something
specific I can be doing to try and further diagnose or solve the problem?

Thank you for your advice.

--
Dave M G
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
On Sun, Oct 10, 2010 at 11:31 PM, Dave M G <martin@autotelic.com> wrote:
> Greg, Jarod,
>
> Thank you for replying.
>
> I have purged the lirc-modules-source package and rebooted, but the
> situation remains the same.
>
> I'm not sure what "try lirc_zilog" means - it doesn't seem to be a command.
>
> The discussion is getting a little beyond me... is there something
> specific I can be doing to try and further diagnose or solve the problem?
>
> Thank you for your advice.

Advice - :)

go back to 10.4 until the kinks are ironed out.. :)

Sorry!
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
On Oct 11, 2010, at 12:16 AM, Greg Oliver wrote:

> On Sun, Oct 10, 2010 at 11:11 PM, Jarod Wilson <jarod@wilsonet.com> wrote:
>> On Oct 10, 2010, at 11:49 PM, Greg Oliver <oliver.greg@gmail.com> wrote:
>>
>>> On Sun, Oct 10, 2010 at 10:42 PM, Dave M G <martin@autotelic.com> wrote:
>>>> Greg,
>>>>
>>>> Thank you for replying, especially during football.
>>>>
>>>> Here is the output from lsmod:
>>>>
>>>> $ lsmod | grep ir
>>>> lirc_i2c 5825 0
>>>> lirc_dev 9393 1 lirc_i2c
>>>> nf_conntrack_irc 3348 0
>>>> nf_conntrack 63258 7
>>>> ipt_MASQUERADE,nf_conntrack_irc,nf_conntrack_ftp,xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4
>>>>
>>>> Does this say anything that points to a problem or solution?
>>>
>>> can you do that again after you purge lirc-modules-source and reboot..
>>> Those module names are from the older 0.8.6 packages.. If you are
>>> runnign 10.10, the names should reflect ir_core, ir_{etc...}..
>>
>> Not quite. There's still lirc_dev and lirc_i2c that have been merged in the kernel as well. The ir-core parts are for drivers that have been ported, which does not include lirc_i2c.
>>
>> I suspect the problem is lirc_i2c trying to be bound to a zilog chip, which is no longer possible (i.e., try lirc_zilog).
>>
>
> I was hoping you would chime in!
>
> I know personally, I am going to kernels <=2.6.34 until the kinks are
> worked out :)

I sent mail to a few Ubuntu kernel/lirc/myth people today along with links to patches I thought they should pull into the Ubuntu kernel to improve the IR experience. There's been a fair amount of ongoing activity upstream. Still not certain what the OP's issue here is though...

--
Jarod Wilson
jarod@wilsonet.com
Re: Mythbuntu 10.10 lost LIRC support [ In reply to ]
On Mon, Oct 11, 2010 at 5:25 PM, Jarod Wilson <jarod@wilsonet.com> wrote:
> On Oct 11, 2010, at 12:16 AM, Greg Oliver wrote:
>
>> On Sun, Oct 10, 2010 at 11:11 PM, Jarod Wilson <jarod@wilsonet.com> wrote:
>>> On Oct 10, 2010, at 11:49 PM, Greg Oliver <oliver.greg@gmail.com> wrote:
>>>
>>>> On Sun, Oct 10, 2010 at 10:42 PM, Dave M G <martin@autotelic.com> wrote:
>>>>> Greg,
>>>>>
>>>>> Thank you for replying, especially during football.
>>>>>
>>>>> Here is the output from lsmod:
>>>>>
>>>>> $ lsmod | grep ir
>>>>> lirc_i2c                5825  0
>>>>> lirc_dev                9393  1 lirc_i2c
>>>>> nf_conntrack_irc        3348  0
>>>>> nf_conntrack           63258  7
>>>>> ipt_MASQUERADE,nf_conntrack_irc,nf_conntrack_ftp,xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4
>>>>>
>>>>> Does this say anything that points to a problem or solution?
>>>>
>>>> can you do that again after you purge lirc-modules-source and reboot..
>>>> Those module names are from the older 0.8.6 packages..  If you are
>>>> runnign 10.10, the names should reflect ir_core, ir_{etc...}..
>>>
>>> Not quite. There's still lirc_dev and lirc_i2c that have been merged in the kernel as well. The ir-core parts are for drivers that have been ported, which does not include lirc_i2c.
>>>
>>> I suspect the problem is lirc_i2c trying to be bound to a zilog chip, which is no longer possible (i.e., try lirc_zilog).
>>>
>>
>> I was hoping you would chime in!
>>
>> I know personally, I am going to kernels <=2.6.34 until the kinks are
>> worked out  :)
>
> I sent mail to a few Ubuntu kernel/lirc/myth people today along with links to patches I thought they should pull into the Ubuntu kernel to improve the IR experience. There's been a fair amount of ongoing activity upstream. Still not certain what the OP's issue here is though...

Hopefully, this can help a few people better understand what's going on:

http://wilsonet.com/?page_id=95

Will update it as more information comes to light.

--
Jarod Wilson
jarod@wilsonet.com
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users