Mailing List Archive

channel icon download fails
When I try to download channel icons via mythtv-setup I am getting the
following errors ...

2010-06-27 14:38:07.482 HttpComms::Timeout for url:
http://lyngsat-logo.com/logo/tv/aa/ae_us.jpg
2010-06-27 14:38:07.501 Server returned an error status code 0 for url:
http://lyngsat-logo.com/logo/tv/aa/ae_us.jpg

Navigating to the link in a browser works fine.
Re: channel icon download fails [ In reply to ]
On Sun, Jun 27, 2010 at 11:48 AM, James Orr <james.orr7@gmail.com> wrote:

> When I try to download channel icons via mythtv-setup I am getting the
> following errors ...
>
> 2010-06-27 14:38:07.482 HttpComms::Timeout for url:
> http://lyngsat-logo.com/logo/tv/aa/ae_us.jpg
> 2010-06-27 14:38:07.501 Server returned an error status code 0 for url:
> http://lyngsat-logo.com/logo/tv/aa/ae_us.jpg
>
> Navigating to the link in a browser works fine.
>

Today, I'm getting the same issue. It worked fine for me a couple weeks
back, but I've had to completely reinstall, and here we are. And of course,
the icons won't show. This is for any that it couldn't find by a normal
search.
Re: channel icon download fails [ In reply to ]
On Sun, Jun 27, 2010 at 8:12 PM, Gavin Hurlbut <gjhurlbu@gmail.com> wrote:

> On Sun, Jun 27, 2010 at 11:48 AM, James Orr <james.orr7@gmail.com> wrote:
>
>> When I try to download channel icons via mythtv-setup I am getting the
>> following errors ...
>>
>> 2010-06-27 14:38:07.482 HttpComms::Timeout for url:
>> http://lyngsat-logo.com/logo/tv/aa/ae_us.jpg
>> 2010-06-27 14:38:07.501 Server returned an error status code 0 for url:
>> http://lyngsat-logo.com/logo/tv/aa/ae_us.jpg
>>
>> Navigating to the link in a browser works fine.
>>
>
> Today, I'm getting the same issue. It worked fine for me a couple weeks
> back, but I've had to completely reinstall, and here we are. And of course,
> the icons won't show. This is for any that it couldn't find by a normal
> search.
>

As an update... I went and tweaked the code a bit. Seems with a 30s timeout
in place, I am now getting icons. I wonder if lyngsat-logo.com isn't now
throttling mythtv users perhaps? That would be unfortunate. I'll look into
the code a bit more, and perhaps commit the change to trunk with a 45s
timeout.
Re: channel icon download fails [ In reply to ]
On Sun, Jun 27, 2010 at 8:44 PM, Gavin Hurlbut <gjhurlbu@gmail.com> wrote:

> On Sun, Jun 27, 2010 at 8:12 PM, Gavin Hurlbut <gjhurlbu@gmail.com> wrote:
>
>> On Sun, Jun 27, 2010 at 11:48 AM, James Orr <james.orr7@gmail.com> wrote:
>>
>>> When I try to download channel icons via mythtv-setup I am getting the
>>> following errors ...
>>>
>>> 2010-06-27 14:38:07.482 HttpComms::Timeout for url:
>>> http://lyngsat-logo.com/logo/tv/aa/ae_us.jpg
>>> 2010-06-27 14:38:07.501 Server returned an error status code 0 for url:
>>> http://lyngsat-logo.com/logo/tv/aa/ae_us.jpg
>>>
>>> Navigating to the link in a browser works fine.
>>>
>>
OK, here's the scoop. It seems that the URLs we fetch from return a 301
(Permanent Redirect). This means we hit the server twice. That's normally
OK, *BUT* mythtv-setup doesn't cache DNS lookups, so it is hitting your DNS
resolver (as setup by /etc/resolv.conf) repeatedly. IF your DNS lookups are
slow, it takes forever, and the logo download will exceed the 10s which
seems to be the default timeout in the code.

So... I am considering changing the timeout to 20s, but additionally, use
faster DNS servers. If you are up for running your own caching server, that
will likely be the best over-all, but otherwise, you are likely best off
pointing /etc/resolv.conf to google's public DNS caches (8.8.8.8 and
8.8.4.4).
Re: channel icon download fails [ In reply to ]
2010/6/28 Gavin Hurlbut <gjhurlbu@gmail.com>:
>>>> 2010-06-27 14:38:07.501 Server returned an error status code 0 for url:
>>>> http://lyngsat-logo.com/logo/tv/aa/ae_us.jpg
>>>> Navigating to the link in a browser works fine.

I'm getting a similar error for the same icon download step, but in my
rewritten XMLTV files
I am using local file:///path/to/channel.jpg urls. And yes of course I
checked the URLs with a browser.

Is the code capable to deal with local icons?


Martin
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: channel icon download fails [ In reply to ]
Gavin Hurlbut wrote:
> On Sun, Jun 27, 2010 at 8:44 PM, Gavin Hurlbut <gjhurlbu@gmail.com> wrote:
>
>> On Sun, Jun 27, 2010 at 8:12 PM, Gavin Hurlbut <gjhurlbu@gmail.com> wrote:
>>
>>> On Sun, Jun 27, 2010 at 11:48 AM, James Orr <james.orr7@gmail.com> wrote:
>>>
>>>> When I try to download channel icons via mythtv-setup I am getting the
>>>> following errors ...
>>>>
>>>> 2010-06-27 14:38:07.482 HttpComms::Timeout for url:
>>>> http://lyngsat-logo.com/logo/tv/aa/ae_us.jpg
>>>> 2010-06-27 14:38:07.501 Server returned an error status code 0 for url:
>>>> http://lyngsat-logo.com/logo/tv/aa/ae_us.jpg
>>>>
>>>> Navigating to the link in a browser works fine.
>>>>
> OK, here's the scoop. It seems that the URLs we fetch from return a 301
> (Permanent Redirect). This means we hit the server twice. That's normally
> OK, *BUT* mythtv-setup doesn't cache DNS lookups, so it is hitting your DNS
> resolver (as setup by /etc/resolv.conf) repeatedly. IF your DNS lookups are
> slow, it takes forever, and the logo download will exceed the 10s which
> seems to be the default timeout in the code.
>
> So... I am considering changing the timeout to 20s, but additionally, use
> faster DNS servers. If you are up for running your own caching server, that
> will likely be the best over-all, but otherwise, you are likely best off
> pointing /etc/resolv.conf to google's public DNS caches (8.8.8.8 and
> 8.8.4.4).
>
Since there are significant numbers of Myth users hitting these icons, is it
worth either mythtv.org or Schedules Direct (or similar) mirroring these files?
Or would that make the Gods of Copyright/Trademarks/Patents/Whatever very angry?

--

Mike Perkins

_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Channel Icon Download fails [ In reply to ]
On Wed, Aug 9, 2017 at 12:53 PM, Swanseasurfing
<swanseasurfing@gmail.com> wrote:

> Did the Apache server configuration of www.lyngsat-logo.com change?

lyngsat has changed their terms of service
(this was discussed on list some months ago),
which no longer allows applications to pull
logos. Their site, their terms.

As I recall, you can manually (going to the
lyngsat site) download logos one at a time
(and then add them manually to your system).

Alternatives have been considered, and
have been worked a bit, but nothing else
is currently available.

If you are using a guide service (such as
Schedules Direct), you may also have a
source of curated logos available.
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org