Mailing List Archive

Cannot change tuner using "Y"
I'm trying to change my tuner (got 2 tuners on a PVR-500) with "Y"
when watching TV. This fails, instead I get the name of the actual
tuner showing up in the left corner for about 2 seconds. If I however
press "M" and change the tuner manually this works.

I see no errors in debug. Is this maybe due to some priority setting I
made or just simply a bug? (Y is mapped according to Myth)

Also, it seems that Tuner #2 always is the default when watching
anything. Why is not Tuner #1 choosen first (even if there is no
scheduled recording)? Is this due to in which order I set up the
tuners on backend. I remember doing Tuner #1 first and then Tuner #2.

Regards Seb
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Cannot change tuner using "Y" [ In reply to ]
On Wed, Jul 16, 2008 at 12:31:02PM +0200, Sebastian Buks wrote:
> I'm trying to change my tuner (got 2 tuners on a PVR-500) with "Y"
> when watching TV. This fails, instead I get the name of the actual
> tuner showing up in the left corner for about 2 seconds. If I however
> press "M" and change the tuner manually this works.

That's strange.

> Also, it seems that Tuner #2 always is the default when watching
> anything. Why is not Tuner #1 choosen first (even if there is no
> scheduled recording)? Is this due to in which order I set up the
> tuners on backend. I remember doing Tuner #1 first and then Tuner #2.

That's normal. The last tuner you set up is the first default
for LiveTV. If you'd like to switch it:

- stop the backend
- in mythtv-setup, delete all tuners
- then recreate them in the order you want
- remember to re-associate them with program sources
- restart the backend.

-dsr-

--
http://tao.merseine.nu/~dsr/eula.html is hereby incorporated by reference.

When freedom gets lots of exercise, it protects itself.
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Cannot change tuner using "Y" [ In reply to ]
Sebastian Buks wrote:
> I'm trying to change my tuner (got 2 tuners on a PVR-500) with "Y"
> when watching TV. This fails, instead I get the name of the actual
> tuner showing up in the left corner for about 2 seconds. If I however
> press "M" and change the tuner manually this works.
>
> I see no errors in debug. Is this maybe due to some priority setting I
> made or just simply a bug? (Y is mapped according to Myth)
>

Unfortunately its broken in 0.21-fixes. Not sure what the status is on
trunk. It would seem that not too many people use this feature as its
only been reported a few times. I rarely used it myself. The official
word that I heard from one of the devs is to use the menu and select the
input you want. Feel free to take a crack at finding this bug as it
would be nice to be able to simply press Y and switch to my SD source.

William
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Cannot change tuner using "Y" [ In reply to ]
On 07/16/2008 05:28 PM, William wrote:
> Sebastian Buks wrote:
>
>> I'm trying to change my tuner (got 2 tuners on a PVR-500) with "Y"
>> when watching TV. This fails, instead I get the name of the actual
>> tuner showing up in the left corner for about 2 seconds. If I however
>> press "M" and change the tuner manually this works.
>>
>> I see no errors in debug. Is this maybe due to some priority setting I
>> made or just simply a bug? (Y is mapped according to Myth)
> Unfortunately its broken in 0.21-fixes. Not sure what the status is on
> trunk. It would seem that not too many people use this feature as its
> only been reported a few times. I rarely used it myself. The official
> word that I heard from one of the devs is to use the menu and select the
> input you want. Feel free to take a crack at finding this bug as it
> would be nice to be able to simply press Y and switch to my SD source.

Uh, really? Are you sure you all didn't just forget to map a key to
allow it to work with the new (post-multirec) key bindings structure?

There is no longer any default mapping for NEXTCARD (which used to be
SWITCHCARDS) nor TOGGLEINPUTS.

http://www.gossamer-threads.com/lists/mythtv/commits/279327#279327

Mike
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Cannot change tuner using "Y" [ In reply to ]
> Date: Wed, 16 Jul 2008 17:28:21 -0400
> From: William <william_munson@comcast.net>
> Subject: Re: [mythtv-users] Cannot change tuner using "Y"
> To: Discussion about mythtv <mythtv-users@mythtv.org>
> Message-ID: <487E67F5.2090309@comcast.net>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> Sebastian Buks wrote:
>> I'm trying to change my tuner (got 2 tuners on a PVR-500) with "Y"
>> when watching TV. This fails, instead I get the name of the actual
>> tuner showing up in the left corner for about 2 seconds. If I however
>> press "M" and change the tuner manually this works.
>>
>> I see no errors in debug. Is this maybe due to some priority
>> setting I
>> made or just simply a bug? (Y is mapped according to Myth)
>>
>
> Unfortunately its broken in 0.21-fixes. Not sure what the status is
> on
> trunk. It would seem that not too many people use this feature as its
> only been reported a few times. I rarely used it myself. The official
> word that I heard from one of the devs is to use the menu and select
> the
> input you want. Feel free to take a crack at finding this bug as it
> would be nice to be able to simply press Y and switch to my SD source.

Oh, do you know if any other commands are broken aswell. I seem to
have problems forwarding using ">" mapped to FF on my remote (and
remote does work and is configured right). Has a bug been filed on
this issue?

_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Cannot change tuner using "Y" [ In reply to ]
2008/7/17 Sebastian Buks <sebastianbuks@yahoo.com>:
>> Date: Wed, 16 Jul 2008 17:28:21 -0400
>> From: William <william_munson@comcast.net>
>> Subject: Re: [mythtv-users] Cannot change tuner using "Y"
>> To: Discussion about mythtv <mythtv-users@mythtv.org>
>> Message-ID: <487E67F5.2090309@comcast.net>
>> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>>
>> Sebastian Buks wrote:
>>> I'm trying to change my tuner (got 2 tuners on a PVR-500) with "Y"
>>> when watching TV. This fails, instead I get the name of the actual
>>> tuner showing up in the left corner for about 2 seconds. If I however
>>> press "M" and change the tuner manually this works.
>>>
>>> I see no errors in debug. Is this maybe due to some priority
>>> setting I
>>> made or just simply a bug? (Y is mapped according to Myth)
>>>
>>
>> Unfortunately its broken in 0.21-fixes. Not sure what the status is
>> on
>> trunk. It would seem that not too many people use this feature as its
>> only been reported a few times. I rarely used it myself. The official
>> word that I heard from one of the devs is to use the menu and select
>> the
>> input you want. Feel free to take a crack at finding this bug as it
>> would be nice to be able to simply press Y and switch to my SD source.
>
> Oh, do you know if any other commands are broken aswell. I seem to
> have problems forwarding using ">" mapped to FF on my remote (and
> remote does work and is configured right). Has a bug been filed on
> this issue?

Have you confirmed it by use of a keyboard?

Steve
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Cannot change tuner using "Y" [ In reply to ]
On 07/17/2008 08:42 AM, Steve Daniels wrote:
> 2008/7/17 Sebastian Buks
>> From: William
>>> Sebastian Buks wrote:
>>>
>>>> I'm trying to change my tuner (got 2 tuners on a PVR-500) with "Y"
>>>> when watching TV. This fails, instead I get the name of the actual
>>>> tuner showing up in the left corner for about 2 seconds. If I however
>>>> press "M" and change the tuner manually this works.
>>>>
>>>> I see no errors in debug. Is this maybe due to some priority
>>>> setting I
>>>> made or just simply a bug? (Y is mapped according to Myth)
>>> Unfortunately its broken in 0.21-fixes. Not sure what the status is
>>> on
>>> trunk. It would seem that not too many people use this feature as its
>>> only been reported a few times. I rarely used it myself. The official
>>> word that I heard from one of the devs is to use the menu and select
>>> the
>>> input you want. Feel free to take a crack at finding this bug as it
>>> would be nice to be able to simply press Y and switch to my SD source.
>>>
>> Oh, do you know if any other commands are broken aswell. I seem to
>> have problems forwarding using ">" mapped to FF on my remote (and
>> remote does work and is configured right). Has a bug been filed on
>> this issue?
> Have you confirmed it by use of a keyboard?

Have either of you read my post (
http://www.gossamer-threads.com/lists/mythtv/users/342223#342223 )?
Have either of you mapped a keybinding for NEXTCARD? I don't believe
there is a bug as it works fine on my system...

Seems to me it's a PEBRAS*.

Mike

*Problem Exists Between Remote and Sofa
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Cannot change tuner using "Y" [ In reply to ]
On Thu, Jul 17, 2008 at 9:51 PM, Michael T. Dean
<mtdean@thirdcontact.com> wrote:
> On 07/17/2008 08:42 AM, Steve Daniels wrote:
>> 2008/7/17 Sebastian Buks
>>> From: William
>>>> Sebastian Buks wrote:
>>>>
>>>>> I'm trying to change my tuner (got 2 tuners on a PVR-500) with "Y"
>>>>> when watching TV. This fails, instead I get the name of the actual
>>>>> tuner showing up in the left corner for about 2 seconds. If I however
>>>>> press "M" and change the tuner manually this works.
>>>>>
>>>>> I see no errors in debug. Is this maybe due to some priority
>>>>> setting I
>>>>> made or just simply a bug? (Y is mapped according to Myth)
>>>> Unfortunately its broken in 0.21-fixes. Not sure what the status is
>>>> on
>>>> trunk. It would seem that not too many people use this feature as its
>>>> only been reported a few times. I rarely used it myself. The official
>>>> word that I heard from one of the devs is to use the menu and select
>>>> the
>>>> input you want. Feel free to take a crack at finding this bug as it
>>>> would be nice to be able to simply press Y and switch to my SD source.
>>>>
>>> Oh, do you know if any other commands are broken aswell. I seem to
>>> have problems forwarding using ">" mapped to FF on my remote (and
>>> remote does work and is configured right). Has a bug been filed on
>>> this issue?
>> Have you confirmed it by use of a keyboard?
>
> Have either of you read my post (
> http://www.gossamer-threads.com/lists/mythtv/users/342223#342223 )?
> Have either of you mapped a keybinding for NEXTCARD? I don't believe
> there is a bug as it works fine on my system...
>
> Seems to me it's a PEBRAS*.
>
> Mike
>
> *Problem Exists Between Remote and Sofa
> _______________________________________________
> mythtv-users mailing list
> mythtv-users@mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>

Would you be so kind as to post instructions on how to make "C" and
"Y" work the way the instruction say they do? That would be a most
useful way to learn what you are talking about. I did read your post,
ikim*

Allen

* in case it matters.
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Re: Cannot change tuner using "Y" [ In reply to ]
On 07/18/2008 10:22 AM, Allen Edwards wrote:
> On Thu, Jul 17, 2008 at 9:51 PM, Michael T. Dean wrote:
>
>> Have either of you read my post (
>> http://www.gossamer-threads.com/lists/mythtv/users/342223#342223 )?
>> Have either of you mapped a keybinding for NEXTCARD? I don't believe
>> there is a bug as it works fine on my system...
>>
> Would you be so kind as to post instructions on how to make "C" and
> "Y" work the way the instruction say they do? That would be a most
> useful way to learn what you are talking about.

Choose a key that's not currently bound to anything. Go to
MythControls. Find the NEXTCARD mapping in the TV Playback context.
Map the chosen key to NEXTCARD. Return to LiveTV. Press the chosen
key. Enjoy.

I think the issue here is you're not understanding how C and Y are /now/
supposed to work. Generally, though, most users--especially analog TV
users--will just want the NEXTCARD binding (and won't need C and Y).
The only reason it's not bound by default is because adding new key
bindings tends to cause problems to anyone who has changed the default
key bindings, so unless some functionality is critical, the devs try not
to map a default binding.

For the short story:
http://www.gossamer-threads.com/lists/mythtv/users/322924#322924 . For
the rest of the story (ROTS):
http://www.gossamer-threads.com/lists/mythtv/users/322921#322921 and
http://www.gossamer-threads.com/lists/mythtv/users/322930#322930 (note
that the second ROTS post suggests how to re-map keys to make it work
more like you're used to).

Mike
_______________________________________________
mythtv-users mailing list
mythtv-users@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users