Mailing List Archive

Why did my remote control quit working?
Hi all-



My remote control with my PVR-150 was working great when I used the packaged
install (mythtv-suite). Then I decided I wanted to tweak some of the plugin
settings, so I decided to build from source.



I have built from source and got basically everything working like it used
to, but my remote control doesn't work with mythtv anymore.



When I compiled, the ./configure script reported "lirc support : yes"



I can still run my remote with irw, the messages are received correctly
(lircd is running).



I can also use the remote with irxevent piping the remote commands to
mythtv.



However, I'd really prefer to get native remote control support in mythtv so
I could use my existing lircrc file.



I searched the archive with nothing pointing directly to my problem.



Thoughts?



Any log files I should post to help the members of this great community to
figure out what's going on?



Eric.
Re: Why did my remote control quit working? [ In reply to ]
At 01:43 PM 10/28/2005, you wrote:
>Hi all-
>
>My remote control with my PVR-150 was working great when I used the
>packaged install (mythtv-suite). Then I decided I wanted to tweak
>some of the plugin settings, so I decided to build from source.
>
>I have built from source and got basically everything working like
>it used to, but my remote control doesn't work with mythtv anymore.
>
>When I compiled, the ./configure script reported "lirc support : yes"
>
>I can still run my remote with irw, the messages are received
>correctly (lircd is running).
>
>I can also use the remote with irxevent piping the remote commands to mythtv.
>
>However, I'd really prefer to get native remote control support in
>mythtv so I could use my existing lircrc file.
>
>I searched the archive with nothing pointing directly to my problem.
>
>Thoughts?
>
>Any log files I should post to help the members of this great
>community to figure out what's going on?
>
>Eric.

There are some reports that ivtv causes the remote to stop working
after a while. Does it come back for a short period if you reboot? On
the ivtv list there was a patch which basically puts in an IR reset
into the code. There are also patches to do the same with a once a
minute cron job. This might not be your case where you say it works with irw.
RE: Why did my remote control quit working? [ In reply to ]
At 01:43 PM 10/28/2005, you wrote:



Hi all-

My remote control with my PVR-150 was working great when I used the packaged
install (mythtv-suite). Then I decided I wanted to tweak some of the plugin
settings, so I decided to build from source.

I have built from source and got basically everything working like it used
to, but my remote control doesnt work with mythtv anymore.

When I compiled, the ./configure script reported lirc support : yes

I can still run my remote with irw, the messages are received correctly
(lircd is running).

I can also use the remote with irxevent piping the remote commands to
mythtv.

However, Id really prefer to get native remote control support in mythtv so
I could use my existing lircrc file.

I searched the archive with nothing pointing directly to my problem.

Thoughts?

Any log files I should post to help the members of this great community to
figure out whats going on?

Eric.


There are some reports that ivtv causes the remote to stop working after a
while. Does it come back for a short period if you reboot? On the ivtv list
there was a patch which basically puts in an IR reset into the code. There
are also patches to do the same with a once a minute cron job. This might
not be your case where you say it works with irw.





That is an interesting idea, but a couple things: Concerning reboot: it
makes no difference. The remote _always_ works with irw and irxevent, but
_never_ in mythtv. I did compile ivtv from source whereas before I was using
the pre-built binaries in the package install, so what you say is possible,
but since it works with irw always, I wouldn't think the problem is with the
driver. Other thoughts? TIA, Eric.
RE: Why did my remote control quit working? [ In reply to ]
At 02:40 PM 10/28/2005, you wrote:
>
>At 01:43 PM 10/28/2005, you wrote:
>
>Hi all-
>
>My remote control with my PVR-150 was working great when I used the
>packaged install (mythtv-suite). Then I decided I wanted to tweak
>some of the plugin settings, so I decided to build from source.
>
>I have built from source and got basically everything working like
>it used to, but my remote control doesnt work with mythtv anymore.
>
>When I compiled, the ./configure script reported lirc support : yes
>
>I can still run my remote with irw, the messages are received
>correctly (lircd is running).
>
>I can also use the remote with irxevent piping the remote commands to mythtv.
>
>However, Id really prefer to get native remote control support in
>mythtv so I could use my existing lircrc file.
>
>I searched the archive with nothing pointing directly to my problem.
>
>Thoughts?
>
>Any log files I should post to help the members of this great
>community to figure out whats going on?
>
>Eric.
>
>There are some reports that ivtv causes the remote to stop working
>after a while. Does it come back for a short period if you reboot?
>On the ivtv list there was a patch which basically puts in an IR
>reset into the code. There are also patches to do the same with a
>once a minute cron job. This might not be your case where you say it
>works with irw.
>
>
>That is an interesting idea, but a couple things: Concerning reboot:
>it makes no difference. The remote _always_ works with irw and
>irxevent, but _never_ in mythtv. I did compile ivtv from source
>whereas before I was using the pre-built binaries in the package
>install, so what you say is possible, but since it works with irw
>always, I wouldn't think the problem is with the driver. Other
>thoughts? TIA, Eric.

Well, the lircrc file is what controls the functionality away from
irw. Are you sure it didn't get corrupted/overwritten?
RE: Why did my remote control quit working? [ In reply to ]
_____

From: mythtv-users-bounces@mythtv.org
[mailto:mythtv-users-bounces@mythtv.org] On Behalf Of Jim Reith
Sent: Friday, October 28, 2005 1:51 PM
To: eric.brandt@pocketcad.com; Discussion about mythtv
Subject: RE: [mythtv-users] Why did my remote control quit working?



At 02:40 PM 10/28/2005, you wrote:




At 01:43 PM 10/28/2005, you wrote:

Hi all-

My remote control with my PVR-150 was working great when I used the packaged
install (mythtv-suite). Then I decided I wanted to tweak some of the plugin
settings, so I decided to build from source.

I have built from source and got basically everything working like it used
to, but my remote control doesnt work with mythtv anymore.

When I compiled, the ./configure script reported lirc support : yes

I can still run my remote with irw, the messages are received correctly
(lircd is running).

I can also use the remote with irxevent piping the remote commands to
mythtv.

However, Id really prefer to get native remote control support in mythtv so
I could use my existing lircrc file.

I searched the archive with nothing pointing directly to my problem.

Thoughts?

Any log files I should post to help the members of this great community to
figure out whats going on?

Eric.

There are some reports that ivtv causes the remote to stop working after a
while. Does it come back for a short period if you reboot? On the ivtv list
there was a patch which basically puts in an IR reset into the code. There
are also patches to do the same with a once a minute cron job. This might
not be your case where you say it works with irw.


That is an interesting idea, but a couple things: Concerning reboot: it
makes no difference. The remote _always_ works with irw and irxevent, but
_never_ in mythtv. I did compile ivtv from source whereas before I was using
the pre-built binaries in the package install, so what you say is possible,
but since it works with irw always, I wouldnt think the problem is with the
driver. Other thoughts? TIA, Eric.


Well, the lircrc file is what controls the functionality away from irw. Are
you sure it didn't get corrupted/overwritten?





Hi Jim, thanks for the reply again.

I think my lircrc is in tact, see below:

~> ls -al .lir*

lrwxrwxrwx 1 ebrandt ebrandt 28 Oct 12 22:52 .lircrc ->
/home/ebrandt/.mythtv/lircrc

~> ls -al .mythtv/lir*

-rw-rw-r-- 1 ebrandt ebrandt 6310 Oct 21 09:17 .mythtv/lircrc

~> head -n30 .mythtv/lircrc

# ~/.mythtv/lircrc

#

# MythTV native LIRC config file for

# the new grey Hauppauge remote

#

# Modified from Jarod Wilson's which came from Jeff Campbell's

# By Brad Templeton





# Here we have the jump point commands. They only work if you have

# defined function keys for these jump points. For me the most

# common command is the menu of recordings, so I put that on "videos"

# even though that's counter-intuitive



begin

prog = mythtv

button = TV

repeat = 3

config = F5

end



begin

prog = mythtv

button = Videos

repeat = 3

config = F2

end



# Not yet defined

Begin



Any further thoughts?



TIA,

Eric.