Mailing List Archive

One more build dependency for ansible
Hi Stuart

Using Xubuntu 16.04

I chose to install mariadb instead of mysql. If you do that you need to
install an extra build dependency on Ubuntu - libmysqlclient-dev, in
order to build mythzoneminder. The config requires mysql/mysql.h.
Perhaps the code should also allow mariadb/mysql.h

These are the respective header files and their packages
/usr/include/mariadb/mysql.h     libmariadb-client-lgpl-dev
/usr/include/mysql/mysql.h     libmysqlclient-dev

Peter
_______________________________________________
mythtv-dev mailing list
mythtv-dev@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-dev
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
Re: One more build dependency for ansible [ In reply to ]
On 15/12/17 18:33, Peter Bennett wrote:
> Hi Stuart
>
> Using Xubuntu 16.04
>
> I chose to install mariadb instead of mysql. If you do that you need to
> install an extra build dependency on Ubuntu - libmysqlclient-dev, in
> order to build mythzoneminder. The config requires mysql/mysql.h.
> Perhaps the code should also allow mariadb/mysql.h
>
> These are the respective header files and their packages
> /usr/include/mariadb/mysql.h     libmariadb-client-lgpl-dev
> /usr/include/mysql/mysql.h     libmysqlclient-dev
>
> Peter

Fixed, as well as a logic flaw (<= meant to be >=)


Regards
Stuart

_______________________________________________
mythtv-dev mailing list
mythtv-dev@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-dev
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org