Mailing List Archive

issues with svn, possibly related to Daniel's recent commits
Noticed what I think are two new issues that are possibly related to the
pile of recent commits from Daniel...

1. mythfrontend seems to freeze when I hit esc (or left-arrow) to return
to the main memu from watching recordings. Makes it difficult to do
anything else if I have to force-quit the frontend every time (usually
alt-tab to the console I opened mythfrontend from and hit control-c). I
think I've run into this trying to get out of other sections, too.

2. For some reason, it appears as if mythbackend is taking over my
soundcard when recording from my pvr-150. This wouldn't normally be an
issue, except that the crappy ac97 audio drivers for my pubdit allow
only one thing to access the card at a time, which means I can't watch
anything if the backend is recording (in mythtv or xine or mplayer or
...). I don't see any reason why the backend needs access to the
soundcard for ivtv recording, so perhaps it's an easy fix?

-Chris
_______________________________________________
mythtv-dev mailing list
mythtv-dev@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev
Re: issues with svn, possibly related to Daniel's recent commits [ In reply to ]
On Mon, 2005-07-25 at 12:20 -0700, Chris Petersen wrote:
> Noticed what I think are two new issues that are possibly related to the
> pile of recent commits from Daniel...
>
> 1. mythfrontend seems to freeze when I hit esc (or left-arrow) to return
> to the main memu from watching recordings. Makes it difficult to do
> anything else if I have to force-quit the frontend every time (usually
> alt-tab to the console I opened mythfrontend from and hit control-c). I
> think I've run into this trying to get out of other sections, too.
I don't think anything I did would have caused this. But if so it
would have probably been a tv_play.cpp commit, possibly from
late June.

> 2. For some reason, it appears as if mythbackend is taking over my
> soundcard when recording from my pvr-150. This wouldn't normally be an
> issue, except that the crappy ac97 audio drivers for my pubdit allow
> only one thing to access the card at a time, which means I can't watch
> anything if the backend is recording (in mythtv or xine or mplayer or
> ...). I don't see any reason why the backend needs access to the
> soundcard for ivtv recording, so perhaps it's an easy fix?
This would have been in a tv_rec.cpp commit, probably from last week
or the previous week.

If you can narrow in on the commit that causes these problems, it
should help me figure out what the problem is.

-- Daniel
Re: Re: issues with svn, possibly related to Daniel's recent commits [ In reply to ]
On Mon, 2005-07-25 at 16:02 -0400, Daniel Kristjansson wrote:
> > 2. For some reason, it appears as if mythbackend is taking over my
> > soundcard when recording from my pvr-150. This wouldn't normally be an
> > issue, except that the crappy ac97 audio drivers for my pubdit allow
> > only one thing to access the card at a time, which means I can't watch
> > anything if the backend is recording (in mythtv or xine or mplayer or
> > ...). I don't see any reason why the backend needs access to the
> > soundcard for ivtv recording, so perhaps it's an easy fix?
Does this happen with current SVN? Looking back at the logs I saw that I
committed something to fix something similar. It was caused by the
preview generation, transcoding and commercial flagging grabbing the
audio output do to a bug fix in NuppelVideoPlayer.cpp

-- Daniel
Re: issues with svn, possibly related to Daniel's recent commits [ In reply to ]
> 1. mythfrontend seems to freeze when I hit esc (or left-arrow) to return
> to the main memu from watching recordings. Makes it difficult to do
> anything else if I have to force-quit the frontend every time (usually
> alt-tab to the console I opened mythfrontend from and hit control-c). I
> think I've run into this trying to get out of other sections, too.

I need to expound upon this.. I was not entirely correct before. The
freeze happens after I've viewed a show, and am returning to the "show"
menu (the left bar, as opposed to the "episode" menu on the right)

Dunno if it's related, but I am not getting a preview movie showing up
(Midnight theme from lxm), despite having the option enabled. I also
have "show group summary" enabled (which imho should be default --
otherwise it's VERY hard to tell whether group or episode has focus)

Tried with `mythfrontend -v all` but nothing showed up. Tried strace,
and the "freeze" happened when I got a near-infinite bit of the following:

write(6, "\0", 1) = 1
gettimeofday({1122620537, 997511}, NULL) = 0
ioctl(3, FIONREAD, [0]) = 0
gettimeofday({1122620537, 997674}, NULL) = 0
select(15, [3 4 5 7 13 14], [], [], {0, 0}) = 1 (in [5], left {0, 0})
read(5, "\0", 1) = 1
gettimeofday({1122620537, 998253}, NULL) = 0
nanosleep({0, 500000}, NULL) = 0
ioctl(5, FIONREAD, [0]) = 0
write(6, "\0", 1) = 1
gettimeofday({1122620538, 3812}, NULL) = 0
ioctl(3, FIONREAD, [0]) = 0
gettimeofday({1122620538, 3964}, NULL) = 0
select(15, [3 4 5 7 13 14], [], [], {0, 0}) = 1 (in [5], left {0, 0})
read(5, "\0", 1) = 1
gettimeofday({1122620538, 4218}, NULL) = 0
nanosleep({0, 500000}, NULL) = 0
ioctl(5, FIONREAD, [0]) = 0
write(6, "\0", 1) = 1
gettimeofday({1122620538, 9284}, NULL) = 0
ioctl(3, FIONREAD, [0]) = 0
gettimeofday({1122620538, 9423}, NULL) = 0
select(15, [3 4 5 7 13 14], [], [], {0, 0}) = 1 (in [5], left {0, 0})
read(5, "\0", 1) = 1
gettimeofday({1122620538, 9682}, NULL) = 0
nanosleep({0, 500000}, NULL) = 0
ioctl(5, FIONREAD, [0]) = 0
write(6, "\0", 1) = 1
gettimeofday({1122620538, 15102}, NULL) = 0
ioctl(3, FIONREAD, [0]) = 0
gettimeofday({1122620538, 15256}, NULL) = 0
select(15, [3 4 5 7 13 14], [], [], {0, 0}) = 1 (in [5], left {0, 0})
read(5, "\0", 1) = 1
gettimeofday({1122620538, 15506}, NULL) = 0
nanosleep({0, 500000}, NULL) = 0
ioctl(5, FIONREAD, [0]) = 0
write(6, "\0", 1) = 1
gettimeofday({1122620538, 17732}, NULL) = 0
ioctl(3, FIONREAD, [0]) = 0
gettimeofday({1122620538, 17840}, NULL) = 0
select(15, [3 4 5 7 13 14], [], [], {0, 0}) = 1 (in [5], left {0, 0})
read(5, "\0", 1) = 1
gettimeofday({1122620538, 18024}, NULL) = 0
nanosleep({0, 500000}, NULL) = 0
ioctl(5, FIONREAD, [0]) = 0
write(6, "\0", 1) = 1
gettimeofday({1122620538, 20719}, NULL) = 0
ioctl(3, FIONREAD, [0]) = 0
gettimeofday({1122620538, 20824}, NULL) = 0
select(15, [3 4 5 7 13 14], [], [], {0, 0}) = 1 (in [5], left {0, 0})
read(5, "\0", 1) = 1
gettimeofday({1122620538, 21011}, NULL) = 0
nanosleep({0, 500000}, NULL) = 0
ioctl(5, FIONREAD, [0]) = 0
write(6, "\0", 1) = 1
gettimeofday({1122620538, 24358}, NULL) = 0
ioctl(3, FIONREAD, [0]) = 0
gettimeofday({1122620538, 24461}, NULL) = 0
select(15, [3 4 5 7 13 14], [], [], {0, 0}) = 1 (in [5], left {0, 0})
read(5, "\0", 1) = 1
gettimeofday({1122620538, 24645}, NULL) = 0
nanosleep({0, 500000}, NULL) = 0
ioctl(5, FIONREAD, [0]) = 0
write(6, "\0", 1) = 1
gettimeofday({1122620538, 27714}, NULL) = 0
ioctl(3, FIONREAD, [0]) = 0
gettimeofday({1122620538, 27817}, NULL) = 0

-Chris
_______________________________________________
mythtv-dev mailing list
mythtv-dev@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev
Re: issues with svn, possibly related to Daniel's recent commits [ In reply to ]
> I need to expound upon this.. I was not entirely correct before. The
> freeze happens after I've viewed a show, and am returning to the "show"
> menu (the left bar, as opposed to the "episode" menu on the right)

Should also add that this same thing happens after viewing a program if
I press D to try to delete it. Only seems to happen after I've viewed
something, though. Works fine before I invoke the viewer.

-Chris
_______________________________________________
mythtv-dev mailing list
mythtv-dev@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev
Re: issues with svn, possibly related to Daniel's recent commits [ In reply to ]
On Fri 29 July 2005 08:07, Chris Petersen wrote:
> > I need to expound upon this.. I was not entirely correct before. The
> > freeze happens after I've viewed a show, and am returning to the "show"
> > menu (the left bar, as opposed to the "episode" menu on the right)
>
> Should also add that this same thing happens after viewing a program if
> I press D to try to delete it. Only seems to happen after I've viewed
> something, though. Works fine before I invoke the viewer.

I've had the same or a very similar problem after watching a recording and
returning to the left menu. I also see a similar problem if I change to
category listing on the recordings screen, don't go the the right menu and
then hit escape. In my case the window actually disappears and I have to
ctrl-c mythfrontend.

--
Stuart Morgan
_______________________________________________
mythtv-dev mailing list
mythtv-dev@mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev