Mailing List Archive

Ticket #13297: Playback hangs and then times out after unpausing
#13297: Playback hangs and then times out after unpausing
-----------------------------------------+---------------------------
Reporter: gigem | Owner: Peter Bennett
Type: Bug Report - General | Status: new
Priority: minor | Milestone: needs_triage
Component: MythTV - Video Playback | Version: v29.1
Severity: medium | Keywords:
Ticket locked: 0 |
-----------------------------------------+---------------------------
When unpausing playback after a moderate pause of a few minutes (I don't
know exactly how long it takes), the frontend doesn't resume playback and
is unresponsive to keypresses. It eventually times out after about 10
seconds and exits back to the watch recordings screen.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/13297>
MythTV <http://www.mythtv.org>
MythTV Media Center
Re: Ticket #13297: Playback hangs and then times out after unpausing [ In reply to ]
#13297: Playback hangs and then times out after unpausing
-------------------------------------+-------------------------------
Reporter: gigem | Owner: Peter Bennett
Type: Bug Report - General | Status: new
Priority: minor | Milestone: needs_triage
Component: MythTV - Video Playback | Version: v29.1
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
-------------------------------------+-------------------------------

Comment (by bauner):

I have exactly the same problem.
After pausing the playback and resuming it after a about 10 minutes it
will hang.
Here are my mythfrontend logs of the problem

mythfrontend log
https://pastebin.com/2XMKcc2T

mythfrontend -v playback log
https://pastebin.com/3u2ezp3v

--
Ticket URL: <https://code.mythtv.org/trac/ticket/13297#comment:1>
MythTV <http://www.mythtv.org>
MythTV Media Center
Re: Ticket #13297: Playback hangs and then times out after unpausing [ In reply to ]
#13297: Playback hangs and then times out after unpausing
-------------------------------------+-------------------------------
Reporter: gigem | Owner: Peter Bennett
Type: Bug Report - General | Status: new
Priority: minor | Milestone: needs_triage
Component: MythTV - Video Playback | Version: v29.1
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
-------------------------------------+-------------------------------

Comment (by Peter Bennett):

The relevant message seems to be
{{{
2018-07-16 16:29:52.968901 E FileRingBuf(myth://bauner-
backend/1005_20180715170500.ts): safe_read(RemoteFile* ...): read failed
}}}
I assume this only happens with a remote frontend. Probably some dsort of
network timeout. I will test it further.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/13297#comment:2>
MythTV <http://www.mythtv.org>
MythTV Media Center
Re: Ticket #13297: Playback hangs and then times out after unpausing [ In reply to ]
#13297: Playback hangs and then times out after unpausing
-------------------------------------+--------------------------------
Reporter: gigem | Owner: Peter Bennett
Type: Bug Report - General | Status: infoneeded_new
Priority: minor | Milestone: needs_triage
Component: MythTV - Video Playback | Version: v29.1
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
-------------------------------------+--------------------------------
Changes (by Peter Bennett):

* status: new => infoneeded_new


Comment:

Using current master, I started a playback on a remote frontend. After a
couple of minutes I paused it (pressed P). I left it undisturbed for 10
minutes. I came back and pressed P again and playback resumed immediately,
no problem.

Can you give me some more information on how to reproduce this. I do not
see any of the error messages or anything unusual in the log.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/13297#comment:3>
MythTV <http://www.mythtv.org>
MythTV Media Center
Re: Ticket #13297: Playback hangs and then times out after unpausing [ In reply to ]
#13297: Playback hangs and then times out after unpausing
-------------------------------------+--------------------------------
Reporter: gigem | Owner: Peter Bennett
Type: Bug Report - General | Status: infoneeded_new
Priority: minor | Milestone: needs_triage
Component: MythTV - Video Playback | Version: v29.1
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
-------------------------------------+--------------------------------

Comment (by gigem):

That's the right procedure to reproduce it but please try with fixes/29
instead of master. That's the version where it happened consistently.
The ffmpeg update in master could have fixed it there.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/13297#comment:4>
MythTV <http://www.mythtv.org>
MythTV Media Center
Re: Ticket #13297: Playback hangs and then times out after unpausing [ In reply to ]
#13297: Playback hangs and then times out after unpausing
-------------------------------------+--------------------------------
Reporter: gigem | Owner: Peter Bennett
Type: Bug Report - General | Status: infoneeded_new
Priority: minor | Milestone: needs_triage
Component: MythTV - Video Playback | Version: v29.1
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
-------------------------------------+--------------------------------

Comment (by jpoet):

I have seen it with Master recently. I don't think it happens every
single time though. Either that, or it only happens on my main nVidia
graphics card box, and not the Shield. I will try to pay more attention
the circumstances in the future.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/13297#comment:5>
MythTV <http://www.mythtv.org>
MythTV Media Center
Re: Ticket #13297: Playback hangs and then times out after unpausing [ In reply to ]
#13297: Playback hangs and then times out after unpausing
-------------------------------------+--------------------------------
Reporter: gigem | Owner: Peter Bennett
Type: Bug Report - General | Status: infoneeded_new
Priority: minor | Milestone: needs_triage
Component: MythTV - Video Playback | Version: v29.1
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
-------------------------------------+--------------------------------

Comment (by Peter Bennett):

I tried again with fixes/29 and could not recreate it. After 10 minutes of
pause it resumed without problem. It may be associated with a particular
environment. I also tried with disconnecting and reconnecting the network
cable. I tried shutting down and restarting the backend while paused. None
of these caused the problem. In each case, playback resumed flawlessly.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/13297#comment:6>
MythTV <http://www.mythtv.org>
MythTV Media Center
Re: Ticket #13297: Playback hangs and then times out after unpausing [ In reply to ]
#13297: Playback hangs and then times out after unpausing
-------------------------------------+--------------------------
Reporter: gigem | Owner: jpoet
Type: Bug Report - General | Status: assigned
Priority: minor | Milestone: unknown
Component: MythTV - Video Playback | Version: v29.1
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
-------------------------------------+--------------------------
Changes (by Peter Bennett):

* owner: Peter Bennett => jpoet
* status: infoneeded_new => assigned


Comment:

Assigned to John as he is working on this (commit
7b737044eff2fff1090c582c1bf3bd61f6c2f26 )

--
Ticket URL: <https://code.mythtv.org/trac/ticket/13297#comment:8>
MythTV <http://www.mythtv.org>
MythTV Media Center