Mailing List Archive

Ticket #10721: mythfrontend cannot play videos using vaapi
#10721: mythfrontend cannot play videos using vaapi
-------------------------------------+-------------------------------------
Reporter: Martin Konopka | Type: Bug Report -
<martin.konopka@…> | General
Status: new | Priority: minor
Milestone: unknown | Component: MythTV - Video
Version: 0.25-fixes | Playback
Keywords: vaapi amd | Severity: medium
| Ticket locked: 0
-------------------------------------+-------------------------------------
Using mythfrontend v0.25-84-g9ccfac1 playback of HD videos and livetv
doesn't work with vaapi.

Output of vainfo:

libva: VA-API version 0.32.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/i386-linux-gnu/dri/fglrx_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA-API version: 0.32 (libva 1.0.15)
vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API -
0.7.8
vainfo: Supported profile and entrypoints
VAProfileH264High : VAEntrypointVLD
VAProfileVC1Advanced : VAEntrypointVLD


Output of the mythfrontend logs:

E CoreContext vaapicontext.cpp:311 (CreateDisplay) VAAPI: Invalid display
E CoreContext videoout_openglvaapi.cpp:145 (CreateVAAPIContext)
VidOutGLVAAPI: Failed to create VAAPI context.

This happens on ubuntu 12.04 with the fglrx driver (8.960) provided by the
distribution.

The same bug was already reported here:
http://www.mythtvtalk.com/myth-0-25-vaapi-e350-15487/

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10721>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits@mythtv.org
http://www.mythtv.org/mailman/listinfo/mythtv-commits