Mailing List Archive

Ticket #10707: mythweb displays broken links to preview images
#10707: mythweb displays broken links to preview images
--------------------------------------+------------------------
Reporter: brian@… | Owner: kormoc
Type: Bug Report - General | Status: new
Priority: minor | Milestone: unknown
Component: Plugin - MythWeb | Version: 0.25-fixes
Severity: medium | Keywords:
Ticket locked: 0 |
--------------------------------------+------------------------
When I load the "Recorded Programs" page in mythweb it will typically show
a few broken links for a few of the most recent preview images. Simply
refreshing fills the broken links in with preview images, quite quickly --
clearly from disk.

Seems there is some kind of race or timeout issue happening.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10707>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits@mythtv.org
http://www.mythtv.org/mailman/listinfo/mythtv-commits
Re: Ticket #10707: mythweb displays broken links to preview images [ In reply to ]
#10707: mythweb displays broken links to preview images
----------------------------------+--------------------------------
Reporter: brian@… | Owner: kormoc
Type: Bug Report - General | Status: infoneeded_new
Priority: minor | Milestone: unknown
Component: Plugin - MythWeb | Version: 0.25-fixes
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
----------------------------------+--------------------------------
Changes (by kormoc):

* status: new => infoneeded_new


Comment:

Can you add the apache logs when this happens?

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10707#comment:1>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits@mythtv.org
http://www.mythtv.org/mailman/listinfo/mythtv-commits
Re: Ticket #10707: mythweb displays broken links to preview images [ In reply to ]
#10707: mythweb displays broken links to preview images
----------------------------------+--------------------------------
Reporter: brian@… | Owner: kormoc
Type: Bug Report - General | Status: infoneeded_new
Priority: minor | Milestone: unknown
Component: Plugin - MythWeb | Version: 0.25-fixes
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
----------------------------------+--------------------------------

Comment (by brian@…):

OK. It just happened again. Two episodes which are showing a broken link
icon instead of a thumbnail. Looking at what was fetched for one of them:

{{{
<a class="x-pixmap" href="http://pvr/mythweb/tv/detail/3093/1365469200"
title="Recording Details"
><img
src="http://pvr/mythweb/tv/get_pixmap/pvr/3093/1365469200/100/75/-1/3093_20130409010000.mpg.100x75x-1.png"
width="100" height="75"></a>
}}}

and then grepping the access_log for 1365469200:

{{{
# grep "1365469200" /var/log/apache2/access.log
1.5.2.1 - - [09/Apr/2013:18:11:54 -0400] "GET
/mythweb/tv/get_pixmap/pvr/3093/1365469200/100/75/-1/3093_20130409010000.mpg.100x75x-1.png
HTTP/1.1" 200 385 "http://pvr/mythweb/tv/recorded" "Mozilla/5.0 (X11;
Linux i686) AppleWebKit/537.22 (KHTML, like Gecko) Ubuntu
Chromium/25.0.1364.160 Chrome/25.0.1364.160 Safari/537.22"
1.5.2.1 - - [09/Apr/2013:18:11:59 -0400] "GET
/mythweb/tv/get_pixmap/pvr/3129/1365469200/100/75/-1/3129_20130409010000.mpg.100x75x-1.png
HTTP/1.1" 200 384 "http://pvr/mythweb/tv/recorded" "Mozilla/5.0 (X11;
Linux i686) AppleWebKit/537.22 (KHTML, like Gecko) Ubuntu
Chromium/25.0.1364.160 Chrome/25.0.1364.160 Safari/537.22"
}}}

So the log doesn't show a 404.

And if I refresh the page, the thumbnail will actually draw the second
time around.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10707#comment:2>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits@mythtv.org
http://www.mythtv.org/mailman/listinfo/mythtv-commits
Re: Ticket #10707: mythweb displays broken links to preview images [ In reply to ]
#10707: mythweb displays broken links to preview images
----------------------------------+----------------------------
Reporter: brian@… | Owner: kormoc
Type: Bug Report - General | Status: new
Priority: minor | Milestone: unknown
Component: Plugin - MythWeb | Version: 0.25-fixes
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
----------------------------------+----------------------------
Changes (by paulh):

* status: infoneeded_new => new


--
Ticket URL: <http://code.mythtv.org/trac/ticket/10707#comment:3>
MythTV <http://www.mythtv.org>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits@mythtv.org
http://www.mythtv.org/mailman/listinfo/mythtv-commits
Re: Ticket #10707: mythweb displays broken links to preview images [ In reply to ]
#10707: mythweb displays broken links to preview images
----------------------------------+------------------------------
Reporter: brian@… | Owner: kormoc
Type: Bug Report - General | Status: closed
Priority: minor | Milestone: unknown
Component: Plugin - MythWeb | Version: 0.25-fixes
Severity: medium | Resolution: Works for me
Keywords: | Ticket locked: 0
----------------------------------+------------------------------
Changes (by kormoc):

* status: new => closed
* resolution: => Works for me


Comment:

I can't reproduce this.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/10707#comment:4>
MythTV <http://www.mythtv.org>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits@mythtv.org
http://www.mythtv.org/mailman/listinfo/mythtv-commits
Re: Ticket #10707: mythweb displays broken links to preview images [ In reply to ]
#10707: mythweb displays broken links to preview images
----------------------------------+------------------------------
Reporter: brian@… | Owner: kormoc
Type: Bug Report - General | Status: closed
Priority: minor | Milestone: unknown
Component: Plugin - MythWeb | Version: 0.25-fixes
Severity: medium | Resolution: Works for me
Keywords: | Ticket locked: 0
----------------------------------+------------------------------

Comment (by brian@…):

Replying to [comment:4 kormoc]:
> I can't reproduce this.

But I can with 100% reliability so it seems a bit short-sighted to close
the ticket just because one person cannot reproduce the problem. Perhaps
these are related since they occur when trying to load the Recorded page:


{{{
Aug 31 07:48:46 pvr mythbackend: mythbackend[2170]: E HttpServer126
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:48:47 pvr mythbackend: mythbackend[2170]: E HttpServer125
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:48:47 pvr mythbackend: mythbackend[2170]: E HttpServer127
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:48:47 pvr mythbackend: mythbackend[2170]: E HttpServer142
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:48:51 pvr mythbackend: mythbackend[2170]: E HttpServer69
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:16 pvr mythbackend: mythbackend[2170]: E HttpServer116
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:19 pvr mythbackend: mythbackend[2170]: E HttpServer120
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:20 pvr mythbackend: mythbackend[2170]: E HttpServer121
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:20 pvr mythbackend: mythbackend[2170]: E HttpServer123
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:20 pvr mythbackend: mythbackend[2170]: E HttpServer125
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:26 pvr mythbackend: mythbackend[2170]: E HttpServer69
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:49 pvr mythbackend: mythbackend[2170]: E HttpServer116
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:52 pvr mythbackend: mythbackend[2170]: E HttpServer118
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:53 pvr mythbackend: mythbackend[2170]: E HttpServer121
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:53 pvr mythbackend: mythbackend[2170]: E HttpServer123
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:53 pvr mythbackend: mythbackend[2170]: E HttpServer126
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:59 pvr mythbackend: mythbackend[2170]: E HttpServer69
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:50:26 pvr mythbackend: mythbackend[2170]: E HttpServer121
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:50:50 pvr mythbackend: mythbackend[2170]: E HttpServer116
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:50:55 pvr mythbackend: mythbackend[2170]: E HttpServer123
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:51:30 pvr mythbackend: mythbackend[2170]: E HttpServer121
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (141)
Aug 31 07:52:13 pvr mythbackend: mythbackend[2170]: E HttpServer64
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (128)
Aug 31 07:52:20 pvr mythbackend: mythbackend[2170]: E HttpServer117
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (128)
Aug 31 07:52:28 pvr mythbackend: mythbackend[2170]: E HttpServer64
previewgenerator.cpp:265 (Run) Preview: Encountered problems running
'/usr/bin/mythpreviewgen' (128)
}}}

But as I have mentioned, they are transient/load related since they only
occur on the first attempt to load the Recorded page and the broken links
will go away if I refresh the page which of course instructs the server to
regenerate the previews.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/10707#comment:5>
MythTV <http://www.mythtv.org>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits@mythtv.org
http://www.mythtv.org/mailman/listinfo/mythtv-commits
Re: Ticket #10707: mythweb displays broken links to preview images [ In reply to ]
#10707: mythweb displays broken links to preview images
----------------------------------+------------------------------
Reporter: brian@… | Owner: kormoc
Type: Bug Report - General | Status: closed
Priority: minor | Milestone: unknown
Component: Plugin - MythWeb | Version: 0.25-fixes
Severity: medium | Resolution: Works for me
Keywords: | Ticket locked: 0
----------------------------------+------------------------------

Comment (by jan@…):

I see this too now. The result sent back from Content/GetPreviewImage is
actually:

{{{
<?xml version="1.0" encoding="UTF-8"?><></>
}}}

instead of the image data. Reloading fixes this.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/10707#comment:6>
MythTV <http://www.mythtv.org>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-commits
Re: Ticket #10707: mythweb displays broken links to preview images [ In reply to ]
#10707: mythweb displays broken links to preview images
----------------------------------+------------------------------
Reporter: brian@… | Owner: kormoc
Type: Bug Report - General | Status: closed
Priority: minor | Milestone: unknown
Component: Plugin - MythWeb | Version: 0.25-fixes
Severity: medium | Resolution: Works for me
Keywords: | Ticket locked: 0
----------------------------------+------------------------------

Comment (by jan@…):

Oh, and I'm running the latest 0.28-fixes.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/10707#comment:7>
MythTV <http://www.mythtv.org>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-commits
Re: Ticket #10707: mythweb displays broken links to preview images [ In reply to ]
#10707: mythweb displays broken links to preview images
----------------------------------+------------------------------
Reporter: brian@… | Owner: kormoc
Type: Bug Report - General | Status: closed
Priority: minor | Milestone: unknown
Component: Plugin - MythWeb | Version: 0.25-fixes
Severity: medium | Resolution: Works for me
Keywords: | Ticket locked: 0
----------------------------------+------------------------------

Comment (by nige@…):

I was experiencing this issue and found that my Apache log was littered
with "AH01797: client denied by server configuration". By migrating the
Apache access control directives
(https://httpd.apache.org/docs/2.4/upgrading.html) to those preferred by
2.4 the errors in the log disappeared, and my images started to show on
first page load.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/10707#comment:8>
MythTV <http://www.mythtv.org>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-commits
Re: Ticket #10707: mythweb displays broken links to preview images [ In reply to ]
#10707: mythweb displays broken links to preview images
----------------------------------+------------------------------
Reporter: brian@… | Owner: kormoc
Type: Bug Report - General | Status: closed
Priority: minor | Milestone: unknown
Component: Plugin - MythWeb | Version: 0.25-fixes
Severity: medium | Resolution: Works for me
Keywords: | Ticket locked: 0
----------------------------------+------------------------------

Comment (by nige@…):

Scrub that. I spoke too soon. It's back again :( I'm also using
0.28-fixes.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/10707#comment:9>
MythTV <http://www.mythtv.org>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits@mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-commits