Mailing List Archive

Precompiling scripts with Apache::ASP->Loader

I have a problem with using the script precompilation feature
using Apache::ASP->Loader(). Any help would be greatly appreciated.

I run a set of Apache::ASP applications in an Apache2/mod_perl2
environemnt, Perl version is 5.8.5, Apache::ASP version is 2.57.

When Apache is started, two scripts are executed:

<IfModule mod_perl.c>
PerlRequire "/jukebox/p4/cms/common/conf/"
PerlRequire "/jukebox/p4/cms/common/tools/"

The first one precompiles loads of modules, while the second
one ist there to precompile the scripts for a defined number of
directories. What it basically does is:

foreach my $application (keys %{$Ets::CMS::Config->{Applications}}) {
Global => $cmsroot."$application/htdocs/global",
Debug => 1);

Now when I start Apache, I get the following error in the apache log

[ASP WARN] Can't call method "cleanup_register" on an undefined value
at /usr/lib/perl5/site_perl/5.8.5/Apache/ line 513.
at /usr/lib/perl5/site_perl/5.8.5/Apache/ line 512
'CODE(0x88048dc)') called at
/usr/lib/perl5/site_perl/5.8.5/Apache/ line 379
'Apache::ASP::Load=HASH(0x8809650)') called at
/usr/lib/perl5/site_perl/5.8.5//Apache/ASP/ line 129
eval {...} called at
/usr/lib/perl5/site_perl/5.8.5//Apache/ASP/ line 127

'(asp|xls)$', 'Global', '/jukebox/p4/cms/iem/htdocs/global', 'Debug',
1) called at /usr/lib/perl5/site_perl/5.8.5//Apache/ASP/ line
'(asp|xls)$', 'Global', '/jukebox/p4/cms/iem/htdocs/global', 'Debug',
1) called at /usr/lib/perl5/site_perl/5.8.5//Apache/ASP/ line
Apache::ASP::Load::Run('Apache::ASP', '/jukebox/p4/cms/iem',
'(asp|xls)$', 'Global', '/jukebox/p4/cms/iem/htdocs/global', 'Debug',
1) called at /usr/lib/perl5/site_perl/5.8.5/Apache/ line 1980
Apache::ASP::Loader('Apache::ASP', '/jukebox/p4/cms/iem',
'(asp|xls)$', 'Global', '/jukebox/p4/cms/iem/htdocs/global', 'Debug',
1) called at /jukebox/p4/cms/common/tools/
line 15
require /jukebox/p4/cms/common/tools/
called at (eval 58) line 1
eval 'require
;' called at /etc/etscms.conf line 0

I get that error once for every script that is being compiled.

Interestingly, when I run the script on the command line, none
of these errors appears to be written to STDERR (or maybe I just don't
see them for some reason?).

I am aware that this error has been reported here mid-2004 but I have
not found a solution to this problem here or anywhere on the Internet.

Thanks... Oliver

To unsubscribe, e-mail:
For additional commands, e-mail: