Mailing List Archive

Compiler can't find glibconfig.h
I apologize if this is a duplicate. I had problems with the first email
I sent. Below is the original message with corrections...

Last evening I followed the instructions in the INSTALL.txt of Maemo 3.0
'bora'. I used the automated install scripts. Everything seems to have
gone fine. 'hello.c' compiled fine in the SDK_ARMEL environment.
However, when I try to compile the sample hildon program I am greeted
with a message stating that 'glibconfig.h' cannot be found, and, in
fact, it is not there. How do I get past this problem?

Thanks,

--
Paul


_______________________________________________
maemo-developers mailing list
maemo-developers@maemo.org
https://maemo.org/mailman/listinfo/maemo-developers
Re: Compiler can't find glibconfig.h [ In reply to ]
On Mon, 2007-03-19 at 18:21 -0600, ext Paul F. Sehorne wrote:
> I apologize if this is a duplicate. I had problems with the first email
> I sent. Below is the original message with corrections...
>
> Last evening I followed the instructions in the INSTALL.txt of Maemo 3.0
> 'bora'. I used the automated install scripts. Everything seems to have
> gone fine. 'hello.c' compiled fine in the SDK_ARMEL environment.
> However, when I try to compile the sample hildon program I am greeted
> with a message stating that 'glibconfig.h' cannot be found, and, in
> fact, it is not there. How do I get past this problem?

Install libglib2.0-dev and use pkg-config's output when compiling your
program:

gcc ... `pkg-config --libs --cflags glib-2.0` ...

>
> Thanks,
>
_______________________________________________
maemo-developers mailing list
maemo-developers@maemo.org
https://maemo.org/mailman/listinfo/maemo-developers