Mailing List Archive

solr highlight results without the pre/post
Hi,

I'm facing a problem related to the solr search highlight result. I'm
getting all the highlight fields but some of them (not 100%) are not filled
with the pre/post element.

ex:
q=text:han&hl.on&hl.fl=text

result:
<lst name="highlighting">
<lst name="1480">
<arr name="Name">
<str>Diapers and changes</str>
</arr>
</lst>
<lst name="4113">
<arr name="Name">
<str>FanXChange Campaign</str>
</arr>
</lst>
<lst name="3687">
<arr name="Name">
<str>Vivafilm Hanna</str>
</arr>
</lst>
<lst name="240">
<arr name="Name">
<str>Volvo Video Channel</str>
</arr>
</lst>
<lst name="2513">
<arr name="Name">
<str>
The Shopping Channel Jan 2011 BT test
</str>
</arr>
</lst>
....

Is there a reason why I didn't get all of my highlighting fields with the
matching ?
Can someone point the problem?

Thanks

--
View this message in context: http://lucene.472066.n3.nabble.com/solr-highlight-results-without-the-pre-post-tp2909539p2909539.html
Sent from the Lucene - General mailing list archive at Nabble.com.
Re: solr highlight results without the pre/post [ In reply to ]
Sorry my span gets removed in the post. here is the result:

<lst name="highlighting">
<lst name="1480">
<arr name="Name">
<str>Diapers and changes</str>
</arr>
</lst>
<lst name="4113">
<arr name="Name">
<str>FanXC[span class="match"]han[/span]ge Campaign</str>
</arr>
</lst>
<lst name="3687">
<arr name="Name">
<str>Vivafilm Hanna</str>
</arr>
</lst>
<lst name="240">
<arr name="Name">
<str>Volvo Video Channel</str>
</arr>
</lst>
<lst name="2513">
<arr name="Name">
<str>
The Shopping C[span class="match"]han[/span]nel Jan 2011 BT test
</str>
</arr>
</lst>
....

--
View this message in context: http://lucene.472066.n3.nabble.com/solr-highlight-results-without-the-pre-post-tp2909539p2909550.html
Sent from the Lucene - General mailing list archive at Nabble.com.