Mailing List Archive

SAPInstance does not start and asking for START_PROFILE
OS: SLES 11 SP 3
pacemaker-1.1.9-0.19.102
corosync-1.4.5-0.18.15
resource-agents-3.9.5-0.32.22

starting the SAP Instance resource fails with following errors:

Jan 14 18:22:16 thltlp1 SAPInstance(SAPInst-DVEBMGS00)[50450]: ERROR:
Expected
TLP_DVEBMGS00_thltlp to be the instance START profile, please set
START_PROFILE
parameter!
Jan 14 18:22:16 thltlp1 crmd[47231]: notice: process_lrm_event: LRM
operation
SAPInst-DVEBMGS00_start_0 (call=81, rc=6, cib-update=66, confirmed=true)
not configured

following is the resource configurations:
primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
op monitor interval="120" timeout="60" \
op start interval="0" timeout="300" \
op stop interval="0" timeout="300" \
params InstanceName="TLP_DVEBMGS00_thltlp"
DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
START_PROFILE="TLP_DVEBMGS00_thltlp" DIR_PROFILE="/sapmnt/TLP/profile"

i.e START_PROFILE is configured but cluster is not starting the SAP
Instance.

Please help

--
Regards,

Muhammad Sharfuddin


_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems
Re: SAPInstance does not start and asking for START_PROFILE [ In reply to ]
Hi Muhammad,

could you try:
primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
op monitor interval="120" timeout="60" \
op start interval="0" timeout="300" \
op stop interval="0" timeout="300" \
params InstanceName="TLP_DVEBMGS00_thltlp"
DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
START_PROFILE="/sapmnt/TLP/profile/TLP_DVEBMGS00_thltlp"

Or even let the parameters DIR_EXECUTABLE and START_PROFILE unset, so
SAPInstance could use the automatical detection.

If you set the param START_PROFILE it must be a full file path NOT
relative to DIR_PROFILE.

Hope that helps
Best regards
Fabian

On 01/14/2015 08:12 PM, Muhammad Sharfuddin wrote:
> OS: SLES 11 SP 3
> pacemaker-1.1.9-0.19.102
> corosync-1.4.5-0.18.15
> resource-agents-3.9.5-0.32.22
>
> starting the SAP Instance resource fails with following errors:
>
> Jan 14 18:22:16 thltlp1 SAPInstance(SAPInst-DVEBMGS00)[50450]: ERROR:
> Expected
> TLP_DVEBMGS00_thltlp to be the instance START profile, please set
> START_PROFILE
> parameter!
> Jan 14 18:22:16 thltlp1 crmd[47231]: notice: process_lrm_event: LRM
> operation
> SAPInst-DVEBMGS00_start_0 (call=81, rc=6, cib-update=66, confirmed=true)
> not configured
>
> following is the resource configurations:
> primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
> op monitor interval="120" timeout="60" \
> op start interval="0" timeout="300" \
> op stop interval="0" timeout="300" \
> params InstanceName="TLP_DVEBMGS00_thltlp"
> DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
> START_PROFILE="TLP_DVEBMGS00_thltlp" DIR_PROFILE="/sapmnt/TLP/profile"
>
> i.e START_PROFILE is configured but cluster is not starting the SAP
> Instance.
>
> Please help
>

_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems
Re: SAPInstance does not start and asking for START_PROFILE [ In reply to ]
On 01/15/2015 12:46 AM, Fabian Herschel wrote:
> Hi Muhammad,
>
> could you try:
> primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
> op monitor interval="120" timeout="60" \
> op start interval="0" timeout="300" \
> op stop interval="0" timeout="300" \
> params InstanceName="TLP_DVEBMGS00_thltlp"
> DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
> START_PROFILE="/sapmnt/TLP/profile/TLP_DVEBMGS00_thltlp"
>
> Or even let the parameters DIR_EXECUTABLE and START_PROFILE unset, so
SAPInstance could use the automatical detection.
>
> If you set the param START_PROFILE it must be a full file path NOT
relative to DIR_PROFILE.
>
> Hope that helps
> Best regards
> Fabian
>
> On 01/14/2015 08:12 PM, Muhammad Sharfuddin wrote:
>> OS: SLES 11 SP 3
>> pacemaker-1.1.9-0.19.102
>> corosync-1.4.5-0.18.15
>> resource-agents-3.9.5-0.32.22
>>
>> starting the SAP Instance resource fails with following errors:
>>
>> Jan 14 18:22:16 thltlp1 SAPInstance(SAPInst-DVEBMGS00)[50450]: ERROR:
>> Expected
>> TLP_DVEBMGS00_thltlp to be the instance START profile, please set
>> START_PROFILE
>> parameter!
>> Jan 14 18:22:16 thltlp1 crmd[47231]: notice: process_lrm_event: LRM
>> operation
>> SAPInst-DVEBMGS00_start_0 (call=81, rc=6, cib-update=66, confirmed=true)
>> not configured
>>
>> following is the resource configurations:
>> primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
>> op monitor interval="120" timeout="60" \
>> op start interval="0" timeout="300" \
>> op stop interval="0" timeout="300" \
>> params InstanceName="TLP_DVEBMGS00_thltlp"
>> DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
>> START_PROFILE="TLP_DVEBMGS00_thltlp" DIR_PROFILE="/sapmnt/TLP/profile"
>>
>> i.e START_PROFILE is configured but cluster is not starting the SAP
>> Instance.
>>
>> Please help
>

provide the full path, and now error changed. It became:

Jan 15 00:54:04 thltlp2 cibadmin[24511]: notice: crm_log_args:
Invoked: cibadmin -p -R -o resources
Jan 15 00:54:04 thltlp2 SAPInstance(SAPInst-DVEBMGS00)[22589]: ERROR:
SAP Instance TLP-DVEBMGS00 start
failed: 15.01.2015 00:54:04 WaitforStarted FAIL: process disp+work
Dispatcher not running
Jan 15 00:54:04 thltlp2 crmd[2778]: warning: do_update_resource:
Resource SAPInst-DVEBMGS00 no longer
exists in the lrmd
Jan 15 00:54:04 thltlp2 crmd[2778]: notice: process_lrm_event: LRM
operation SAPInst-DVEBMGS00_start_0
(call=176, rc=7, cib-update=0, confirmed=true) not running
Jan 15 00:54:04 thltlp2 crmd[2778]: warning: decode_transition_key: Bad
UUID (crm_resource.c) in sscanf
result (4) for 24450:0:0:crm_resource.c
Jan 15 00:54:04 thltlp2 crmd[2778]: error: send_msg_via_ipc: Unknown
Sub-system
(9f52a2cf-6c1d-453d-bc1b-90322f3147f4)... discarding message


Regards,

Muhammad Sharfuddin

_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems
Re: SAPInstance does not start and asking for START_PROFILE [ In reply to ]
On 01/15/2015 01:07 AM, Muhammad Sharfuddin wrote:
>
> On 01/15/2015 12:46 AM, Fabian Herschel wrote:
> > Hi Muhammad,
> >
> > could you try:
> > primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
> > op monitor interval="120" timeout="60" \
> > op start interval="0" timeout="300" \
> > op stop interval="0" timeout="300" \
> > params InstanceName="TLP_DVEBMGS00_thltlp"
> > DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
> > START_PROFILE="/sapmnt/TLP/profile/TLP_DVEBMGS00_thltlp"
> >
> > Or even let the parameters DIR_EXECUTABLE and START_PROFILE unset,
so SAPInstance could use the automatical detection.
> >
> > If you set the param START_PROFILE it must be a full file path NOT
relative to DIR_PROFILE.
> >
> > Hope that helps
> > Best regards
> > Fabian
> >
> > On 01/14/2015 08:12 PM, Muhammad Sharfuddin wrote:
> >> OS: SLES 11 SP 3
> >> pacemaker-1.1.9-0.19.102
> >> corosync-1.4.5-0.18.15
> >> resource-agents-3.9.5-0.32.22
> >>
> >> starting the SAP Instance resource fails with following errors:
> >>
> >> Jan 14 18:22:16 thltlp1 SAPInstance(SAPInst-DVEBMGS00)[50450]: ERROR:
> >> Expected
> >> TLP_DVEBMGS00_thltlp to be the instance START profile, please set
> >> START_PROFILE
> >> parameter!
> >> Jan 14 18:22:16 thltlp1 crmd[47231]: notice: process_lrm_event: LRM
> >> operation
> >> SAPInst-DVEBMGS00_start_0 (call=81, rc=6, cib-update=66,
confirmed=true)
> >> not configured
> >>
> >> following is the resource configurations:
> >> primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
> >> op monitor interval="120" timeout="60" \
> >> op start interval="0" timeout="300" \
> >> op stop interval="0" timeout="300" \
> >> params InstanceName="TLP_DVEBMGS00_thltlp"
> >> DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
> >> START_PROFILE="TLP_DVEBMGS00_thltlp" DIR_PROFILE="/sapmnt/TLP/profile"
> >>
> >> i.e START_PROFILE is configured but cluster is not starting the SAP
> >> Instance.
> >>
> >> Please help
> >
>
> provide the full path, and now error changed. It became:
>
> Jan 15 00:54:04 thltlp2 cibadmin[24511]: notice: crm_log_args:
Invoked: cibadmin -p -R -o resources
> Jan 15 00:54:04 thltlp2 SAPInstance(SAPInst-DVEBMGS00)[22589]: ERROR:
SAP Instance TLP-DVEBMGS00 start
> failed: 15.01.2015 00:54:04 WaitforStarted FAIL: process disp+work
Dispatcher not running
> Jan 15 00:54:04 thltlp2 crmd[2778]: warning: do_update_resource:
Resource SAPInst-DVEBMGS00 no longer
> exists in the lrmd
> Jan 15 00:54:04 thltlp2 crmd[2778]: notice: process_lrm_event: LRM
operation SAPInst-DVEBMGS00_start_0
> (call=176, rc=7, cib-update=0, confirmed=true) not running
> Jan 15 00:54:04 thltlp2 crmd[2778]: warning: decode_transition_key:
Bad UUID (crm_resource.c) in sscanf
> result (4) for 24450:0:0:crm_resource.c
> Jan 15 00:54:04 thltlp2 crmd[2778]: error: send_msg_via_ipc:
Unknown Sub-system
> (9f52a2cf-6c1d-453d-bc1b-90322f3147f4)... discarding message
>
>
> Regards,
>
> Muhammad Sharfuddin

also note that I can very easily start the SAP without any issue via
running following command:
startsap -i DVEBMGS00 -v thltlp

--
Regards,

Muhammad Sharfuddin


_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems
Re: SAPInstance does not start and asking for START_PROFILE [ In reply to ]
Hi Muhammed,

sorry please do NOT use startsap. Please use sapctrl.
sapctrl -nr 00 -function Start
Check the started processes using
sapctrl -nr 00 -function GetProcessList

If disp+work processes are not starting than you might need to check the reason in the work directory of the SAP NetWaver instance.  

Regards
Fabian



Von Samsung-Tablet gesendet

-------- Ursprüngliche Nachricht --------
Von: Muhammad Sharfuddin <M.Sharfuddin@nds.com.pk>
Datum:14.01.2015 21:13 (GMT+01:00)
An: linux-ha@lists.linux-ha.org
Betreff: Re: [Linux-HA] SAPInstance does not start and asking for START_PROFILE

On 01/15/2015 01:07 AM, Muhammad Sharfuddin wrote:
>
> On 01/15/2015 12:46 AM, Fabian Herschel wrote:
> > Hi Muhammad,
> >
> > could you try:
> > primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
> > op monitor interval="120" timeout="60" \
> > op start interval="0" timeout="300" \
> > op stop interval="0" timeout="300" \
> > params InstanceName="TLP_DVEBMGS00_thltlp"
> > DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
> > START_PROFILE="/sapmnt/TLP/profile/TLP_DVEBMGS00_thltlp"
> >
> > Or even let the parameters DIR_EXECUTABLE and START_PROFILE unset,
so SAPInstance could use the automatical detection.
> >
> > If you set the param START_PROFILE it must be a full file path NOT
relative to DIR_PROFILE.
> >
> > Hope that helps
> > Best regards
> > Fabian
> >
> > On 01/14/2015 08:12 PM, Muhammad Sharfuddin wrote:
> >> OS: SLES 11 SP 3
> >> pacemaker-1.1.9-0.19.102
> >> corosync-1.4.5-0.18.15
> >> resource-agents-3.9.5-0.32.22
> >>
> >> starting the SAP Instance resource fails with following errors:
> >>
> >> Jan 14 18:22:16 thltlp1 SAPInstance(SAPInst-DVEBMGS00)[50450]: ERROR:
> >> Expected
> >> TLP_DVEBMGS00_thltlp to be the instance START profile, please set
> >> START_PROFILE
> >> parameter!
> >> Jan 14 18:22:16 thltlp1 crmd[47231]: notice: process_lrm_event: LRM
> >> operation
> >> SAPInst-DVEBMGS00_start_0 (call=81, rc=6, cib-update=66,
confirmed=true)
> >> not configured
> >>
> >> following is the resource configurations:
> >> primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
> >> op monitor interval="120" timeout="60" \
> >> op start interval="0" timeout="300" \
> >> op stop interval="0" timeout="300" \
> >> params InstanceName="TLP_DVEBMGS00_thltlp"
> >> DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
> >> START_PROFILE="TLP_DVEBMGS00_thltlp" DIR_PROFILE="/sapmnt/TLP/profile"
> >>
> >> i.e START_PROFILE is configured but cluster is not starting the SAP
> >> Instance.
> >>
> >> Please help
> >
>
> provide the full path, and now error changed. It became:
>
> Jan 15 00:54:04 thltlp2 cibadmin[24511]: notice: crm_log_args:
Invoked: cibadmin -p -R -o resources
> Jan 15 00:54:04 thltlp2 SAPInstance(SAPInst-DVEBMGS00)[22589]: ERROR:
SAP Instance TLP-DVEBMGS00 start
> failed: 15.01.2015 00:54:04 WaitforStarted FAIL: process disp+work
Dispatcher not running
> Jan 15 00:54:04 thltlp2 crmd[2778]: warning: do_update_resource:
Resource SAPInst-DVEBMGS00 no longer
> exists in the lrmd
> Jan 15 00:54:04 thltlp2 crmd[2778]: notice: process_lrm_event: LRM
operation SAPInst-DVEBMGS00_start_0
> (call=176, rc=7, cib-update=0, confirmed=true) not running
> Jan 15 00:54:04 thltlp2 crmd[2778]: warning: decode_transition_key:
Bad UUID (crm_resource.c) in sscanf
> result (4) for 24450:0:0:crm_resource.c
> Jan 15 00:54:04 thltlp2 crmd[2778]: error: send_msg_via_ipc:
Unknown Sub-system
> (9f52a2cf-6c1d-453d-bc1b-90322f3147f4)... discarding message
>
>
> Regards,
>
> Muhammad Sharfuddin

also note that I can very easily start the SAP without any issue via
running following command:
startsap -i DVEBMGS00 -v thltlp

--
Regards,

Muhammad Sharfuddin


_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems
_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems
Re: SAPInstance does not start and asking for START_PROFILE [ In reply to ]
On 01/15/2015 02:35 AM, Fabian Herschel wrote:
> Hi Muhammed,
>
> sorry please do NOT use startsap. Please use sapctrl.
> sapctrl -nr 00 -function Start
> Check the started processes using
> sapctrl -nr 00 -function GetProcessList
>
I dont find the sapctrl command available on the system.

>
> If disp+work processes are not starting than you might need to check
the reason in the work directory of the SAP NetWaver instance.
>
Thanks for the pointer, I'll get this check with SAP Guys

> Regards
> Fabian
>
>
--
Regards,
Muhammad Sharfuddin
>
> -------- Ursprüngliche Nachricht --------
> Von: Muhammad Sharfuddin <M.Sharfuddin@nds.com.pk>
> Datum:14.01.2015 21:13 (GMT+01:00)
> An: linux-ha@lists.linux-ha.org
> Betreff: Re: [Linux-HA] SAPInstance does not start and asking for
> START_PROFILE
>
> On 01/15/2015 01:07 AM, Muhammad Sharfuddin wrote:
>>
>> On 01/15/2015 12:46 AM, Fabian Herschel wrote:
>>> Hi Muhammad,
>>>
>>> could you try:
>>> primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
>>> op monitor interval="120" timeout="60" \
>>> op start interval="0" timeout="300" \
>>> op stop interval="0" timeout="300" \
>>> params InstanceName="TLP_DVEBMGS00_thltlp"
>>> DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
>>> START_PROFILE="/sapmnt/TLP/profile/TLP_DVEBMGS00_thltlp"
>>>
>>> Or even let the parameters DIR_EXECUTABLE and START_PROFILE unset,
> so SAPInstance could use the automatical detection.
>>>
>>> If you set the param START_PROFILE it must be a full file path NOT
> relative to DIR_PROFILE.
>>>
>>> Hope that helps
>>> Best regards
>>> Fabian
>>>
>>> On 01/14/2015 08:12 PM, Muhammad Sharfuddin wrote:
>>>> OS: SLES 11 SP 3
>>>> pacemaker-1.1.9-0.19.102
>>>> corosync-1.4.5-0.18.15
>>>> resource-agents-3.9.5-0.32.22
>>>>
>>>> starting the SAP Instance resource fails with following errors:
>>>>
>>>> Jan 14 18:22:16 thltlp1 SAPInstance(SAPInst-DVEBMGS00)[50450]: ERROR:
>>>> Expected
>>>> TLP_DVEBMGS00_thltlp to be the instance START profile, please set
>>>> START_PROFILE
>>>> parameter!
>>>> Jan 14 18:22:16 thltlp1 crmd[47231]: notice: process_lrm_event: LRM
>>>> operation
>>>> SAPInst-DVEBMGS00_start_0 (call=81, rc=6, cib-update=66,
> confirmed=true)
>>>> not configured
>>>>
>>>> following is the resource configurations:
>>>> primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
>>>> op monitor interval="120" timeout="60" \
>>>> op start interval="0" timeout="300" \
>>>> op stop interval="0" timeout="300" \
>>>> params InstanceName="TLP_DVEBMGS00_thltlp"
>>>> DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
>>>> START_PROFILE="TLP_DVEBMGS00_thltlp" DIR_PROFILE="/sapmnt/TLP/profile"
>>>>
>>>> i.e START_PROFILE is configured but cluster is not starting the SAP
>>>> Instance.
>>>>
>>>> Please help
>>>
>>
>> provide the full path, and now error changed. It became:
>>
>> Jan 15 00:54:04 thltlp2 cibadmin[24511]: notice: crm_log_args:
> Invoked: cibadmin -p -R -o resources
>> Jan 15 00:54:04 thltlp2 SAPInstance(SAPInst-DVEBMGS00)[22589]: ERROR:
> SAP Instance TLP-DVEBMGS00 start
>> failed: 15.01.2015 00:54:04 WaitforStarted FAIL: process disp+work
> Dispatcher not running
>> Jan 15 00:54:04 thltlp2 crmd[2778]: warning: do_update_resource:
> Resource SAPInst-DVEBMGS00 no longer
>> exists in the lrmd
>> Jan 15 00:54:04 thltlp2 crmd[2778]: notice: process_lrm_event: LRM
> operation SAPInst-DVEBMGS00_start_0
>> (call=176, rc=7, cib-update=0, confirmed=true) not running
>> Jan 15 00:54:04 thltlp2 crmd[2778]: warning: decode_transition_key:
> Bad UUID (crm_resource.c) in sscanf
>> result (4) for 24450:0:0:crm_resource.c
>> Jan 15 00:54:04 thltlp2 crmd[2778]: error: send_msg_via_ipc:
> Unknown Sub-system
>> (9f52a2cf-6c1d-453d-bc1b-90322f3147f4)... discarding message
>>
>>
>> Regards,
>>
>> Muhammad Sharfuddin
>
> also note that I can very easily start the SAP without any issue via
> running following command:
> startsap -i DVEBMGS00 -v thltlp
>

_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems
Re: SAPInstance does not start and asking for START_PROFILE [ In reply to ]
Please ask the sap guys which version of sap netweaver and which sap kernel you are using.
Regards
Fabian




Von Samsung-Tablet gesendet

-------- Ursprüngliche Nachricht --------
Von: Muhammad Sharfuddin <M.Sharfuddin@nds.com.pk>
Datum:14.01.2015 22:53 (GMT+01:00)
An: linux-ha@lists.linux-ha.org
Betreff: Re: [Linux-HA] SAPInstance does not start and asking for START_PROFILE

On 01/15/2015 02:35 AM, Fabian Herschel wrote:
> Hi Muhammed,
>
> sorry please do NOT use startsap. Please use sapctrl.
> sapctrl -nr 00 -function Start
> Check the started processes using
> sapctrl -nr 00 -function GetProcessList
>
I dont find the sapctrl command available on the system.

>
> If disp+work processes are not starting than you might need to check
the reason in the work directory of the SAP NetWaver instance.
>
Thanks for the pointer, I'll get this check with SAP Guys

> Regards
> Fabian
>
>
--
Regards,
Muhammad Sharfuddin
>
> -------- Ursprüngliche Nachricht --------
> Von: Muhammad Sharfuddin <M.Sharfuddin@nds.com.pk>
> Datum:14.01.2015 21:13 (GMT+01:00)
> An: linux-ha@lists.linux-ha.org
> Betreff: Re: [Linux-HA] SAPInstance does not start and asking for
> START_PROFILE
>
> On 01/15/2015 01:07 AM, Muhammad Sharfuddin wrote:
>>
>> On 01/15/2015 12:46 AM, Fabian Herschel wrote:
>>> Hi Muhammad,
>>>
>>> could you try:
>>> primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
>>> op monitor interval="120" timeout="60" \
>>> op start interval="0" timeout="300" \
>>> op stop interval="0" timeout="300" \
>>> params InstanceName="TLP_DVEBMGS00_thltlp"
>>> DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
>>> START_PROFILE="/sapmnt/TLP/profile/TLP_DVEBMGS00_thltlp"
>>>
>>> Or even let the parameters DIR_EXECUTABLE and START_PROFILE unset,
> so SAPInstance could use the automatical detection.
>>>
>>> If you set the param START_PROFILE it must be a full file path NOT
> relative to DIR_PROFILE.
>>>
>>> Hope that helps
>>> Best regards
>>> Fabian
>>>
>>> On 01/14/2015 08:12 PM, Muhammad Sharfuddin wrote:
>>>> OS: SLES 11 SP 3
>>>> pacemaker-1.1.9-0.19.102
>>>> corosync-1.4.5-0.18.15
>>>> resource-agents-3.9.5-0.32.22
>>>>
>>>> starting the SAP Instance resource fails with following errors:
>>>>
>>>> Jan 14 18:22:16 thltlp1 SAPInstance(SAPInst-DVEBMGS00)[50450]: ERROR:
>>>> Expected
>>>> TLP_DVEBMGS00_thltlp to be the instance START profile, please set
>>>> START_PROFILE
>>>> parameter!
>>>> Jan 14 18:22:16 thltlp1 crmd[47231]: notice: process_lrm_event: LRM
>>>> operation
>>>> SAPInst-DVEBMGS00_start_0 (call=81, rc=6, cib-update=66,
> confirmed=true)
>>>> not configured
>>>>
>>>> following is the resource configurations:
>>>> primitive SAPInst-DVEBMGS00 ocf:heartbeat:SAPInstance \
>>>> op monitor interval="120" timeout="60" \
>>>> op start interval="0" timeout="300" \
>>>> op stop interval="0" timeout="300" \
>>>> params InstanceName="TLP_DVEBMGS00_thltlp"
>>>> DIR_EXECUTABLE="/usr/sap/TLP/DVEBMGS00/exe"
>>>> START_PROFILE="TLP_DVEBMGS00_thltlp" DIR_PROFILE="/sapmnt/TLP/profile"
>>>>
>>>> i.e START_PROFILE is configured but cluster is not starting the SAP
>>>> Instance.
>>>>
>>>> Please help
>>>
>>
>> provide the full path, and now error changed. It became:
>>
>> Jan 15 00:54:04 thltlp2 cibadmin[24511]: notice: crm_log_args:
> Invoked: cibadmin -p -R -o resources
>> Jan 15 00:54:04 thltlp2 SAPInstance(SAPInst-DVEBMGS00)[22589]: ERROR:
> SAP Instance TLP-DVEBMGS00 start
>> failed: 15.01.2015 00:54:04 WaitforStarted FAIL: process disp+work
> Dispatcher not running
>> Jan 15 00:54:04 thltlp2 crmd[2778]: warning: do_update_resource:
> Resource SAPInst-DVEBMGS00 no longer
>> exists in the lrmd
>> Jan 15 00:54:04 thltlp2 crmd[2778]: notice: process_lrm_event: LRM
> operation SAPInst-DVEBMGS00_start_0
>> (call=176, rc=7, cib-update=0, confirmed=true) not running
>> Jan 15 00:54:04 thltlp2 crmd[2778]: warning: decode_transition_key:
> Bad UUID (crm_resource.c) in sscanf
>> result (4) for 24450:0:0:crm_resource.c
>> Jan 15 00:54:04 thltlp2 crmd[2778]: error: send_msg_via_ipc:
> Unknown Sub-system
>> (9f52a2cf-6c1d-453d-bc1b-90322f3147f4)... discarding message
>>
>>
>> Regards,
>>
>> Muhammad Sharfuddin
>
> also note that I can very easily start the SAP without any issue via
> running following command:
> startsap -i DVEBMGS00 -v thltlp
>

_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems
_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems
Re: SAPInstance does not start and asking for START_PROFILE [ In reply to ]
On 01/14/2015 10:53 PM, Muhammad Sharfuddin wrote:
> On 01/15/2015 02:35 AM, Fabian Herschel wrote:
> > Hi Muhammed,
> >
> > sorry please do NOT use startsap. Please use sapctrl.
> > sapctrl -nr 00 -function Start
> > Check the started processes using
> > sapctrl -nr 00 -function GetProcessList
> >
> I dont find the sapctrl command available on the system.

Sorry the command is sapcontrol (I abbreviated the control to ctrl)
From the SAPInstance resource agent:
SAPCONTROL="/usr/sap/$SID/$InstanceName/exe/sapcontrol

>
> >
> > If disp+work processes are not starting than you might need to check
> the reason in the work directory of the SAP NetWaver instance.
> >
> Thanks for the pointer, I'll get this check with SAP Guys
>
> > Regards
> > Fabian
> >
> >

_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems
Re: SAPInstance does not start and asking for START_PROFILE [ In reply to ]
Hi Muhammad,

please ask the SAP Guys what they have changed. Did they install the
sapstartsrv or saphostagent?

Threads should not stop with "its working now, but I could not explain
what we have changed" :) This stops others to learn from this situation.

Regards
Fabian


On 01/15/2015 04:12 PM, Muhammad Sharfuddin wrote:
> Thanks for your excellent help, appreciated.
>
> I dont know what happened exactly, seems like SAP Guys has fixed the
> issue as now cluster start running the SAPInstance without any issue.
> Also find below the sapcontrol output
>
> thltlp2:tlpadm 48> /usr/sap/TLP/DVEBMGS00/exe/sapcontrol -nr 00
> -function GetProcessList
>
> 15.01.2015 19:40:04
> GetProcessList
> OK
> name, description, dispstatus, textstatus, starttime, elapsedtime, pid
> disp+work, Dispatcher, GREEN, Running, 2015 01 15 19:27:24, 0:12:40, 10920
> igswd_mt, IGS Watchdog, GREEN, Running, 2015 01 15 19:27:24, 0:12:40, 10921
> gwrd, Gateway, GREEN, Running, 2015 01 15 19:27:25, 0:12:39, 10938
> icman, ICM, GREEN, Running, 2015 01 15 19:27:25, 0:12:39, 10939
> thltlp2:tlpadm 49>
>
>
> Thanks once again.
>
> Regards,
>
> Muhammad Sharfuddin
> Cell: +92-3332144823 | UAN: +92(21) 111-111-142 ext: 113 | NDS.COM.PK
> <http://www.nds.com.pk>
>
> On 01/15/2015 03:57 PM, Fabian Herschel wrote:
>> Hi Muhammad,
>>
>> please retry the command as user <sid>adm. Or inspect the resource
>> agent for ALL environment variables to be set, not only LD_LIBRARY_PATH
>>
>> If sapcontrol would be disfunctional using <sid>adm you have a SAP
>> problem and that could not be disussed here.
>>
>> Regards
>> Fabian
>>
>> On 01/15/2015 11:49 AM, Muhammad Sharfuddin wrote:
>>> thltlp1:~ # echo $LD_LIBRARY_PATH
>>> /usr/sap/TLP/ASCS01/exe/:/usr/sap/TLP/DVEBMGS00/exe:/usr/lib64
>>> thltlp1:~ # /usr/sap/TLP/DVEBMGS00/exe/sapcontrol -nr 00 -function Start
>>> Could not open the ICU common library.
>>> The following files must be in the path described by
>>> the environment variable "LD_LIBRARY_PATH":
>>> libicuuc.so.50, libicudata.so.50, libicui18n.so.50
>>> [/bas/741_REL/src/flat/nlsui0.c 1535] pid = 27543
>>> LD_LIBRARY_PATH is currently set to <not set>
>>> [/bas/741_REL/src/flat/nlsui0.c 1538] pid = 27543
>>> thltlp1:~ #
>>>
>>> please help
>>>
>>>
>>> Regards,
>>>
>>> Muhammad Sharfuddin
>>> Cell: +92-3332144823 | UAN: +92(21) 111-111-142 ext: 113 | NDS.COM.PK
>>> <http://www.nds.com.pk>
>>>
>>> On 01/15/2015 02:15 PM, Fabian Herschel wrote:
>>>> On 01/14/2015 10:53 PM, Muhammad Sharfuddin wrote:
>>>>> On 01/15/2015 02:35 AM, Fabian Herschel wrote:
>>>>> > Hi Muhammed,
>>>>> >
>>>>> > sorry please do NOT use startsap. Please use sapctrl.
>>>>> > sapctrl -nr 00 -function Start
>>>>> > Check the started processes using
>>>>> > sapctrl -nr 00 -function GetProcessList
>>>>> >
>>>>> I dont find the sapctrl command available on the system.
>>>>
>>>> Sorry the command is sapcontrol (I abbreviated the control to ctrl)
>>>> From the SAPInstance resource agent:
>>>> SAPCONTROL="/usr/sap/$SID/$InstanceName/exe/sapcontrol
>>>>
>>>>>
>>>>> >
>>>>> > If disp+work processes are not starting than you might need to
>>>>> check
>>>>> the reason in the work directory of the SAP NetWaver instance.
>>>>> >
>>>>> Thanks for the pointer, I'll get this check with SAP Guys
>>>>>
>>>>> > Regards
>>>>> > Fabian
>>>>> >
>>>>> >
>>>>
>>>> _______________________________________________
>>>> Linux-HA mailing list
>>>> Linux-HA@lists.linux-ha.org
>>>> http://lists.linux-ha.org/mailman/listinfo/linux-ha
>>>> See also: http://linux-ha.org/ReportingProblems
>>>>
>>>
>>
>>
>

_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems