Mailing List Archive

Resource too active / vsftpd ubuntu 10.04
Hi.I'm getting the error "Resource too active" on several standard ubuntu 10.04 startup scripts, like nmbd, smbd, vsftpd and winbind.I didn't test with ocf-tester but it looks very strange to me that they're not ocf standard!I configured them this way:primitive Cluster-smbd upstart:smbd \
op start interval="0" timeout="120s" \
op stop interval="0" timeout="120s" \
op monitor interval="30s" \
meta target-role="Started"

When I restart the second node I get the following in syslog:Jun 10 15:55:09 ubuntu pengine: [863]: notice: unpack_rsc_op: Operation Cluster-nmbd_last_failure_0 found resource Cluster-nmbd active on ubuntuJun 10 15:55:09 ubuntu pengine: [863]: ERROR: native_create_actions: Resource Cluster-nmbd (upstart::nmbd) is active on 2 nodes attempting recoveryJun 10 15:55:09 ubuntu pengine: [863]: WARN: See http://clusterlabs.org/wiki/FAQ#Resource_is_Too_Active for more information.

And resources are restarted...Is this correct?thanks
_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems
Re: Resource too active / vsftpd ubuntu 10.04 [ In reply to ]
On Mon, Jun 11, 2012 at 1:52 AM, Luca Meron <ckslxpcjus@hotmail.it> wrote:
>
> Hi.I'm getting the error "Resource too active" on several standard ubuntu 10.04 startup scripts, like nmbd, smbd, vsftpd and winbind.I didn't test with ocf-tester but it looks very strange to me that they're not ocf standard!I

Because they're init/upstart scripts, not OCF ones (which have a
completely different API).

> configured them this way:primitive Cluster-smbd upstart:smbd \
>        op start interval="0" timeout="120s" \
>        op stop interval="0" timeout="120s" \
>        op monitor interval="30s" \
>        meta target-role="Started"
>
> When I restart the second node I get the following in syslog:Jun 10 15:55:09 ubuntu pengine: [863]: notice: unpack_rsc_op: Operation Cluster-nmbd_last_failure_0 found resource Cluster-nmbd active on ubuntuJun 10 15:55:09 ubuntu pengine: [863]: ERROR: native_create_actions: Resource Cluster-nmbd (upstart::nmbd) is active on 2 nodes attempting recoveryJun 10 15:55:09 ubuntu pengine: [863]: WARN: See http://clusterlabs.org/wiki/FAQ#Resource_is_Too_Active for more information.

And you read that link?
Specifically the bit that says "Check you are _not_ starting it on boot"

>
> And resources are restarted...Is this correct?thanks
> _______________________________________________
> Linux-HA mailing list
> Linux-HA@lists.linux-ha.org
> http://lists.linux-ha.org/mailman/listinfo/linux-ha
> See also: http://linux-ha.org/ReportingProblems
_______________________________________________
Linux-HA mailing list
Linux-HA@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems