Mailing List Archive

3.10 kernel: [drm:evergreen_startup] *ERROR* radeon: error initializing UVD (-1).
Hello,

I use an ATI graphics card (PCI-e x1) for a server:
Card: [AMD/ATI] Park [Mobility Radeon HD 5430]

I upgraded my kernel from 3.9.x to 3.10, after rebooting I found the driver
now wants a new firmware:
radeon 0000:05:00.0: radeon_uvd: Can't load firmware
"radeon/CYPRESS_uvd.bin"

I pulled the latest firmware down (and also updated the others) and
rebooted:
CONFIG_EXTRA_FIRMWARE="radeon/CEDAR_me.bin radeon/CEDAR_pfp.bin
radeon/CEDAR_rlc.bin radeon/CYPRESS_uvd.bin"

Then have this issue:
[drm] radeon: irq initialized.
[drm:evergreen_startup] *ERROR* radeon: error initializing UVD (-1).

The screen goes black for ~5 seconds and then come back on.
Not sure if this has been reported or not (w/CEDAR chipset) but FYI.

Kernel config:
http://home.comcast.net/~jpiszcz/20130702/config-3.10-4.txt

Full dmesg:
http://home.comcast.net/~jpiszcz/20130702/full-dmesg.txt

Possibly related:
http://lists.opensuse.org/opensuse-bugs/2013-06/msg00053.html
https://bugzilla.novell.com/show_bug.cgi?id=822777
https://bugzilla.novell.com/show_bug.cgi?id=822777#c0
http://www.mail-archive.com/dri-devel@lists.freedesktop.org/msg38066.html
https://bugs.freedesktop.org/show_bug.cgi?id=63935

Snippet:
[ 2.033535] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
reset the VCPU!!!
[ 3.053742] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
reset the VCPU!!!
[ 4.073985] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
reset the VCPU!!!
[ 5.094192] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
reset the VCPU!!!
[ 6.114405] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
reset the VCPU!!!
[ 7.134611] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
reset the VCPU!!!
[ 8.154824] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
reset the VCPU!!!
[ 9.175044] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
reset the VCPU!!!
[ 10.195251] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
reset the VCPU!!!
[ 11.215464] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
reset the VCPU!!!
[ 11.235537] [drm:r600_uvd_init] *ERROR* UVD not responding, giving up!!!
[ 11.235607] [drm:evergreen_startup] *ERROR* radeon: error initializing
UVD (-1).

Justin.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Re: 3.10 kernel: [drm:evergreen_startup] *ERROR* radeon: error initializing UVD (-1). [ In reply to ]
On Tue, Jul 2, 2013 at 2:33 PM, Justin Piszcz <jpiszcz@lucidpixels.com> wrote:
> Hello,
>
> I use an ATI graphics card (PCI-e x1) for a server:
> Card: [AMD/ATI] Park [Mobility Radeon HD 5430]
>
> I upgraded my kernel from 3.9.x to 3.10, after rebooting I found the driver
> now wants a new firmware:
> radeon 0000:05:00.0: radeon_uvd: Can't load firmware
> "radeon/CYPRESS_uvd.bin"
>
> I pulled the latest firmware down (and also updated the others) and
> rebooted:
> CONFIG_EXTRA_FIRMWARE="radeon/CEDAR_me.bin radeon/CEDAR_pfp.bin
> radeon/CEDAR_rlc.bin radeon/CYPRESS_uvd.bin"
>
> Then have this issue:
> [drm] radeon: irq initialized.
> [drm:evergreen_startup] *ERROR* radeon: error initializing UVD (-1).
>
> The screen goes black for ~5 seconds and then come back on.
> Not sure if this has been reported or not (w/CEDAR chipset) but FYI.

Make sure you have the the latest CEDAR_rlc.bin in addition to
CYPRESS_uvd.bin and make sure the latest images are available in your
initrd or kernel image, etc.

Alex


>
> Kernel config:
> http://home.comcast.net/~jpiszcz/20130702/config-3.10-4.txt
>
> Full dmesg:
> http://home.comcast.net/~jpiszcz/20130702/full-dmesg.txt
>
> Possibly related:
> http://lists.opensuse.org/opensuse-bugs/2013-06/msg00053.html
> https://bugzilla.novell.com/show_bug.cgi?id=822777
> https://bugzilla.novell.com/show_bug.cgi?id=822777#c0
> http://www.mail-archive.com/dri-devel@lists.freedesktop.org/msg38066.html
> https://bugs.freedesktop.org/show_bug.cgi?id=63935
>
> Snippet:
> [ 2.033535] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
> reset the VCPU!!!
> [ 3.053742] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
> reset the VCPU!!!
> [ 4.073985] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
> reset the VCPU!!!
> [ 5.094192] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
> reset the VCPU!!!
> [ 6.114405] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
> reset the VCPU!!!
> [ 7.134611] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
> reset the VCPU!!!
> [ 8.154824] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
> reset the VCPU!!!
> [ 9.175044] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
> reset the VCPU!!!
> [ 10.195251] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
> reset the VCPU!!!
> [ 11.215464] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to
> reset the VCPU!!!
> [ 11.235537] [drm:r600_uvd_init] *ERROR* UVD not responding, giving up!!!
> [ 11.235607] [drm:evergreen_startup] *ERROR* radeon: error initializing
> UVD (-1).
>
> Justin.
>
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/dri-devel
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
RE: 3.10 kernel: [drm:evergreen_startup] *ERROR* radeon: error initializing UVD (-1). [ In reply to ]
-----Original Message-----
From: Alex Deucher [mailto:alexdeucher@gmail.com]
Sent: Tuesday, July 02, 2013 2:36 PM
To: Justin Piszcz
Cc: linux-kernel@vger.kernel.org; dri-devel@lists.freedesktop.org
Subject: Re: 3.10 kernel: [drm:evergreen_startup] *ERROR* radeon: error
initializing UVD (-1).

> The screen goes black for ~5 seconds and then come back on.
> Not sure if this has been reported or not (w/CEDAR chipset) but FYI.

Make sure you have the the latest CEDAR_rlc.bin in addition to
CYPRESS_uvd.bin and make sure the latest images are available in your
initrd or kernel image, etc.

Alex

--

Hi,

Even with the latest (confirmed below) and built-in to the kernel:

$ git clone
git://git.kernel.org/pub/scm/linux/kernel/git/dwmw2/linux-firmware.git
Cloning into 'linux-firmware'...
remote: Counting objects: 2210, done.
remote: Compressing objects: 100% (1102/1102), done.
remote: Total 2210 (delta 1123), reused 2113 (delta 1073)
Receiving objects: 100% (2210/2210), 39.84 MiB | 6.49 MiB/s, done.
Resolving deltas: 100% (1123/1123), done.
$ date
Tue Jul 2 14:39:19 EDT 2013

2b244d41832f46382bfbb8994522dcdd d/linux-firmware/radeon/CEDAR_me.bin
23915e382ea0d2f2491a19146ca3001c d/linux-firmware/radeon/CEDAR_pfp.bin
e8770d3d588f24dc6f1a8609c9db3467 d/linux-firmware/radeon/CEDAR_rlc.bin
fb23b281dcc94a035d374e709c9842bd d/linux-firmware/radeon/CYPRESS_uvd.bin

Current system firmware (/lib/firmware/radeon):
$ for i in $CONFIG_EXTRA_FIRMWARE; do md5sum $i; done
2b244d41832f46382bfbb8994522dcdd radeon/CEDAR_me.bin
23915e382ea0d2f2491a19146ca3001c radeon/CEDAR_pfp.bin
e8770d3d588f24dc6f1a8609c9db3467 radeon/CEDAR_rlc.bin
fb23b281dcc94a035d374e709c9842bd radeon/CYPRESS_uvd.bin

CONFIG_EXTRA_FIRMWARE="radeon/CEDAR_me.bin radeon/CEDAR_pfp.bin
radeon/CEDAR_rlc.bin radeon/CYPRESS_uvd.bin"

Same issue.

Justin.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Re: 3.10 kernel: [drm:evergreen_startup] *ERROR* radeon: error initializing UVD (-1). [ In reply to ]
On Tue, Jul 2, 2013 at 2:44 PM, Justin Piszcz <jpiszcz@lucidpixels.com> wrote:
>
>
> -----Original Message-----
> From: Alex Deucher [mailto:alexdeucher@gmail.com]
> Sent: Tuesday, July 02, 2013 2:36 PM
> To: Justin Piszcz
> Cc: linux-kernel@vger.kernel.org; dri-devel@lists.freedesktop.org
> Subject: Re: 3.10 kernel: [drm:evergreen_startup] *ERROR* radeon: error
> initializing UVD (-1).
>
>> The screen goes black for ~5 seconds and then come back on.
>> Not sure if this has been reported or not (w/CEDAR chipset) but FYI.
>
> Make sure you have the the latest CEDAR_rlc.bin in addition to
> CYPRESS_uvd.bin and make sure the latest images are available in your
> initrd or kernel image, etc.
>
> Alex
>
> --
>
> Hi,
>
> Even with the latest (confirmed below) and built-in to the kernel:
>
> $ git clone
> git://git.kernel.org/pub/scm/linux/kernel/git/dwmw2/linux-firmware.git
> Cloning into 'linux-firmware'...
> remote: Counting objects: 2210, done.
> remote: Compressing objects: 100% (1102/1102), done.
> remote: Total 2210 (delta 1123), reused 2113 (delta 1073)
> Receiving objects: 100% (2210/2210), 39.84 MiB | 6.49 MiB/s, done.
> Resolving deltas: 100% (1123/1123), done.
> $ date
> Tue Jul 2 14:39:19 EDT 2013
>
> 2b244d41832f46382bfbb8994522dcdd d/linux-firmware/radeon/CEDAR_me.bin
> 23915e382ea0d2f2491a19146ca3001c d/linux-firmware/radeon/CEDAR_pfp.bin
> e8770d3d588f24dc6f1a8609c9db3467 d/linux-firmware/radeon/CEDAR_rlc.bin
> fb23b281dcc94a035d374e709c9842bd d/linux-firmware/radeon/CYPRESS_uvd.bin
>
> Current system firmware (/lib/firmware/radeon):
> $ for i in $CONFIG_EXTRA_FIRMWARE; do md5sum $i; done
> 2b244d41832f46382bfbb8994522dcdd radeon/CEDAR_me.bin
> 23915e382ea0d2f2491a19146ca3001c radeon/CEDAR_pfp.bin
> e8770d3d588f24dc6f1a8609c9db3467 radeon/CEDAR_rlc.bin
> fb23b281dcc94a035d374e709c9842bd radeon/CYPRESS_uvd.bin
>
> CONFIG_EXTRA_FIRMWARE="radeon/CEDAR_me.bin radeon/CEDAR_pfp.bin
> radeon/CEDAR_rlc.bin radeon/CYPRESS_uvd.bin"
>
> Same issue.

Please open a bug (product: DRI, component: DRM/Radeon):
https://bugs.freedesktop.org
and attach your dmesg output and xorg log.

Alex
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/