Mailing List Archive

iwlagn regression in v3.1.5
Hello,

there in an regression in kernel release v3.1.5. Commit
43c308bd8d0a3e7d98c5abcd41a4a3fada3d198f "iwlwifi: do not re-configure
HT40 after associated" break iwlagn driver for Intel Corporation
Centrino Ultimate-N 6300 (rev 35) on my Thinkpad t510. I still can
connect to the AP, but i can't pin or access anything. Reverting that
commit solved the Problem. I attached the patch.

Regards,
Andrej Gelenberg
Re: iwlagn regression in v3.1.5 [ In reply to ]
Hello,

the original commit 34a5b4b6af104cf18eb50748509528b9bdbc4036 in upstream
(v3.2.0-rc5) break the driver too. Please revert it, before the release.
Patch for 3.2-rc5 attached.

Regards,
Andrej Gelenberg

On 12/11/2011 02:24 PM, Andrej Gelenberg wrote:
> Hello,
>
> there in an regression in kernel release v3.1.5. Commit
> 43c308bd8d0a3e7d98c5abcd41a4a3fada3d198f "iwlwifi: do not re-configure
> HT40 after associated" break iwlagn driver for Intel Corporation
> Centrino Ultimate-N 6300 (rev 35) on my Thinkpad t510. I still can
> connect to the AP, but i can't pin or access anything. Reverting that
> commit solved the Problem. I attached the patch.
>
> Regards,
> Andrej Gelenberg
Re: iwlagn regression in v3.1.5 [ In reply to ]
Hi,

The patch fixes the following bug:
http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2326

If the patch introduces a regression for you, then the problem needs to be
investigated further. Reverting the patch will reintroduce an already fixed
problem for others.

Cheers,

- Udo

On Sun, 11 Dec 2011 17:33:25 +0100 Andrej Gelenberg (AG) wrote:

AG> Hello,
AG>
AG> the original commit 34a5b4b6af104cf18eb50748509528b9bdbc4036 in upstream (v3.2.0-rc5) break the driver too. Please revert it, before the release. Patch for 3.2-rc5 attached.
AG>
AG> Regards,
AG> Andrej Gelenberg
AG>
AG> On 12/11/2011 02:24 PM, Andrej Gelenberg wrote:
AG> > Hello,
AG> >
AG> > there in an regression in kernel release v3.1.5. Commit
AG> > 43c308bd8d0a3e7d98c5abcd41a4a3fada3d198f "iwlwifi: do not re-configure
AG> > HT40 after associated" break iwlagn driver for Intel Corporation
AG> > Centrino Ultimate-N 6300 (rev 35) on my Thinkpad t510. I still can
AG> > connect to the AP, but i can't pin or access anything. Reverting that
AG> > commit solved the Problem. I attached the patch.
AG> >
AG> > Regards,
AG> > Andrej Gelenberg
AG>


--
Dipl.-Inf. Udo Steinberg
Technische Universität Dresden http://os.inf.tu-dresden.de/~us15
Institute of Systems Architecture Tel: +49 351 463 38401
D-01062 Dresden Fax: +49 351 463 38284
Re: iwlagn regression in v3.1.5 [ In reply to ]
Hi,

this is pretty mean regression for the stable kernel. You may the fix
only for cards, which need it and not for all of them.

Regards,
Andrej

On 12/11/2011 05:41 PM, Udo Steinberg wrote:
> Hi,
>
> The patch fixes the following bug:
> http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2326
>
> If the patch introduces a regression for you, then the problem needs to be
> investigated further. Reverting the patch will reintroduce an already fixed
> problem for others.
>
> Cheers,
>
> - Udo
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Re: iwlagn regression in v3.1.5 [ In reply to ]
On Sun, 2011-12-11 at 08:58 -0800, Andrej Gelenberg wrote:
> Hi,
>
> this is pretty mean regression for the stable kernel. You may the fix
> only for cards, which need it and not for all of them.

Could you elaborate more on the failure case and setup. this patch is to
address HT40 related problem which cause the iwlwifi firmware crash.

Thanks
Wey
> >


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Re: iwlagn regression in v3.1.5 [ In reply to ]
Hi,

i haven't experienced firmware crushes, but after that commit i don't
get any networking with my wlan card. I added some lspci and dmesg
output to the patch. There was no strange output in my dmesg. dhcpcd
says in logs, that carrier lost after about 30 seconds. How can i
reproduce the HT40 bug?

Regards,
Andrej

On 12/11/2011 07:23 PM, wwguy wrote:
> On Sun, 2011-12-11 at 08:58 -0800, Andrej Gelenberg wrote:
>> Hi,
>>
>> this is pretty mean regression for the stable kernel. You may the fix
>> only for cards, which need it and not for all of them.
>
> Could you elaborate more on the failure case and setup. this patch is to
> address HT40 related problem which cause the iwlwifi firmware crash.
>
> Thanks
> Wey
>>>
>
>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Re: iwlagn regression in v3.1.5 [ In reply to ]
Hi,

some info to the AP i use:

Technaxx Router-150 Wifi-N based on ranik soc

$ iw dev wlan0 station dump
Station xx:xx..xx:xx (on wlan0)
inactive time: 6603 ms
rx bytes: 377786468
rx packets: 443535
tx bytes: 15677515
tx packets: 155009
tx retries: 2723757
tx failed: 51495
signal: -72 dBm
signal avg: -71 dBm
tx bitrate: 135.0 MBit/s MCS 6 40Mhz short GI
authorized: yes
authenticated: yes
preamble: long
WMM/WME: yes
MFP: no

$ iwconfig wlan0
wlan0 IEEE 802.11abgn ESSID:"xxx"
Mode:Managed Frequency:2.437 GHz Access Point: xx:xx..xx:xx
Bit Rate=121.5 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=42/70 Signal level=-68 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:51520 Invalid misc:3567 Missed beacon:0

some dmesg output:

[ 903.748514] wlan0: authenticate with xx:xx..xx:xx (try 1)
[ 903.750991] wlan0: authenticated
[ 903.753357] wlan0: associate with xx:xx..xx:xx (try 1)
[ 903.759482] wlan0: RX AssocResp from xx:xx..xx:xx (capab=0xc31
status=0 aid=1)
[ 903.759487] wlan0: associated

$ iwlist wlan0 scan

Cell 06 - Address: xx:xx..xx:xx
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=45/70 Signal level=-65 dBm
Encryption key:on
ESSID:"xxx"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
18 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=0000005666eac197
Extra: Last beacon: 33ms ago
IE: Unknown: 000873757065726B7568
IE: Unknown: 010882848B961224486C
IE: Unknown: 030106
IE: Unknown: 2A0100
IE: Unknown: 32040C183060
IE: Unknown:
2D1A7E1117FF000000010000000000000000000000000C0000000000
IE: Unknown:
3D1606070500000000000000000000000000000000000000
IE: Unknown: 3E0100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown:
DD180050F2020101800003A4000027A4000042435E0062322F00
IE: Unknown: 0B05020012127A
IE: Unknown: 4A0E14000A002C01C800140005001900
IE: Unknown: 7F0101
IE: Unknown: DD07000C4307000000
IE: Unknown: 0706465220010D10
IE: Unknown:
DD1E00904C337E1117FF000000010000000000000000000000000C0000000000
IE: Unknown:
DD1A00904C3406070500000000000000000000000000000000000000

Regards,
Andrej Gelenberg

On 12/11/2011 07:23 PM, wwguy wrote:
> On Sun, 2011-12-11 at 08:58 -0800, Andrej Gelenberg wrote:
>> Hi,
>>
>> this is pretty mean regression for the stable kernel. You may the fix
>> only for cards, which need it and not for all of them.
>
> Could you elaborate more on the failure case and setup. this patch is to
> address HT40 related problem which cause the iwlwifi firmware crash.
>
> Thanks
> Wey
>>>
>
>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Re: iwlagn regression in v3.1.5 [ In reply to ]
Hi Andjej,


Could you please load the module with debug=0x1082 and send me the log.

$sudo modprobe iwlagn debug=0x1082

Thanks
Wey

On Sun, 2011-12-11 at 11:20 -0800, Andrej Gelenberg wrote:
> Hi,
>
> some info to the AP i use:
>
> Technaxx Router-150 Wifi-N based on ranik soc
>
> $ iw dev wlan0 station dump
> Station xx:xx..xx:xx (on wlan0)
> inactive time: 6603 ms
> rx bytes: 377786468
> rx packets: 443535
> tx bytes: 15677515
> tx packets: 155009
> tx retries: 2723757
> tx failed: 51495
> signal: -72 dBm
> signal avg: -71 dBm
> tx bitrate: 135.0 MBit/s MCS 6 40Mhz short GI
> authorized: yes
> authenticated: yes
> preamble: long
> WMM/WME: yes
> MFP: no
>
> $ iwconfig wlan0
> wlan0 IEEE 802.11abgn ESSID:"xxx"
> Mode:Managed Frequency:2.437 GHz Access Point: xx:xx..xx:xx
> Bit Rate=121.5 Mb/s Tx-Power=15 dBm
> Retry long limit:7 RTS thr:off Fragment thr:off
> Power Management:off
> Link Quality=42/70 Signal level=-68 dBm
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:51520 Invalid misc:3567 Missed beacon:0
>
> some dmesg output:
>
> [ 903.748514] wlan0: authenticate with xx:xx..xx:xx (try 1)
> [ 903.750991] wlan0: authenticated
> [ 903.753357] wlan0: associate with xx:xx..xx:xx (try 1)
> [ 903.759482] wlan0: RX AssocResp from xx:xx..xx:xx (capab=0xc31
> status=0 aid=1)
> [ 903.759487] wlan0: associated
>
> $ iwlist wlan0 scan
>
> Cell 06 - Address: xx:xx..xx:xx
> Channel:6
> Frequency:2.437 GHz (Channel 6)
> Quality=45/70 Signal level=-65 dBm
> Encryption key:on
> ESSID:"xxx"
> Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
> 18 Mb/s; 36 Mb/s; 54 Mb/s
> Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
> Mode:Master
> Extra:tsf=0000005666eac197
> Extra: Last beacon: 33ms ago
> IE: Unknown: 000873757065726B7568
> IE: Unknown: 010882848B961224486C
> IE: Unknown: 030106
> IE: Unknown: 2A0100
> IE: Unknown: 32040C183060
> IE: Unknown:
> 2D1A7E1117FF000000010000000000000000000000000C0000000000
> IE: Unknown:
> 3D1606070500000000000000000000000000000000000000
> IE: Unknown: 3E0100
> IE: IEEE 802.11i/WPA2 Version 1
> Group Cipher : CCMP
> Pairwise Ciphers (1) : CCMP
> Authentication Suites (1) : PSK
> IE: Unknown:
> DD180050F2020101800003A4000027A4000042435E0062322F00
> IE: Unknown: 0B05020012127A
> IE: Unknown: 4A0E14000A002C01C800140005001900
> IE: Unknown: 7F0101
> IE: Unknown: DD07000C4307000000
> IE: Unknown: 0706465220010D10
> IE: Unknown:
> DD1E00904C337E1117FF000000010000000000000000000000000C0000000000
> IE: Unknown:
> DD1A00904C3406070500000000000000000000000000000000000000
>
> Regards,
> Andrej Gelenberg
>
> On 12/11/2011 07:23 PM, wwguy wrote:
> > On Sun, 2011-12-11 at 08:58 -0800, Andrej Gelenberg wrote:
> >> Hi,
> >>
> >> this is pretty mean regression for the stable kernel. You may the fix
> >> only for cards, which need it and not for all of them.
> >
> > Could you elaborate more on the failure case and setup. this patch is to
> > address HT40 related problem which cause the iwlwifi firmware crash.
> >
> > Thanks
> > Wey
> >>>
> >
> >
>


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Re: iwlagn regression in v3.1.5 [ In reply to ]
Hi,

there are broken wlan log and working wlan log and an diff of them.

Regards,
Andrej Gelenberg

On 12/12/2011 02:35 AM, wwguy wrote:
> Hi Andjej,
>
>
> Could you please load the module with debug=0x1082 and send me the log.
>
> $sudo modprobe iwlagn debug=0x1082
>
> Thanks
> Wey
Re: iwlagn regression in v3.1.5 [ In reply to ]
Hi Andrej,

Could you try this patch and see any differences.

please still use the same debug flag I ask you last time.

Thanks
Wey

n Mon, 2011-12-12 at 09:15 -0800, Andrej Gelenberg wrote:
> Hi,
>
> there are broken wlan log and working wlan log and an diff of them.
>
> Regards,
> Andrej Gelenberg
>
> On 12/12/2011 02:35 AM, wwguy wrote:
> > Hi Andjej,
> >
> >
> > Could you please load the module with debug=0x1082 and send me the log.
> >
> > $sudo modprobe iwlagn debug=0x1082
> >
> > Thanks
> > Wey
Re: iwlagn regression in v3.1.5 [ In reply to ]
Hi,

work now for me.

Regards,
Andrej Gelenberg

On 12/13/2011 09:15 PM, wwguy wrote:
> Hi Andrej,
>
> Could you try this patch and see any differences.
>
> please still use the same debug flag I ask you last time.
>
> Thanks
> Wey
Re: iwlagn regression in v3.1.5 [ In reply to ]
Hi,

Glad to hear it works for you now. In the patch, the following piece of code

+ if ((iwl_is_associated_ctx(ctx) &&
+ !ctx->ht.is_40mhz) ||
+ !iwl_is_associated_ctx(ctx))

can be simplified to:

if (!iwl_is_associated_ctx(ctx) || !ctx->ht.is_40mhz)

Cheers,

- Udo

On Tue, 13 Dec 2011 22:08:17 +0100 Andrej Gelenberg (AG) wrote:

AG> Hi,
AG>
AG> work now for me.
AG>
AG> Regards,
AG> Andrej Gelenberg
AG>
AG> On 12/13/2011 09:15 PM, wwguy wrote:
AG> > Hi Andrej,
AG> >
AG> > Could you try this patch and see any differences.
AG> >
AG> > please still use the same debug flag I ask you last time.
AG> >
AG> > Thanks
AG> > Wey
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Re: iwlagn regression in v3.1.5 [ In reply to ]
On Tue, 2011-12-13 at 14:04 -0800, Udo Steinberg wrote:
> Hi,
>
> Glad to hear it works for you now. In the patch, the following piece of code
>
> + if ((iwl_is_associated_ctx(ctx) &&
> + !ctx->ht.is_40mhz) ||
> + !iwl_is_associated_ctx(ctx))
>
> can be simplified to:
>
> if (!iwl_is_associated_ctx(ctx) || !ctx->ht.is_40mhz)
>
right, looks better this way :-)

Thanks
Wey

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Re: iwlagn regression in v3.1.5 [ In reply to ]
On Tue, Dec 13, 2011 at 9:15 PM, wwguy <wey-yi.w.guy@intel.com> wrote:
> Hi Andrej,
>
> Could you try this patch and see any differences.

I had a problem with 3.1.5 (3.1.4 was fine) and current Linus git
where I was able to associate with my AP (5GHz) but only icmp was
working and while trying to ssh then all packets (including icmp ones)
started to be dropped.

My card is 5350 AGN [Echo Peak] and this patch makes things working
for me on top of current Linus git, too.

--
Arkadiusz Miśkiewicz        PLD/Linux Team
arekm / maven.pl            http://ftp.pld-linux.org/
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/