Mailing List Archive

[PATCH] Possible NTSC Xv/yuv fix
I believe the attached patch fixes a problem with the ivtv yuv ioctl used by
the Xv driver.

Can those of you with color problems with NTSC playback try it and let me
know how it changes it. If it doesn't fix it then a before & after picture
may be useful. (Probably best sent direct rather than to the list).



Chris

This still works (for me at least) with PAL so I think it should
probably be applied to the next release in any case.



Thanks,



John
Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
Hi -

I applied this patch (using the -R option, is that right?) and, on video
output, the semi-transparent green band has moved from near to the top
of the screen to the bottom 1/3 of the screen. I also noticed an offet
red ghost image displaced about 1/3 up on the screen.

I'd love to make a screenshot available, I just don't know how to. I
tried to use fbgrab, but that just created a black image for me.

Mike

> I believe the attached patch fixes a problem with the ivtv yuv ioctl used by
> the Xv driver.
>
> Can those of you with color problems with NTSC playback try it and let me
> know how it changes it. If it doesn't fix it then a before & after picture
> may be useful. (Probably best sent direct rather than to the list).
>
>
>
> Chris
>
> This still works (for me at least) with PAL so I think it should
> probably be applied to the next release in any case.
>
>
>
> Thanks,
>
>
>
> John
>
>


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
On Sunday 22 May 2005 13:46, John Harvey wrote:
> I believe the attached patch fixes a problem with the ivtv yuv ioctl used by
> the Xv driver.
>
> Can those of you with color problems with NTSC playback try it and let me
> know how it changes it. If it doesn't fix it then a before & after picture
> may be useful. (Probably best sent direct rather than to the list).

Still getting green bars, but they're in a different position. I'm using
S/VIDEO output.

Images of before and after at http://lfx.org/ivtv/

I can't actually take a screenshot of the output with my setup, so I used a
digital camera. The black bars in the picture are from the vertical refresh
of my camera not lining up with the TV, so you can ignore those.

Thanks,
jim


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
Your screenshots show exactly what I see on my setup too.

Mike

On Sun, 22 May 2005 aziivtv@lfx.org wrote:

> Still getting green bars, but they're in a different position. I'm using
> S/VIDEO output.
>
> Images of before and after at http://lfx.org/ivtv/
>
> I can't actually take a screenshot of the output with my setup, so I used a
> digital camera. The black bars in the picture are from the vertical refresh
> of my camera not lining up with the TV, so you can ignore those.
>
> Thanks,
> jim
>
>



-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
RE: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
Here is a newer driver to try. This is not a released version but it may fix
the NTSC problem (or at least it should change it) so it would be
interesting for someone to try it and if it fixes things I'll release an .11
version.

John

> -----Original Message-----
> From: ivtv-devel-admin@lists.sourceforge.net [mailto:ivtv-devel-
> admin@lists.sourceforge.net] On Behalf Of aziivtv@lfx.org
> Sent: 22 May 2005 23:04
> To: ivtv-devel@lists.sourceforge.net
> Subject: Re: [ivtv-devel] [PATCH] Possible NTSC Xv/yuv fix
>
> On Sunday 22 May 2005 13:46, John Harvey wrote:
> > I believe the attached patch fixes a problem with the ivtv yuv ioctl
> used by
> > the Xv driver.
> >
> > Can those of you with color problems with NTSC playback try it and let
> me
> > know how it changes it. If it doesn't fix it then a before & after
> picture
> > may be useful. (Probably best sent direct rather than to the list).
>
> Still getting green bars, but they're in a different position. I'm using
> S/VIDEO output.
>
> Images of before and after at http://lfx.org/ivtv/
>
> I can't actually take a screenshot of the output with my setup, so I used
> a
> digital camera. The black bars in the picture are from the vertical
> refresh
> of my camera not lining up with the TV, so you can ignore those.
>
> Thanks,
> jim
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by Oracle Space Sweepstakes
> Want to be the first software developer in space?
> Enter now for the Oracle Space Sweepstakes!
> http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
> _______________________________________________
> ivtv-devel mailing list
> ivtv-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/ivtv-devel
Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
This driver combined with ivtv-0.3.5e fixes my color problems!

Jim Perry

On Monday 23 May 2005 14:13, John Harvey wrote:
> Here is a newer driver to try. This is not a released version but it may fix
> the NTSC problem (or at least it should change it) so it would be
> interesting for someone to try it and if it fixes things I'll release an .11
> version.


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
RE: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
John,

The green band has disappeared for my with this driver, but I still
see a red ghost image of what was previously shown on the last
tv channel I was watching. Using ivtv 0.3.4s

Mike

On Mon, 23 May 2005, John Harvey wrote:

> Here is a newer driver to try. This is not a released version but it may fix
> the NTSC problem (or at least it should change it) so it would be
> interesting for someone to try it and if it fixes things I'll release an .11
> version.
>
> John
>
> > -----Original Message-----
> > From: ivtv-devel-admin@lists.sourceforge.net [mailto:ivtv-devel-
> > admin@lists.sourceforge.net] On Behalf Of aziivtv@lfx.org
> > Sent: 22 May 2005 23:04
> > To: ivtv-devel@lists.sourceforge.net
> > Subject: Re: [ivtv-devel] [PATCH] Possible NTSC Xv/yuv fix
> >
> > On Sunday 22 May 2005 13:46, John Harvey wrote:
> > > I believe the attached patch fixes a problem with the ivtv yuv ioctl
> > used by
> > > the Xv driver.
> > >
> > > Can those of you with color problems with NTSC playback try it and let
> > me
> > > know how it changes it. If it doesn't fix it then a before & after
> > picture
> > > may be useful. (Probably best sent direct rather than to the list).
> >
> > Still getting green bars, but they're in a different position. I'm using
> > S/VIDEO output.
> >
> > Images of before and after at http://lfx.org/ivtv/
> >
> > I can't actually take a screenshot of the output with my setup, so I used
> > a
> > digital camera. The black bars in the picture are from the vertical
> > refresh
> > of my camera not lining up with the TV, so you can ignore those.
> >
> > Thanks,
> > jim
> >
> >
> > -------------------------------------------------------
> > This SF.Net email is sponsored by Oracle Space Sweepstakes
> > Want to be the first software developer in space?
> > Enter now for the Oracle Space Sweepstakes!
> > http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
> > _______________________________________________
> > ivtv-devel mailing list
> > ivtv-devel@lists.sourceforge.net
> > https://lists.sourceforge.net/lists/listinfo/ivtv-devel
>


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
On Monday 23 May 2005 18:17, Michael Papazoglou wrote:
> The green band has disappeared for my with this driver, but I still
> see a red ghost image of what was previously shown on the last
> tv channel I was watching. Using ivtv 0.3.4s

I saw an effect like that on ivtv-0.3.5c, but it went away when I upgraded to
0.3.5e (and used the new driver).

Jim Perry


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
On Mon, 23 May 2005, Jim Perry wrote:
> I saw an effect like that on ivtv-0.3.5c, but it went away when I upgraded to
> 0.3.5e (and used the new driver).
>
> Jim Perry
>
Hi -

I upgraded to ivtv-0.3.5f, and, with the new driver, the picture
looks great when playing videos!

I now have a couple of observations:

1. I can no longer see the OSD when using mplayer or xine to play
video/dvd

2. When I'm watching live tv or a recording in Myth, when I hit pause,
it takes 3-4 seconds for the pause to take effect. That doesn't happen
with ivtv-0.3.4s (the last version I was using)

Thanks for all of your help!

Mike



-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
RE: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
> -----Original Message-----
> From: ivtv-devel-admin@lists.sourceforge.net [mailto:ivtv-devel-
> admin@lists.sourceforge.net] On Behalf Of Michael Papazoglou
> Sent: 24 May 2005 03:02
> To: ivtv-devel@lists.sourceforge.net
> Subject: Re: [ivtv-devel] [PATCH] Possible NTSC Xv/yuv fix
>
>
> On Mon, 23 May 2005, Jim Perry wrote:
> > I saw an effect like that on ivtv-0.3.5c, but it went away when I
> upgraded to
> > 0.3.5e (and used the new driver).
> >
> > Jim Perry
> >
> Hi -
>
> I upgraded to ivtv-0.3.5f, and, with the new driver, the picture
> looks great when playing videos!
>
> I now have a couple of observations:
>
> 1. I can no longer see the OSD when using mplayer or xine to play
> video/dvd
>

That makes sense. I'm not sure how to handle that but I'll think about it.

> 2. When I'm watching live tv or a recording in Myth, when I hit pause,
> it takes 3-4 seconds for the pause to take effect. That doesn't happen
> with ivtv-0.3.4s (the last version I was using)
>
I think this is one for Chris.

> Thanks for all of your help!
>
> Mike
>
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by Oracle Space Sweepstakes
> Want to be the first software developer in space?
> Enter now for the Oracle Space Sweepstakes!
> http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
> _______________________________________________
> ivtv-devel mailing list
> ivtv-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/ivtv-devel



-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
RE: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
On Tue, 24 May 2005, John Harvey wrote:
> > 1. I can no longer see the OSD when using mplayer or xine to play
> > video/dvd
> >
>
> That makes sense. I'm not sure how to handle that but I'll think about it.

The good thing is that I can still see subtitles



-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
RE: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
Is there any way to persuade mplayer or xine to insert
the OSD into the Xv stream rather than writing to X?

John
--- Michael Papazoglou <mpapazoglou@verizon.net>
wrote:
>
>
> On Tue, 24 May 2005, John Harvey wrote:
> > > 1. I can no longer see the OSD when using
> mplayer or xine to play
> > > video/dvd
> > >
> >
> > That makes sense. I'm not sure how to handle that
> but I'll think about it.
>
> The good thing is that I can still see subtitles
>
>
>
>
-------------------------------------------------------
> This SF.Net email is sponsored by Oracle Space
> Sweepstakes
> Want to be the first software developer in space?
> Enter now for the Oracle Space Sweepstakes!
>
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
> _______________________________________________
> ivtv-devel mailing list
> ivtv-devel@lists.sourceforge.net
>
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
>


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
Actually I didn't touch the decoding code, that's odd, not sure what
is causing the pause to do that againl? Don't think the YUV changes
have done anything to decoding.

Thanks,
Chris
On Tue, May 24, 2005 at 07:43:10AM +0100, John Harvey wrote:
>
>
> > -----Original Message-----
> > From: ivtv-devel-admin@lists.sourceforge.net [mailto:ivtv-devel-
> > admin@lists.sourceforge.net] On Behalf Of Michael Papazoglou
> > Sent: 24 May 2005 03:02
> > To: ivtv-devel@lists.sourceforge.net
> > Subject: Re: [ivtv-devel] [PATCH] Possible NTSC Xv/yuv fix
> >
> >
> > On Mon, 23 May 2005, Jim Perry wrote:
> > > I saw an effect like that on ivtv-0.3.5c, but it went away when I
> > upgraded to
> > > 0.3.5e (and used the new driver).
> > >
> > > Jim Perry
> > >
> > Hi -
> >
> > I upgraded to ivtv-0.3.5f, and, with the new driver, the picture
> > looks great when playing videos!
> >
> > I now have a couple of observations:
> >
> > 1. I can no longer see the OSD when using mplayer or xine to play
> > video/dvd
> >
>
> That makes sense. I'm not sure how to handle that but I'll think about it.
>
> > 2. When I'm watching live tv or a recording in Myth, when I hit pause,
> > it takes 3-4 seconds for the pause to take effect. That doesn't happen
> > with ivtv-0.3.4s (the last version I was using)
> >
> I think this is one for Chris.
>
> > Thanks for all of your help!
> >
> > Mike
> >
> >
> >
> > -------------------------------------------------------
> > This SF.Net email is sponsored by Oracle Space Sweepstakes
> > Want to be the first software developer in space?
> > Enter now for the Oracle Space Sweepstakes!
> > http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
> > _______________________________________________
> > ivtv-devel mailing list
> > ivtv-devel@lists.sourceforge.net
> > https://lists.sourceforge.net/lists/listinfo/ivtv-devel
>
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by Oracle Space Sweepstakes
> Want to be the first software developer in space?
> Enter now for the Oracle Space Sweepstakes!
> http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
> _______________________________________________
> ivtv-devel mailing list
> ivtv-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/ivtv-devel

--
---
Chris Kennedy / ckennedy@kmos.cmsu.edu
Engineer KMOS-TV/KTBG-FM
Broadcasting Services Department
Central Missouri State University


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
On Tuesday 24 May 2005 11:54, John Harvey wrote:
> Is there any way to persuade mplayer or xine to insert
> the OSD into the Xv stream rather than writing to X?
>
<snip>

As long as it's only the OSD and not the gui itself, xine can be configured
okay.

Bring up the setup menu & go into the GUI settings. As long as the
configuration experience level is higher than 'Beginner', then about halfway
down the list there is the option to 'Use unscaled OSD', this should be
un-ticked. I don't believe there is a command line option to change this
setting.

If you fancy editing the config file manually (usually ~/.xine/config), then
look for gui.osd_use_unscaled, make sure it's not commented out & set it to
0.

--
Ian


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
John Harvey wrote:
> Is there any way to persuade mplayer or xine to insert
> the OSD into the Xv stream rather than writing to X?

It does so by default for me. I see the mplayer volume slider, and seek
slider just fine. I'm not sure what setting it is, but its defenitely
possible.

(running mplayer on gentoo. using normal mplayer from portage nothing fancy)

Bye, Lucas



-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
i've setup everything with the new ivtv 0.3.5f and john's ivtvdev driver
and it is working fine now.
Everything works and switching from livetv to video/mpeg and vs gives no
problems.
To watch video after reboot, livetv must be started first to enable
/dev/video48<->YUV. After this it keeps working.

After watching a video and switching to livetv, you see the picture of the
video for 2-3 sec until livetv appears

still remain issue is the -fs and -zoom with mplayer which is not working.

--
gr.

patrick



-------------------------------------------------------
This SF.Net email is sponsored by Yahoo.
Introducing Yahoo! Search Developer Network - Create apps using Yahoo!
Search APIs Find out how you can build Yahoo! directly into your own
Applications - visit http://developer.yahoo.net/?fr=offad-ysdn-ostg-q22005
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
I've picked up this setting from another thread, this works fine for me:

mplayer -vo xv -vf scale=720:-3,expand=720:576

With this setting, an avi file plays with mplayer using ~15% cpu en X
using ~30% cpu (P4 3.0GHz). Minor tearing only visible in really fast
moving scenes...

As an off-topic idea, I was wondering if it wouldn't be too difficult to
include a tiny mpg stream (like just a single jpg converted to mpg) in the
driver and to play that when the driver is started.
This would accomplish 2 things:
1. The garbage that gets displayed as soon as the driver loads, but only
gets cleared when X is started, could be replaced by an ivtv logo or so.
2. The decoder gets initialised, so it is possible to use the YUV stuff
immediately.

Stanley.


> i've setup everything with the new ivtv 0.3.5f and john's ivtvdev driver
> and it is working fine now.
> Everything works and switching from livetv to video/mpeg and vs gives no
> problems.
> To watch video after reboot, livetv must be started first to enable
> /dev/video48<->YUV. After this it keeps working.
>
> After watching a video and switching to livetv, you see the picture of the
> video for 2-3 sec until livetv appears
>
> still remain issue is the -fs and -zoom with mplayer which is not working.
>
> --
> gr.
>
> patrick
>
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by Yahoo.
> Introducing Yahoo! Search Developer Network - Create apps using Yahoo!
> Search APIs Find out how you can build Yahoo! directly into your own
> Applications - visit http://developer.yahoo.net/?fr=offad-ysdn-ostg-q22005
> _______________________________________________
> ivtv-devel mailing list
> ivtv-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/ivtv-devel
>
>




-------------------------------------------------------
This SF.Net email is sponsored by Yahoo.
Introducing Yahoo! Search Developer Network - Create apps using Yahoo!
Search APIs Find out how you can build Yahoo! directly into your own
Applications - visit http://developer.yahoo.net/?fr=offad-ysdn-ostg-q22005
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
On Tue, 24 May 2005, Ian Armstrong wrote:

> On Tuesday 24 May 2005 11:54, John Harvey wrote:
> > Is there any way to persuade mplayer or xine to insert
> > the OSD into the Xv stream rather than writing to X?
> >
> <snip>
>
> As long as it's only the OSD and not the gui itself, xine can be configured
> okay.
>
> Bring up the setup menu & go into the GUI settings. As long as the
> configuration experience level is higher than 'Beginner', then about halfway
> down the list there is the option to 'Use unscaled OSD', this should be
> un-ticked. I don't believe there is a command line option to change this
> setting.
>
> If you fancy editing the config file manually (usually ~/.xine/config), then
> look for gui.osd_use_unscaled, make sure it's not commented out & set it to
> 0.
>

Ian,

Thanks for the tip. Setting gui.osd_use_unscaled to 0 did the trick.

Mike


-------------------------------------------------------
This SF.Net email is sponsored by Yahoo.
Introducing Yahoo! Search Developer Network - Create apps using Yahoo!
Search APIs Find out how you can build Yahoo! directly into your own
Applications - visit http://developer.yahoo.net/?fr=offad-ysdn-ostg-q22005
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel
RE: Re: [PATCH] Possible NTSC Xv/yuv fix [ In reply to ]
Yes & No.
The garbage is actually osd stuff not mpeg stuff so this wouldn't really
make any difference to that.
I'm gradually tracking down the registers that affect this and I believe can
also allow us to scale up the image so I hope we can get to the point where
we don't need to do the initialization, but if we can't this has been the
plan that I will fall back to.
But we should address the garbage issue differently.

John

> -----Original Message-----
> From: ivtv-devel-admin@lists.sourceforge.net [mailto:ivtv-devel-
> admin@lists.sourceforge.net] On Behalf Of ivtv@merkx.demon.nl
> Sent: 24 May 2005 22:16
> To: ivtv-devel@lists.sourceforge.net
> Subject: [ivtv-devel] Re: [PATCH] Possible NTSC Xv/yuv fix
>
>
> I've picked up this setting from another thread, this works fine for me:
>
> mplayer -vo xv -vf scale=720:-3,expand=720:576
>
> With this setting, an avi file plays with mplayer using ~15% cpu en X
> using ~30% cpu (P4 3.0GHz). Minor tearing only visible in really fast
> moving scenes...
>
> As an off-topic idea, I was wondering if it wouldn't be too difficult to
> include a tiny mpg stream (like just a single jpg converted to mpg) in the
> driver and to play that when the driver is started.
> This would accomplish 2 things:
> 1. The garbage that gets displayed as soon as the driver loads, but only
> gets cleared when X is started, could be replaced by an ivtv logo or so.
> 2. The decoder gets initialised, so it is possible to use the YUV stuff
> immediately.
>
> Stanley.
>
>
> > i've setup everything with the new ivtv 0.3.5f and john's ivtvdev driver
> > and it is working fine now.
> > Everything works and switching from livetv to video/mpeg and vs gives no
> > problems.
> > To watch video after reboot, livetv must be started first to enable
> > /dev/video48<->YUV. After this it keeps working.
> >
> > After watching a video and switching to livetv, you see the picture of
> the
> > video for 2-3 sec until livetv appears
> >
> > still remain issue is the -fs and -zoom with mplayer which is not
> working.
> >
> > --
> > gr.
> >
> > patrick
> >
> >
> >
> > -------------------------------------------------------
> > This SF.Net email is sponsored by Yahoo.
> > Introducing Yahoo! Search Developer Network - Create apps using Yahoo!
> > Search APIs Find out how you can build Yahoo! directly into your own
> > Applications - visit http://developer.yahoo.net/?fr=offad-ysdn-ostg-
> q22005
> > _______________________________________________
> > ivtv-devel mailing list
> > ivtv-devel@lists.sourceforge.net
> > https://lists.sourceforge.net/lists/listinfo/ivtv-devel
> >
> >
>
>
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by Yahoo.
> Introducing Yahoo! Search Developer Network - Create apps using Yahoo!
> Search APIs Find out how you can build Yahoo! directly into your own
> Applications - visit http://developer.yahoo.net/?fr=offad-ysdn-ostg-q22005
> _______________________________________________
> ivtv-devel mailing list
> ivtv-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/ivtv-devel



-------------------------------------------------------
This SF.Net email is sponsored by Yahoo.
Introducing Yahoo! Search Developer Network - Create apps using Yahoo!
Search APIs Find out how you can build Yahoo! directly into your own
Applications - visit http://developer.yahoo.net/?fr=offad-ysdn-ostg-q22005
_______________________________________________
ivtv-devel mailing list
ivtv-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ivtv-devel