Mailing List Archive

{Spam?} Re: Message: Attempt to order missing product code
On Fri, 2012-02-10 at 11:54 +0000, Lars Weinrich wrote:
> Hi,
>
> I'm new to Interchange and have a Problem with an existing installation:
>
> Very often I can't store products in the cart. I use the same way to store a product, sometimes it works, and sometimes the next second it does not work.
>
> In the error.log in the catalog-directory appears the following Message:
> Attempt to order missing product code: [...]
>
> I've traced the problem and sometimes (when the error occures) the Array $Vend::Cfg->{ProductFiles} is empty (and as a result the array @Vend::Productbase, too).
> When there is no problem the ProductFiles-Array contains 'products' and 'variants'.
>
> Informations about the system:
> Interchange V5.7.6
> Perl v5.8.8
> Linux (2.6.18-274.17.1.el5)
>
> Has anybody an idea how to solve the problem?
>
> Thanks in advance
>
> Lars
>

Does your cart just sometimes empty itself? Maybe check to see if you
have CookieDomain set? Does it happen between secure and non-secure
pages? Maybe you're loosing your session between these "servers?"
Rick





_______________________________________________
interchange-users mailing list
interchange-users@icdevgroup.org
http://www.icdevgroup.org/mailman/listinfo/interchange-users
Re: {Spam?} Re: Message: Attempt to order missing product code [ In reply to ]
>> Very often I can't store products in the cart. I use the same way to store a product, sometimes it works, and sometimes the next second it does not work.
>>
>> In the error.log in the catalog-directory appears the following Message:
>> Attempt to order missing product code: [...]
>>
>> I've traced the problem and sometimes (when the error occures) the Array $Vend::Cfg->{ProductFiles} is empty (and as a result the array @Vend::Productbase, too).
>> When there is no problem the ProductFiles-Array contains 'products' and 'variants'.
>>
>> Informations about the system:
>> Interchange V5.7.6
>> Perl v5.8.8
>> Linux (2.6.18-274.17.1.el5)
>
>Does your cart just sometimes empty itself? Maybe check to see if you have CookieDomain set? Does it happen between secure and non-secure pages? Maybe you're loosing your session between these "servers?"
>Rick

The cart does not empty itself.
All request are non-secure. CookieDomain is not set. Is it relevant when the problem occurs only on non-secure pages?

Lars

_______________________________________________
interchange-users mailing list
interchange-users@icdevgroup.org
http://www.icdevgroup.org/mailman/listinfo/interchange-users