Mailing List Archive

gem install linecache19 fails
Hello,

I do need the ruby-gem linecache19-0.5.12. Usually, there are two ways to install a gem, right? Via emerge and via gem install. But here, only one way works. dev-ruby/linecache only builds the
ruby18-version
of
this gem, so I'm stuck with gem install. But gem install fails with the following error:

trace_nums.c:(.text+0x22): undefined reference to `ruby_current_thread'


I am using ruby-1.9.3p194, but tried with different versions as well.

Does anyone have a clue what I can do to solve the problem and get linecache19-0.5.12 installed?

Thanks in advance,

Christian.
Re: gem install linecache19 fails [ In reply to ]
On 05/16/12 08:57, 1126 wrote:
> Hello,
>
> I do need the ruby-gem linecache19-0.5.12. Usually, there are two ways to install a gem, right? Via emerge and via gem install. But here, only one way works. dev-ruby/linecache only builds the
> ruby18-version
> of
> this gem, so I'm stuck with gem install. But gem install fails with the following error:
>
> trace_nums.c:(.text+0x22): undefined reference to `ruby_current_thread'
>
>
> I am using ruby-1.9.3p194, but tried with different versions as well.
>
> Does anyone have a clue what I can do to solve the problem and get linecache19-0.5.12 installed?
>
> Thanks in advance,
>
> Christian.
>

Relevant:

http://bugs.gentoo.org/show_bug.cgi?id=398455

Other people seem to have had the same problem. Try the git version,
it's somewhat more likely to work considering the last commit was
"updated for Ruby 1.9.3":

https://github.com/mark-moseley/linecache