Mailing List Archive

can't install ati-drivers
Hello!
I have a big problem installing ati driver. Please somebody help.

When I try to install it I get a huge error message:

localhost fglrx # emerge -v ati-drivers
Calculating dependencies... done!
>>> Emerging (1 of 1) x11-drivers/ati-drivers-8.21.7-r1 to /
>>> checking ebuild checksums ;-)
>>> checking auxfile checksums ;-)
>>> checking miscfile checksums ;-)
>>> checking ati-driver-installer-8.21.7-i386.run ;-)
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found sources for kernel version:
* 2.6.17-gentoo-r4
* Checking for MTRR support enabled ...
[ ok ]
* Checking for AGP support enabled ...
[ !! ]
* Checking for PCI Express support enabled ...
[ ok ]
* Checking for DRM support disabled ...
[ ok ]
* X11 implementation is xorg-x11.
>>> Unpacking source...
* Unpacking Ati drivers ...
[ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/ati-drivers-8.21.7-r1 ...
* Building the DRM module...
make: Entering directory `/usr/src/linux-2.6.17-gentoo-r4'
CC
[M] /var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/agp3.o
CC
[M] /var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/nvidia-agp.o
CC
[M] /var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/agpgart_be.o
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/agpgart_be.c:
In function `__fgl_agp_init':
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/agpgart_be.c:8173:
warning: implicit declaration of function `pm_register'
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/agpgart_be.c:
In function `__fgl_agp_cleanup':
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/agpgart_be.c:8183:
warning: implicit declaration of function `pm_unregister_all'
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/agpgart_be.c:
At top level:
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/agpgart_be.c:6077:
warning: 'ati_gart_base' defined but not used
CC
[M] /var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/i7505-agp.o
CC
[M] /var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.o
In file included
from /var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:162:
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.h:267:5:
warning: "FIREGL_VMA_INFO" is not defined
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:228:
error: parse error before string constant
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:228:
warning: type defaults to `int' in declaration of `MODULE_PARM'
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:228:
warning: function declaration isn't a prototype
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:228:
warning: data definition has no type or storage class
In file included
from /var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/drm_proc.h:41,

from /var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:333:
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/drmP.h:561:5:
warning: "__HAVE_VBL_IRQ" is not defined
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/drmP.h:664:5:
warning: "__HAVE_VBL_IRQ" is not defined
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/drmP.h:936:5:
warning: "__HAVE_SG" is not defined
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:407:5:
warning: "FIREGL_VMA_INFO" is not defined
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:425:5:
warning: "FIREGL_VMA_INFO" is not defined
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:
In function `firegl_stub_open':
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:530:
warning: assignment discards qualifiers from pointer target type
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:
In function `firegl_stub_putminor':
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:579:
warning: `inter_module_put' is deprecated (declared at
include/linux/module.h:567)
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:581:
warning: `inter_module_unregister' is deprecated (declared at
include/linux/module.h:564)
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:
In function `firegl_stub_register':
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:601:
warning: `inter_module_register' is deprecated (declared at
include/linux/module.h:563)
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:632:
warning: `inter_module_put' is deprecated (declared at
include/linux/module.h:567)
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:
At top level:
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3509:
warning: initialization from incompatible pointer type
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3510:
warning: initialization from incompatible pointer type
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3511:
warning: initialization from incompatible pointer type
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3512:
warning: initialization from incompatible pointer type
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3513:
warning: initialization from incompatible pointer type
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3514:
warning: initialization from incompatible pointer type
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3515:
warning: initialization from incompatible pointer type
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3516:
warning: initialization from incompatible pointer type
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3518:
warning: initialization from incompatible pointer type
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3528:
warning: function declaration isn't a prototype
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:
In function `test_inter_module_interface':
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3594:
warning: `inter_module_put' is deprecated (declared at
include/linux/module.h:567)
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3600:
warning: `inter_module_put' is deprecated (declared at
include/linux/module.h:567)
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:
In function `__ke_agp_allocate_memory_phys_list':
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3858:
warning: passing arg 3 of pointer to function makes integer from pointer
without a cast
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:
In function `__ke_agp_bind_memory':
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3897:
warning: passing arg 1 of pointer to function from incompatible pointer type
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:
In function `__ke_agp_unbind_memory':
/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3910:
warning: passing arg 1 of pointer to function from incompatible pointer type
make[1]: ***
[/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.o]
Error 1
make: ***
[_module_/var/tmp/portage/ati-drivers-8.21.7-r1/work/common/lib/modules/fglrx/build_mod]
Error 2
make: Leaving directory `/usr/src/linux-2.6.17-gentoo-r4'
* DRM module not built
>>> Source compiled.
>>> Test phase [not enabled]: x11-drivers/ati-drivers-8.21.7-r1

>>> Install ati-drivers-8.21.7-r1
into /var/tmp/portage/ati-drivers-8.21.7-r1/image/ category x11-drivers
* Installing fglrx module
install: cannot stat `fglrx.ko': No such file or directory

!!! ERROR: x11-drivers/ati-drivers-8.21.7-r1 failed.
Call stack:
ebuild.sh, line 1539: Called dyn_install
ebuild.sh, line 1013: Called src_install
ati-drivers-8.21.7-r1.ebuild, line 182: Called linux-mod_src_install
linux-mod.eclass, line 497: Called die

!!! doins fglrx.ko failed
!!! If you need support, post the topmost build error, and the call stack if
relevant.
--
gentoo-user@gentoo.org mailing list
Re: can't install ati-drivers [ In reply to ]
Hello,

is that the newest version in portage? if not i would sujest upgrading as
each version of ati-drivers is only good for certian kernels

Cynyr

On 7/25/06, Stefán István <stefi@geohidroterv.hu> wrote:
>
> Hello!
> I have a big problem installing ati driver. Please somebody help.
>
> When I try to install it I get a huge error message:
>
> localhost fglrx # emerge -v ati-drivers
> Calculating dependencies... done!
> >>> Emerging (1 of 1) x11-drivers/ati-drivers-8.21.7-r1 to /
>
> make: Leaving directory `/usr/src/linux-2.6.17-gentoo-r4'
> * DRM module not built
> >>> Source compiled.
> >>> Test phase [not enabled]: x11-drivers/ati-drivers-8.21.7-r1
>
> >>> Install ati-drivers-8.21.7-r1
> into /var/tmp/portage/ati-drivers-8.21.7-r1/image/ category x11-drivers
> * Installing fglrx module
> install: cannot stat `fglrx.ko': No such file or directory
>
> !!! ERROR: x11-drivers/ati-drivers-8.21.7-r1 failed.
> Call stack:
> ebuild.sh, line 1539: Called dyn_install
> ebuild.sh, line 1013: Called src_install
> ati-drivers-8.21.7-r1.ebuild, line 182: Called linux-mod_src_install
> linux-mod.eclass, line 497: Called die
>
> !!! doins fglrx.ko failed
> !!! If you need support, post the topmost build error, and the call stack
> if
> relevant.
> --
> gentoo-user@gentoo.org mailing list
>
>
Re: can't install ati-drivers [ In reply to ]
On 7/25/06, Stefán István <stefi@geohidroterv.hu> wrote:
> Hello!
> I have a big problem installing ati driver. Please somebody help.
>
> When I try to install it I get a huge error message:
>
> localhost fglrx # emerge -v ati-drivers
> Calculating dependencies... done!
> >>> Emerging (1 of 1) x11-drivers/ati-drivers-8.21.7-r1 to /

8.21.7 seems quite old to me, especially to try and use with a new
kerrnel. Can you try something more recent, like 8.26.18-r1? You'll
have to accept the ~arch keyword for this:

echo "x11-drivers/ati-drivers ~x86" >>/etc/portage/package.keywords

-Richard

--
gentoo-user@gentoo.org mailing list
Re: can't install ati-drivers [ In reply to ]
Meanwhile I was able to install the ati-drivers by adding
ACCEPT_KEYWORDS="~x86" to emerge and install the latest version in portage.
But now X doesn't start, and I find the following in the log file:
Required symbol drmUnmap from module /usr/lib/modules/drivers/fglrx_drv.o is
unresolved!
Symbol drmUnmap from module /usr/lib/modules/drivers/fglrx_drv.o is
unresolved!
Required symbol drmMap from module /usr/lib/modules/drivers/fglrx_drv.o is
unresolved!
Symbol drmMap from module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!
Required symbol drmUnmap from module /usr/lib/modules/drivers/fglrx_drv.o is
unresolved!
Symbol drmUnmap from module /usr/lib/modules/drivers/fglrx_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/lib/modules/drivers/fglrx_drv.o is
unresolved!
Required symbol vgaHWUnlock from module /usr/lib/modules/drivers/fglrx_drv.o
is unresolved!
Required symbol vgaHWSave from module /usr/lib/modules/drivers/fglrx_drv.o is
unresolved!
Required symbol vgaHWLock from module /usr/lib/modules/drivers/fglrx_drv.o is
unresolved!
Symbol vgaHWGetIndex from module /usr/lib/modules/drivers/fglrx_drv.o is
unresolved!
Required symbol vgaHWUnlock from module /usr/lib/modules/drivers/fglrx_drv.o
is unresolved!
Required symbol vgaHWRestore from module /usr/lib/modules/drivers/fglrx_drv.o
is unresolved!
Required symbol vgaHWFreeHWRec from
module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol xf86FreeInt10 from module /usr/lib/modules/drivers/fglrx_drv.o is
unresolved!
Required symbol vgaHWGetHWRec from module /usr/lib/modules/drivers/fglrx_drv.o
is unresolved!
Symbol xf86InitInt10 from module /usr/lib/modules/drivers/fglrx_drv.o is
unresolved!
Required symbol drmMap from module /usr/lib/modules/drivers/fglrx_drv.o is
unresolved!

<snip>

Fatal server error:
Some required symbols were unresolved

Anyway, it is the newest portage, I installed Gentoo today on this laptop.
How can I find out which ati-drivers good for which kernel?

Thanks:
Istvan

kedd 25 július 2006 20.25 dátummal Andrew Frink ezt írta:
> Hello,
>
> is that the newest version in portage? if not i would sujest upgrading as
> each version of ati-drivers is only good for certian kernels
>
> Cynyr
>
> On 7/25/06, Stefán István <stefi@geohidroterv.hu> wrote:
> >
> > Hello!
> > I have a big problem installing ati driver. Please somebody help.
> >
> > When I try to install it I get a huge error message:
> >
> > localhost fglrx # emerge -v ati-drivers
> > Calculating dependencies... done!
> > >>> Emerging (1 of 1) x11-drivers/ati-drivers-8.21.7-r1 to /
> >
> > make: Leaving directory `/usr/src/linux-2.6.17-gentoo-r4'
> > * DRM module not built
> > >>> Source compiled.
> > >>> Test phase [not enabled]: x11-drivers/ati-drivers-8.21.7-r1
> >
> > >>> Install ati-drivers-8.21.7-r1
> > into /var/tmp/portage/ati-drivers-8.21.7-r1/image/ category x11-drivers
> > * Installing fglrx module
> > install: cannot stat `fglrx.ko': No such file or directory
> >
> > !!! ERROR: x11-drivers/ati-drivers-8.21.7-r1 failed.
> > Call stack:
> > ebuild.sh, line 1539: Called dyn_install
> > ebuild.sh, line 1013: Called src_install
> > ati-drivers-8.21.7-r1.ebuild, line 182: Called linux-mod_src_install
> > linux-mod.eclass, line 497: Called die
> >
> > !!! doins fglrx.ko failed
> > !!! If you need support, post the topmost build error, and the call stack
> > if
> > relevant.
> > --
> > gentoo-user@gentoo.org mailing list
> >
> >
>

--
gentoo-user@gentoo.org mailing list
Re: can't install ati-drivers [ In reply to ]
Stefán István a gentiment tapote:
> !!! ERROR: x11-drivers/ati-drivers-8.21.7-r1 failed.
> Call stack:
> ebuild.sh, line 1539: Called dyn_install
> ebuild.sh, line 1013: Called src_install
> ati-drivers-8.21.7-r1.ebuild, line 182: Called linux-mod_src_install
> linux-mod.eclass, line 497: Called die
>
> !!! doins fglrx.ko failed
> !!! If you need support, post the topmost build error, and the call stack if
> relevant.
>

Hi,

ati-drivers-8.25.18 works fine with gentoo-sources-2.6.17-r4

Regards,


--- Ptitjack --


^
^^^
^^^^^
( 0 0 )
\/
-----0000----------0000-----
--
gentoo-user@gentoo.org mailing list
Re: can't install ati-drivers [ In reply to ]
kedd 25 július 2006 20.58 dátummal Ptitjack ezt írta:
> Stefán István a gentiment tapote:
> > !!! ERROR: x11-drivers/ati-drivers-8.21.7-r1 failed.
> > Call stack:
> > ebuild.sh, line 1539: Called dyn_install
> > ebuild.sh, line 1013: Called src_install
> > ati-drivers-8.21.7-r1.ebuild, line 182: Called linux-mod_src_install
> > linux-mod.eclass, line 497: Called die
> >
> > !!! doins fglrx.ko failed
> > !!! If you need support, post the topmost build error, and the call stack
if
> > relevant.
> >
>
> Hi,
>
> ati-drivers-8.25.18 works fine with gentoo-sources-2.6.17-r4
>

Hello!
I tried the version above, and it installs perfectly, but when I try to start
X, I get the unresolved symbols error I worte in my previous mail.

Maybe my xorg has a wrong version? I installed 6.8.2-r8.

István

--
gentoo-user@gentoo.org mailing list
Re: can't install ati-drivers [ In reply to ]
kedd 25 július 2006 20.32 dátummal Richard Fish ezt írta:
> On 7/25/06, Stefán István <stefi@geohidroterv.hu> wrote:
> > Hello!
> > I have a big problem installing ati driver. Please somebody help.
> >
> > When I try to install it I get a huge error message:
> >
> > localhost fglrx # emerge -v ati-drivers
> > Calculating dependencies... done!
> > >>> Emerging (1 of 1) x11-drivers/ati-drivers-8.21.7-r1 to /
>
> 8.21.7 seems quite old to me, especially to try and use with a new
> kerrnel. Can you try something more recent, like 8.26.18-r1? You'll
> have to accept the ~arch keyword for this:
>
> echo "x11-drivers/ati-drivers ~x86" >>/etc/portage/package.keywords
>
Please find my answers in my previous answer for Andrew's mail.

István

--
gentoo-user@gentoo.org mailing list
Re: can't install ati-drivers [ In reply to ]
On Tuesday 25 July 2006 19:32, Richard Fish wrote:

> 8.21.7 seems quite old to me, especially to try and use with a new
> kerrnel. Can you try something more recent, like 8.26.18-r1? You'll
> have to accept the ~arch keyword for this:
>
> echo "x11-drivers/ati-drivers ~x86" >>/etc/portage/package.keywords
>
> -Richard

Also, if you have "userpriv" in your FEATURES= in /etc/make.conf remove it and
then emerge -resume. It may work . . . after that you can re-instate it.
--
Regards,
Mick
Re: can't install ati-drivers [ In reply to ]
kedd 25 július 2006 21.28 dátummal Mick ezt írta:
> On Tuesday 25 July 2006 19:32, Richard Fish wrote:
>
> > 8.21.7 seems quite old to me, especially to try and use with a new
> > kerrnel. Can you try something more recent, like 8.26.18-r1? You'll
> > have to accept the ~arch keyword for this:
> >
> > echo "x11-drivers/ati-drivers ~x86" >>/etc/portage/package.keywords
> >
> > -Richard
>
> Also, if you have "userpriv" in your FEATURES= in /etc/make.conf remove it
and
> then emerge -resume. It may work . . . after that you can re-instate it.

Thanks, but I don't have anything like that in /etc/make.conf :(


--
gentoo-user@gentoo.org mailing list
Re: can't install ati-drivers [ In reply to ]
On Tuesday 25 July 2006 20:35, Stefán István wrote:
> kedd 25 július 2006 21.28 dátummal Mick ezt írta:

> > Also, if you have "userpriv" in your FEATURES= in /etc/make.conf remove
> > it
>
> and
>
> > then emerge -resume. It may work . . . after that you can re-instate it.
>
> Thanks, but I don't have anything like that in /etc/make.conf :(

Just ignore me then, it was a long shot anyway but the error was similar to
one that I had before and thought that it might help.
--
Regards,
Mick
Re: can't install ati-drivers [ In reply to ]
On 7/25/06, Stefán István <stefi@geohidroterv.hu> wrote:
> Meanwhile I was able to install the ati-drivers by adding
> ACCEPT_KEYWORDS="~x86" to emerge and install the latest version in portage.
> But now X doesn't start, and I find the following in the log file:

Do you have the dri use flag set for xorg-server? (emerge -pv xorg-server)

Are you loading the dri module in /etc/X11/xorg.conf?

It might help to gzip and attach your full /var/log/Xorg.0.log file.

-Richard

--
gentoo-user@gentoo.org mailing list
Re: can't install ati-drivers [ In reply to ]
kedd 25 július 2006 22.43 dátummal Richard Fish ezt írta:
> On 7/25/06, Stefán István <stefi@geohidroterv.hu> wrote:
> > Meanwhile I was able to install the ati-drivers by adding
> > ACCEPT_KEYWORDS="~x86" to emerge and install the latest version in
portage.
> > But now X doesn't start, and I find the following in the log file:
>
> Do you have the dri use flag set for xorg-server? (emerge -pv xorg-server)
>
Well, first I tried to install xorg simply by the "emerge xorg-x11" command.
It installed the newest 7.x version, but it doesn't want to work. Then I
unmerged it and installed the 6.8.2-r8. It works now with the vesa driver,
but not with fgrlx.
So, now I don't have xorg-server package installed (because it is part of the
7.x version), only xorg-x11:
# emerge -pv =xorg-x11-6.8.2-r8

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-base/xorg-x11-6.8.2-r8 USE="bitmap-fonts dlloader ipv6
nls opengl pam truetype-fonts type1-fonts xv -3dfx -3dnow -cjk -debug -dmx
-doc -font-server -insecure-drivers -minimal -mmx* -nocxx -sdk -sse* -static
-xprint*" 0 kB

> Are you loading the dri module in /etc/X11/xorg.conf?
Yes, it is loaded, or at least it is specified in the xorg.conf file.

> It might help to gzip and attach your full /var/log/Xorg.0.log file.

Okay, I attach it. I would have done it already, but I didn't kow that it is
allowed to send attachments to this list.

Thanks,
István
Re: can't install ati-drivers [ In reply to ]
Stefán István wrote:
> Calculating dependencies... done!
> [ebuild R ] x11-base/xorg-x11-6.8.2-r8 USE="bitmap-fonts dlloader ipv6
> nls opengl pam truetype-fonts type1-fonts xv -3dfx -3dnow -cjk -debug -dmx
> -doc -font-server -insecure-drivers -minimal -mmx* -nocxx -sdk -sse* -static
> -xprint*" 0 kB

I missed the beginning of this thread, but you need USE="-dlloader" to
use binary drivers with xorg 6.8.

Thanks,
Donnie
Re: can't install ati-drivers [ In reply to ]
szerda 26 július 2006 08.21 dátummal Donnie Berkholz ezt írta:
> Stefán István wrote:
> > Calculating dependencies... done!
> > [ebuild R ] x11-base/xorg-x11-6.8.2-r8 USE="bitmap-fonts dlloader
ipv6
> > nls opengl pam truetype-fonts type1-fonts xv -3dfx -3dnow -cjk -debug -dmx
> > -doc -font-server -insecure-drivers -minimal -mmx* -nocxx -sdk -sse*
-static
> > -xprint*" 0 kB
>
> I missed the beginning of this thread, but you need USE="-dlloader" to
> use binary drivers with xorg 6.8.
>
Thanks the tip, i try it rigth now.
Should I reemerge the ati-drivers also?

--
gentoo-user@gentoo.org mailing list
Re: can't install ati-drivers [ In reply to ]
szerda 26 július 2006 08.21 dátummal Donnie Berkholz ezt írta:
> Stefán István wrote:
> > Calculating dependencies... done!
> > [ebuild R ] x11-base/xorg-x11-6.8.2-r8 USE="bitmap-fonts dlloader
ipv6
> > nls opengl pam truetype-fonts type1-fonts xv -3dfx -3dnow -cjk -debug -dmx
> > -doc -font-server -insecure-drivers -minimal -mmx* -nocxx -sdk -sse*
-static
> > -xprint*" 0 kB
>
> I missed the beginning of this thread, but you need USE="-dlloader" to
> use binary drivers with xorg 6.8.

Thanks to your suggestion, fglrx driver works now in 2D
But with 3D I still have problems.
When I try to start glxinfo, it says:
Extension "GLX" missing.....

And I found this in the log file:
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *


Does somebody know any solution for this?

Thanks,
István

--
gentoo-user@gentoo.org mailing list
Re: can't install ati-drivers - SOLVED [ In reply to ]
szerda 26 július 2006 13.47 dátummal Stefán István ezt írta:
> szerda 26 július 2006 08.21 dátummal Donnie Berkholz ezt írta:
> > Stefán István wrote:
> > > Calculating dependencies... done!
> > > [ebuild R ] x11-base/xorg-x11-6.8.2-r8 USE="bitmap-fonts dlloader
> ipv6
> > > nls opengl pam truetype-fonts type1-fonts xv -3dfx -3dnow -cjk -debug
-dmx
> > > -doc -font-server -insecure-drivers -minimal -mmx* -nocxx -sdk -sse*
> -static
> > > -xprint*" 0 kB
> >
> > I missed the beginning of this thread, but you need USE="-dlloader" to
> > use binary drivers with xorg 6.8.
>
> Thanks to your suggestion, fglrx driver works now in 2D
> But with 3D I still have problems.
> When I try to start glxinfo, it says:
> Extension "GLX" missing.....
>
> And I found this in the log file:
> (WW) fglrx(0): ***********************************************
> (WW) fglrx(0): * DRI initialization failed! *
> (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
> (WW) fglrx(0): * 2D acceleraton available (MMIO) *
> (WW) fglrx(0): * no 3D acceleration available *
> (WW) fglrx(0): ********************************************* *
>
>
> Does somebody know any solution for this?

Okay, I found that there was no symlink
for /usr/lib/opengl/xorg-x11/extensions/libglx.a
in /usr/lib/modules/extensions. I created one, and know 3D works fine.

Thanks for everyone the help!!!

István

--
gentoo-user@gentoo.org mailing list