Mailing List Archive

2004.3 trouble mounting external G5 via firewire
Well, I'm trying to cheat, and it's not going well. :(

I have a G5 with gentoo installed and running. I'm trying to build a
second G5. My theory is to boot the gentoo G5 holding the 't' key so it
comes up as nothing more than a firewire drive. Then boot the new G5
with the Gentoo PPC64 liveCD, mount the firewire 'drives', and copy the
partitions over. :)

I can bring up the Gentoo G5 into firewire mode just fine (dancing
firewire symbol on the screen). However, the firewire drive doesn't
seem to be seen by the install CD... Here's (what I think) the relevant
portion of dmesg:

###Boot up####
ieee1394: Initialized config rom entry `ip1394'
ohci1394: $Rev: 1223 $ Ben Collins <bcollins@debian.org>
PCI: Enabling device: (0001:03:0e.0), cmd 2
ohci1394: fw-host0: Unexpected PCI resource length of 1000!
ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[40]
MMIO=[80200000-802007ff] Max Packet=[4096]
ieee1394: NodeMgr: could not process reset of unused host
ieee1394: raw1394: /dev/raw1394 device initialized
##############

###After bringing up G5 as firewire#####
ieee1394: Node changed: 0-01:1023 -> 0-00:1023
ieee1394: got invalid ack 252 from node 65472 (tcode 4)
ieee1394: got invalid ack 252 from node 65472 (tcode 4)
ieee1394: got invalid ack 252 from node 65472 (tcode 4)
ieee1394: Error parsing configrom for node 0-00:1023
ieee1394: Node changed: 0-00:1023 -> 0-01:1023
ieee1394: unsolicited response packet received - no tlabel match
sbp2: $Rev: 1219 $ Ben Collins <bcollins@debian.org>
ieee1394: got invalid ack 252 from node 65472 (tcode 4)
ieee1394: got invalid ack 252 from node 65472 (tcode 4)
ieee1394: Error parsing configrom for node 0-00:1023
ieee1394: Error parsing configrom for node 0-01:1023
ieee1394: Node suspended: ID:BUS[0-01:1023] GUID[000a95fffeba785a]
ieee1394: Node resumed: ID:BUS[0-01:1023] GUID[000a95fffeba785a]
ieee1394: Node changed: 0-01:1023 -> 0-00:1023
ieee1394: The root node is not cycle master capable; selecting a new
root node and resetting...
ieee1394: Node changed: 0-00:1023 -> 0-01:1023
ieee1394: got invalid ack 252 from node 65472 (tcode 4)
ieee1394: got invalid ack 252 from node 65472 (tcode 4)
ieee1394: got invalid ack 252 from node 65472 (tcode 4)
ieee1394: Error parsing configrom for node 0-00:1023
ieee1394: got invalid ack 252 from node 65472 (tcode 4)
ieee1394: got invalid ack 252 from node 65472 (tcode 4)
ieee1394: got invalid ack 252 from node 65472 (tcode 4)
ieee1394: Error parsing configrom for node 0-00:1023
ieee1394: unsolicited response packet received - no tlabel match
sbp2: $Rev: 1219 $ Ben Collins <bcollins@debian.org>
#################################

Any ideas what I'm doing wrong? (other than cheating)

tia,

Cooper.

--
gentoo-ppc-user@gentoo.org mailing list