Mailing List Archive

armv5tel-softfloat-linux-gnueabi-emerge ~sys-libs/glibc-2.2.5-r10
Hi everyone.

armv5tel-softfloat-linux-gnueabi-emerge ~sys-libs/glibc-2.2.5-r10

configure: error:
*** These critical programs are missing or too old:gcc
*** Check the INSTALL file for required versions.
*
* ERROR: cross-armv5tel-softfloat-linux-gnueabi/glibc-2.2.5-r10 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 2605: Called die
* The specific snippet of code:
* ../configure ${myconf} || die "configure failed";
* The die message:
* configure failed
*
* If you need support, post the topmost build error, and the call stack
if relevant.
* A complete build log is located at
'/var/log/portage/cross-armv5tel-softfloat-linux-gnueabi:glibc-2.2.5-r10:20090813-144513.log'.
* The ebuild environment file is located at
'/var/tmp/portage/cross-armv5tel-softfloat-linux-gnueabi/glibc-2.2.5-r10/temp/environment'.
* This ebuild is from an overlay named 'sunrise':
'/usr/local/portage/layman/sunrise/'
*

As you can see glibc configure can't find gcc (or is not getting the
right version number).

# gcc-config -l
[1] armv5tel-softfloat-linux-gnueabi-4.4.1 *

[2] x86_64-pc-linux-gnu-4.1.2
[3] x86_64-pc-linux-gnu-4.2.3
[4] x86_64-pc-linux-gnu-4.3.2 *

Please help.


--
Kind regards.

Stephen Feyrer.
Re: armv5tel-softfloat-linux-gnueabi-emerge ~sys-libs/glibc-2.2.5-r10 [ In reply to ]
On Thursday 13 August 2009 10:48:59 Stephen Feyrer wrote:
> ~sys-libs/glibc-2.2.5-r10

there is no chance at all of having this work with anything other than gcc-2
-mike
Re: armv5tel-softfloat-linux-gnueabi-emerge ~sys-libs/glibc-2.2.5-r10 [ In reply to ]
Hi.

Sorry.

--
Stephen Feyrer.

Mike Frysinger wrote:
> please keep replies on list
> -mike