Mailing List Archive

[PATCH 1/2] install-qa-check.d: disallow "nix" and "gnu" as top-level paths.
These exceptions were made for the sys-apps/nix and sys-apps/guix
packages that are no longer in the tree.
---
metadata/install-qa-check.d/08gentoo-paths | 2 --
1 file changed, 2 deletions(-)

diff --git a/metadata/install-qa-check.d/08gentoo-paths b/metadata/install-qa-check.d/08gentoo-paths
index e6cd7e67442..5161aef9922 100644
--- a/metadata/install-qa-check.d/08gentoo-paths
+++ b/metadata/install-qa-check.d/08gentoo-paths
@@ -17,8 +17,6 @@ gentoo_path_check() {
local allowed_paths_toplevel=(
"${allowed_common_dirs[@]}"
boot dev etc opt srv usr var
- nix # sys-apps/nix, bug #670902
- gnu # sys-apps/guix, bug #670902
)

# directories in /usr which can be installed to by ebuilds
--
2.24.1
Re: [PATCH 1/2] install-qa-check.d: disallow "nix" and "gnu" as top-level paths. [ In reply to ]
On Sun, 2020-01-19 at 22:43 -0500, Michael Orlitzky wrote:
> These exceptions were made for the sys-apps/nix and sys-apps/guix
> packages that are no longer in the tree.
> ---
> metadata/install-qa-check.d/08gentoo-paths | 2 --
> 1 file changed, 2 deletions(-)
>
> diff --git a/metadata/install-qa-check.d/08gentoo-paths b/metadata/install-qa-check.d/08gentoo-paths
> index e6cd7e67442..5161aef9922 100644
> --- a/metadata/install-qa-check.d/08gentoo-paths
> +++ b/metadata/install-qa-check.d/08gentoo-paths
> @@ -17,8 +17,6 @@ gentoo_path_check() {
> local allowed_paths_toplevel=(
> "${allowed_common_dirs[@]}"
> boot dev etc opt srv usr var
> - nix # sys-apps/nix, bug #670902
> - gnu # sys-apps/guix, bug #670902
> )
>
> # directories in /usr which can be installed to by ebuilds

Oh, were they removed already? In that case LGTM.

--
Best regards,
Micha? Górny