Mailing List Archive

[PATCH 3/3] kde5-functions.eclass: Drop functions/vars moved to ecm-utils
Functions moved to ecm-utils:
- _check_gcc_version
- punt_bogus_dep

Variable moved to ecm-utils:
- KDE_GCC_MINIMAL

Deprecated:
- _add_category_dep()
- add_frameworks_dep()
- add_plasma_dep()
- add_kdeapps_dep()
- add_qt_dep()


--- a/eclass/kde5-functions.eclass
+++ b/eclass/kde5-functions.eclass
@@ -15,23 +15,11 @@
if [[ -z ${_KDE5_FUNCTIONS_ECLASS} ]]; then
_KDE5_FUNCTIONS_ECLASS=1

-inherit toolchain-funcs
-
case ${EAPI} in
7) ;;
*) die "EAPI=${EAPI:-0} is not supported" ;;
esac

-# @ECLASS-VARIABLE: KDE_BUILD_TYPE
-# @DESCRIPTION:
-# If PV matches "*9999*", this is automatically set to "live".
-# Otherwise, this is automatically set to "release".
-KDE_BUILD_TYPE="release"
-if [[ ${PV} = *9999* ]]; then
- KDE_BUILD_TYPE="live"
-fi
-export KDE_BUILD_TYPE
-
case ${CATEGORY} in
kde-frameworks)
[[ ${KDE_BUILD_TYPE} = live ]] && : ${FRAMEWORKS_MINIMAL:=9999}
@@ -65,40 +53,6 @@ esac
# Minimum version of KDE Applications to require. This affects add_kdeapps_dep.
: ${KDE_APPS_MINIMAL:=19.04.3}

-# @ECLASS-VARIABLE: KDE_GCC_MINIMAL
-# @DEFAULT_UNSET
-# @DESCRIPTION:
-# Minimum version of active GCC to require. This is checked in kde5.eclass in
-# kde5_pkg_pretend and kde5_pkg_setup.
-
-# @FUNCTION: _check_gcc_version
-# @INTERNAL
-# @DESCRIPTION:
-# Determine if the current GCC version is acceptable, otherwise die.
-_check_gcc_version() {
- if [[ ${MERGE_TYPE} != binary && -v KDE_GCC_MINIMAL ]] && tc-is-gcc; then
-
- local version=$(gcc-version)
- local major=${version%.*}
- local minor=${version#*.}
- local min_major=${KDE_GCC_MINIMAL%.*}
- local min_minor=${KDE_GCC_MINIMAL#*.}
-
- debug-print "GCC version check activated"
- debug-print "Version detected:"
- debug-print " - Full: ${version}"
- debug-print " - Major: ${major}"
- debug-print " - Minor: ${minor}"
- debug-print "Version required:"
- debug-print " - Major: ${min_major}"
- debug-print " - Minor: ${min_minor}"
-
- [[ ${major} -lt ${min_major} ]] || \
- ( [[ ${major} -eq ${min_major} && ${minor} -lt ${min_minor} ]] ) \
- && die "Sorry, but gcc-${KDE_GCC_MINIMAL} or later is required for this package (found ${version})."
- fi
-}
-
# @FUNCTION: _add_category_dep
# @INTERNAL
# @DESCRIPTION:
@@ -143,6 +97,7 @@ _add_category_dep() {
# The output of this should be added directly to DEPEND/RDEPEND, and may be
# wrapped in a USE conditional (but not an || conditional without an extra set
# of parentheses).
+# PORTING: no replacement
add_frameworks_dep() {
debug-print-function ${FUNCNAME} "$@"

@@ -175,6 +130,7 @@ add_frameworks_dep() {
# The output of this should be added directly to DEPEND/RDEPEND, and may be
# wrapped in a USE conditional (but not an || conditional without an extra set
# of parentheses).
+# PORTING: no replacement
add_plasma_dep() {
debug-print-function ${FUNCNAME} "$@"

@@ -207,6 +163,7 @@ add_plasma_dep() {
# The output of this should be added directly to DEPEND/RDEPEND, and may be
# wrapped in a USE conditional (but not an || conditional without an extra set
# of parentheses).
+# PORTING: no replacement
add_kdeapps_dep() {
debug-print-function ${FUNCNAME} "$@"

@@ -239,6 +196,7 @@ add_kdeapps_dep() {
# The output of this should be added directly to DEPEND/RDEPEND, and may be
# wrapped in a USE conditional (but not an || conditional without an extra set
# of parentheses).
+# PORTING: no replacement
add_qt_dep() {
debug-print-function ${FUNCNAME} "$@"

@@ -263,6 +221,7 @@ add_qt_dep() {
# @USAGE: <prefix> <dependency>
# @DESCRIPTION:
# Removes a specified dependency from a find_package call with multiple components.
+# PORTING: Use ecm_punt_bogus_dep from ecm-utils.eclass instead.
punt_bogus_dep() {
local prefix=${1}
local dep=${2}