Mailing List Archive

Re: Radeon driver not working (solved)
It looks like while cleaning up I de-installed linux-firmware, found this
by looking at dmesg. Reinstalled the firmware & all good now.

On 31 May 2017 5:00 PM, "Daiajo Tibdixious" <> wrote:

I can't actually send from the machine so its hard to include stuff. I'm
not looking for a solution, just things to try.

I'm on kernel 4.9.16-gentoo
GPU is Turks XT (Radeon HD 6500/7670)
Kernel is setup according to the gentoo radeon guide, I compared it to
4.4.6 kernel, which has been working for months. Booting off that older
kernel doesn't change anything, so it can't be the kernel.

These are a manual transcript of selected Xorg.0.log errors
open /dev/dri/card0: No such file or directory
Device (s) detected, but none match those in config file

The /dev/dri directory does not exist. If it's created by udev, maybe I
have a udev problem?

On 31 May 2017 4:29 PM, "Thanasis" <> wrote:

On 05/31/2017 07:29 AM, Daiajo Tibdixious wrote:
> For a while now I've been logging into root & doing "modprobe radeon"
> after which the screen will blank, then come back at a much higher
> resolution. (as an aside, where do I put modules to autoload?) Since the
> last reboot nothing happens. SDDM/KDE will not start.
> I have checked all the radeon settings in the kernel, & tried booting
> off a previous kernel with no change.
> If I login to my user account & do "startx" that also fails.
> I took the cover off the machine & the GPU fan is spinning. It's dusty
> but not too bad.
> I've run out of ideas. To me it looks like a HW fault but I don't know
> how to check the GPU. It's still visible in lspci & console mode works
> (with tiny # lines & width).
> (IDK if this will be text or html, the setting is not visible on phone)

Are you expecting people here to guess your hardware configuration,
kernel configuration, debug messages, etc?