Mailing List Archive

kde 4.2.1 bug in kscreensaver? SOLVED
Now that I have xorg-server worked out (and it's really stable too) I'm
upgrading to KDE4.2.1. I just tried to upgrade kdeartwork-kscreensaver
and I got this:

[ 18%] Building CXX object
kscreensaver/kdesavers/CMakeFiles/kflux.kss.dir/Flux.o

Linking CXX executable keuphoria.kss

/usr/lib64/qt4/libQtOpenGL.so: undefined reference to
`QFontEngine::getGlyphPositions(QGlyphLayout const*, int, QTransform


Well that was easy enough. Turns out the problem was with Qt. It seems
when I updated to 4.5.0 qt-opengl did not get updated. I don't know if
that was my fault or if emerge missed it. I suspect it was an ID10T error.

Regardless, upgrading qt-opengl to 4.5.0 has fixed that error.


--
Frustra laborant quotquot se calculationibus fatigant pro inventione
quadraturae circuli

Mark Haney
Sr. Systems Administrator
ERC Broadband
(828) 350-2415

Call (866) ERC-7110 for after hours support
Re: kde 4.2.1 bug in kscreensaver? SOLVED [ In reply to ]
"Mark Haney" <mhaney@ercbroadband.org> posted
49BADEDD.9040708@ercbroadband.org, excerpted below, on Fri, 13 Mar 2009
18:31:57 -0400:

> I suspect it was an ID10T error.

Hmm... I'm used to seeing that referred to as a PEBCAK (alternatively
PEBKAC) issue. Interesting how the same idea in both problem and
description of it produced two rather different labels.

Regardless, glad it's fixed! =:^)

--
Duncan - List replies preferred. No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master." Richard Stallman