Mailing List Archive

AUTH PLAIN fails while AUTH LOGIN succeeds with Exim -> Dovecot SASL auth
Hello,
we're trying to setup a platform with authenticated SMTP with exim and
relying on dovecot as auth agent.

We've read http://wiki2.dovecot.org/HowTo/EximAndDovecotSASL and so made
the changes mentioned there, also setting

auth_mechanisms = plain login

in conf.d/10-auth.conf .

With this setup, we're able to use AUTH LOGIN method on an SMTP session,
but using AUTH PLAIN fails.

What we receive in the SMTP session is:

auth plain `echo -e -n `\0user\0password' | mimencode`
535 Incorrect authentication data

(it's actually the output of that command that we put there), and in the
dovecot log we see:

2012-05-24 15:04:20 auth: Debug: client in: AUTH 1 PLAIN
service=smtp secured rip=127.0.0.1 lip=127.0.0.1
nologin resp=<hidden>
2012-05-24 15:04:20 auth: Info: plain(?,127.0.0.1): invalid input

Do you know where we can look to resolve this problem? If you need any
further information/test feel free to ask.

Thanks in advance,
--
Sandro Tosi
Product Engineer
Shared Hosting Products
R&D | Dada.pro
eml sandro.tosi@register.it

--
## List details at https://lists.exim.org/mailman/listinfo/exim-users
## Exim details at http://www.exim.org/
## Please use the Wiki with this list - http://wiki.exim.org/
Re: AUTH PLAIN fails while AUTH LOGIN succeeds with Exim -> Dovecot SASL auth [ In reply to ]
On 05/25/2012 05:38 PM, Sandro Tosi wrote:
> With this setup, we're able to use AUTH LOGIN method on an SMTP session,
> but using AUTH PLAIN fails.

It turned out to be a problem in the encoding of the AUTH PLAIN string.

Sorry for the noise,
--
Sandro Tosi
Product Engineer
Shared Hosting Products
R&D | Dada.pro
eml sandro.tosi@register.it

--
## List details at https://lists.exim.org/mailman/listinfo/exim-users
## Exim details at http://www.exim.org/
## Please use the Wiki with this list - http://wiki.exim.org/