Mailing List Archive

UTF chars in Exim debug output
Hello!

I've noticed that Exim started to print UTF chars in its debug output.
Is there an option to disable this behavior?

--
George L. Yermulnik
[YZ-RIPE]

--
## List details at https://lists.exim.org/mailman/listinfo/exim-users
## Exim details at http://www.exim.org/
## Please use the Wiki with this list - http://wiki.exim.org/
Re: UTF chars in Exim debug output [ In reply to ]
On 9/30/18 9:55 PM, George L. Yermulnik via Exim-users wrote:
> I've noticed that Exim started to print UTF chars in its debug output.
> Is there an option to disable this behavior?

No. I decided that enough terminal-emulators were UTF-8 -enabled.
If it's a stopper for you, please raise a bug.

Oddly, "less" when run from my commandline is, yet when run from
certain other tools I need to say
minus, 'r', enter
to it to get that mode.

--
Cheers,
Jeremy




--
## List details at https://lists.exim.org/mailman/listinfo/exim-users
## Exim details at http://www.exim.org/
## Please use the Wiki with this list - http://wiki.exim.org/
Re: UTF chars in Exim debug output [ In reply to ]
Hello!

On Sun, 30 Sep 2018 at 22:10:38 (+0100), Jeremy Harris via Exim-users wrote:

> > I've noticed that Exim started to print UTF chars in its debug output.
> > Is there an option to disable this behavior?

> No. I decided that enough terminal-emulators were UTF-8 -enabled.
> If it's a stopper for you, please raise a bug.

Not quite a stopper, but makes it less readable when running Exim debug
smtp sessions on non-utf terminal emulators and systems. I realise that
these sort of systems/terminals are kind of outdated but still exist and
use Exim as their main MTA so might worth having this option switchable.

Just looked into https://github.com/Exim/exim and couldn't find 'Issues'
in there thus please let me know how do I raise a bug for it and if it's
kind of achievable (option to switch it on or off).

Thank you.

--
George L. Yermulnik
[YZ-RIPE]

--
## List details at https://lists.exim.org/mailman/listinfo/exim-users
## Exim details at http://www.exim.org/
## Please use the Wiki with this list - http://wiki.exim.org/
Re: UTF chars in Exim debug output [ In reply to ]
On 9/30/18 10:38 PM, George L. Yermulnik via Exim-users wrote:
> please let me know how do I raise a bug for it and if it's
> kind of achievable (option to switch it on or off).

https://bugs.exim.org/

It'll take thinking about about for the best way of presenting
such a control. After considering how high the demand is,
of course.

It doesn't sound like it'd be too hard to do; the question
is really whether it's worth complexifying the code.
--
Cheers,
Jeremy

--
## List details at https://lists.exim.org/mailman/listinfo/exim-users
## Exim details at http://www.exim.org/
## Please use the Wiki with this list - http://wiki.exim.org/
Re: UTF chars in Exim debug output [ In reply to ]
Hello!

On Sun, 30 Sep 2018 at 22:47:00 (+0100), Jeremy Harris via Exim-users wrote:

> > please let me know how do I raise a bug for it and if it's
> > kind of achievable (option to switch it on or off).

> https://bugs.exim.org/

> It'll take thinking about about for the best way of presenting
> such a control. After considering how high the demand is,
> of course.

> It doesn't sound like it'd be too hard to do; the question
> is really whether it's worth complexifying the code.

I'm not sure the demand is quite high for this "feature" so I switched
to ascii locally. Might not be that super-beautiful as utf can do but
still works for me. Please let me know if you still want me to create a
bug for this feature to be implemented (utf8 vs ascii vs on/off).
Thanks.

--
George L. Yermulnik
[YZ-RIPE]

--
## List details at https://lists.exim.org/mailman/listinfo/exim-users
## Exim details at http://www.exim.org/
## Please use the Wiki with this list - http://wiki.exim.org/
Re: UTF chars in Exim debug output [ In reply to ]
On 01/10/2018 11:20, George L. Yermulnik via Exim-users wrote:
> I'm not sure the demand is quite high for this "feature" so I switched
> to ascii locally. Might not be that super-beautiful as utf can do but
> still works for me. Please let me know if you still want me to create a
> bug for this feature to be implemented (utf8 vs ascii vs on/off).

I've had one other person expressing interest (offlist),
so yes, please do raise a bug. Make it a "wishlist" type.
--
Thanks,
Jeremy


--
## List details at https://lists.exim.org/mailman/listinfo/exim-users
## Exim details at http://www.exim.org/
## Please use the Wiki with this list - http://wiki.exim.org/
Re: UTF chars in Exim debug output [ In reply to ]
Hello!

On Mon, 01 Oct 2018 at 12:12:33 (+0100), Jeremy Harris via Exim-users wrote:

> I've had one other person expressing interest (offlist),
> so yes, please do raise a bug. Make it a "wishlist" type.

No problem. Here it is: https://bugs.exim.org/show_bug.cgi?id=2324
Please adjust bug options as needed.
And thankings =)

--
George L. Yermulnik
[YZ-RIPE]

--
## List details at https://lists.exim.org/mailman/listinfo/exim-users
## Exim details at http://www.exim.org/
## Please use the Wiki with this list - http://wiki.exim.org/