Mailing List Archive

Unknown error
Hi,

I've tried to install Catalyst::Devel with ActivePerl 5.10.0 under Fedora,
but I received the warning below.

I read that bug ticket and I've seen that this bug was patched in perl
5.10.1.

Does this mean that if I will compile Perl 5.10.0 from the tarball, it will
give the same error?
If yes, is Perl 5.10.1 available somewhere and stable enough for beeing
recommended to install it?
If no, do you have a better suggestion for solving this issue?

Thank you.

The warning:

############################### WARNING #################################
# #
# You are using perl 5.10.0 with the "Unknown error" bug. This can make #
# developing Catalyst applications much more painful, as it will come #
# up with no details every time you have a syntax error in a Controller.#
# #
# For more information see: #
# #
# * http://rt.perl.org/rt3/Public/Bug/Display.html?id=49472 #
# #
# It is highly recommended that you use a different version of perl or #
# compile a patched version for Catalyst development. #
# #
# To skip this check, set the CATALYST_DEVEL_NO_510_CHECK environment #
# variable. #
# #
#########################################################################
Do you want to continue? [no]


_______________________________________________
List: Catalyst@lists.scsys.co.uk
Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
Dev site: http://dev.catalyst.perl.org/
Re: Unknown error [ In reply to ]
Octavian Râşniţă wrote:
> Does this mean that if I will compile Perl 5.10.0 from the tarball, it
> will give the same error?

Yes.

> If yes, is Perl 5.10.1 available somewhere and stable enough for beeing
> recommended to install it?

<shrug> I wouldn't run bleed perl in production, but why not use that
for development?

I'm not sure what your criteria for 'recommended to install it' are..

> If no, do you have a better suggestion for solving this issue?

Either patch the tarball yourself, use the 5.10.1 git branch, or use a
distribution which ships a reasonable perl (perl in debian lenny is
patched for example), or use perl 5.8.

Cheers
t0m



_______________________________________________
List: Catalyst@lists.scsys.co.uk
Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
Dev site: http://dev.catalyst.perl.org/