Mailing List Archive

mythweb/php53 conflict
CentOS v5.7/mythtv.i386 0.24.1-278.el5

Have need for php53 due to other packages installed, get dependency
conflict over php53-common and php-common when trying to add
mythweb.noarch 0.24.1-266

As php53 provides version greater than required php >= 5.1, can requires
clause be changed, or is there a simpler, less globally affecting
install method to achieve same?

--skip-broken barfs up same errors......

Thanks, and repo is a WONDERFUL resource and huge benefit to the
community, THANKS!!!

_______________________________________________
atrpms-users mailing list
atrpms-users@atrpms.net
http://lists.atrpms.net/mailman/listinfo/atrpms-users
Re: mythweb/php53 conflict [ In reply to ]
On Wed, Nov 16, 2011 at 10:58:39AM -0600, Noel Leistad - atrpms wrote:
> CentOS v5.7/mythtv.i386 0.24.1-278.el5
>
> Have need for php53 due to other packages installed, get dependency
> conflict over php53-common and php-common when trying to add
> mythweb.noarch 0.24.1-266
>
> As php53 provides version greater than required php >= 5.1, can requires
> clause be changed, or is there a simpler, less globally affecting
> install method to achieve same?

From rpm's POV it doesn't provide php >= 5.1, it really provides
really few hooks to try to soften the dependencies of mythweb.

This probably applies to any php based package. If there were a
solution I wouldn't mind applying it. I think the only way out is for
you to download the src.rpm of mythweb, install it (rpm -i) and modify
the php dependency before rebuiling it (rpm -bb).

> --skip-broken barfs up same errors......
>
> Thanks, and repo is a WONDERFUL resource and huge benefit to the
> community, THANKS!!!

You are welcome! :)
--
Axel.Thimm at ATrpms.net

_______________________________________________
atrpms-users mailing list
atrpms-users@atrpms.net
http://lists.atrpms.net/mailman/listinfo/atrpms-users