Mailing List Archive

httpd-2.4.2 "make install" fails on AIX 6.1
I have similar problem to the problem described here: http://grokbase.com/t/apache/dev/11cva03wa7/httpd-2-3-16-beta-make-install-fails

I have coreutils and libtools installed.

I have successfully compiled apr and apr-utils as follows:

# Build and install apr
./configure --prefix=/usr/local/apr-httpd/
make
make install

# Build and install apr-util
./configure --prefix=/usr/local/apr-util-httpd/ --with-apr=/usr/local/apr-httpd/ --with-openssl --with-crypto --with-ldap --with-expat=/usr
make
make install

# Configure httpd
./configure --with-apr=/usr/local/apr-httpd/ --with-apr-util=/usr/local/apr-util-httpd/ \
--with-mpm=prefork \
--enable-auth-basic \
--enable-auth-form \
--enable-authn-anon \
--enable-authn-dbm \
--enable-auth-digest \
--enable-authnz-ldap \
--enable-cern-meta \
--enable-dav \
--enable-dav-fs \
--enable-dbd \
--enable-deflate \
--enable-expires \
--enable-ext-filter \
--enable-headers \
--enable-info \
--enable-ldap \
--enable-mime-magic \
--enable-proxy \
--enable-rewrite \
--enable-session \
--enable-session-cookie \
--enable-session-crypto \
--enable-session-dbd \
--enable-speling \
--enable-ssl \
--enable-unique-id \
--enable-usertrack \
--enable-vhost-alias \
--enable-mods-shared="auth-basic auth-form authn_anon authn_dbm auth_digest authnz-ldap cern_meta dav dav_fs dbd deflate expires ext_filter headers info ldap mime_magic proxy rewrite session session-cookie session-crypto session-dbd ssl speling unique_id usertrack vhost_alias"

make is successful.

make install fails with this error:

Making install in modules
Making install in aaa
rm -f /usr/local/apache2/modules/mod_authn_file.so
/usr/local/apr-httpd//build-1/libtool --silent --mode=install install mod_authn_file.la /usr/local/apache2/modules/
find: bad status-- /usr/local/apache2/modules/mod_authn_file.so
install: File mod_authn_file.so was not found.
make: 1254-004 The error code from the last command is 2.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.

Thanks for assistance.
RE: httpd-2.4.2 "make install" fails on AIX 6.1 [ In reply to ]
Hi Brian,
I ran into this same problem just a week ago, if I knew more about mailing lists and how to update a Wiki I'd be able to refer you to the email I sent In about it.

The problem went away for me when I set up my execution path so that the 'which install' command found the GNU CoreUtils install program in /opt/freeware/bin (I think) instead of the AIX one in /usr/bin. You may need to re-run the configure script so the GNU install program gets picked out then.

Yours,

George Reimer

From: Brian Gaber [mailto:Brian.Gaber@tpsgc-pwgsc.gc.ca]
Sent: Tuesday, June 05, 2012 8:31 AM
To: 'users@httpd.apache.org'
Subject: [users@httpd] httpd-2.4.2 "make install" fails on AIX 6.1

I have similar problem to the problem described here: http://grokbase.com/t/apache/dev/11cva03wa7/httpd-2-3-16-beta-make-install-fails

I have coreutils and libtools installed.

I have successfully compiled apr and apr-utils as follows:

# Build and install apr
./configure --prefix=/usr/local/apr-httpd/
make
make install

# Build and install apr-util
./configure --prefix=/usr/local/apr-util-httpd/ --with-apr=/usr/local/apr-httpd/ --with-openssl --with-crypto --with-ldap --with-expat=/usr
make
make install

# Configure httpd
./configure --with-apr=/usr/local/apr-httpd/ --with-apr-util=/usr/local/apr-util-httpd/ \
--with-mpm=prefork \
--enable-auth-basic \
--enable-auth-form \
--enable-authn-anon \
--enable-authn-dbm \
--enable-auth-digest \
--enable-authnz-ldap \
--enable-cern-meta \
--enable-dav \
--enable-dav-fs \
--enable-dbd \
--enable-deflate \
--enable-expires \
--enable-ext-filter \
--enable-headers \
--enable-info \
--enable-ldap \
--enable-mime-magic \
--enable-proxy \
--enable-rewrite \
--enable-session \
--enable-session-cookie \
--enable-session-crypto \
--enable-session-dbd \
--enable-speling \
--enable-ssl \
--enable-unique-id \
--enable-usertrack \
--enable-vhost-alias \
--enable-mods-shared="auth-basic auth-form authn_anon authn_dbm auth_digest authnz-ldap cern_meta dav dav_fs dbd deflate expires ext_filter headers info ldap mime_magic proxy rewrite session session-cookie session-crypto session-dbd ssl speling unique_id usertrack vhost_alias"

make is successful.

make install fails with this error:

Making install in modules
Making install in aaa
rm -f /usr/local/apache2/modules/mod_authn_file.so
/usr/local/apr-httpd//build-1/libtool --silent --mode=install install mod_authn_file.la /usr/local/apache2/modules/
find: bad status-- /usr/local/apache2/modules/mod_authn_file.so
install: File mod_authn_file.so was not found.
make: 1254-004 The error code from the last command is 2.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.

Thanks for assistance.

_____________
The information contained in this message is proprietary and/or confidential. If you are not the intended recipient, please: (i) delete the message and all copies; (ii) do not disclose, distribute or use the message in any manner; and (iii) notify the sender immediately. In addition, please be aware that any message addressed to our domain is subject to archiving and review by persons other than the intended recipient. Thank you.
RE: httpd-2.4.2 "make install" fails on AIX 6.1 [ In reply to ]
This suggestion worked.

For the "configure" and "make" I had the PATH have "/usr/bin" before "/opt/freeware/bin". Before running "make install" I changed PATH to have "/opt/freeware/bin" before "/usr/bin" and this worked.

Having the path with "/opt/freeware/bin" before "/usr/bin" from the beginning resulted in a make error.

Thanks.

________________________________
From: Reimer, George [mailto:George.Reimer@fisglobal.com]
Sent: Tuesday, June 05, 2012 10:31 AM
To: users@httpd.apache.org
Subject: [users@httpd] RE: httpd-2.4.2 "make install" fails on AIX 6.1

Hi Brian,
I ran into this same problem just a week ago, if I knew more about mailing lists and how to update a Wiki I'd be able to refer you to the email I sent In about it.

The problem went away for me when I set up my execution path so that the 'which install' command found the GNU CoreUtils install program in /opt/freeware/bin (I think) instead of the AIX one in /usr/bin. You may need to re-run the configure script so the GNU install program gets picked out then.

Yours,

George Reimer

From: Brian Gaber [mailto:Brian.Gaber@tpsgc-pwgsc.gc.ca]
Sent: Tuesday, June 05, 2012 8:31 AM
To: 'users@httpd.apache.org'
Subject: [users@httpd] httpd-2.4.2 "make install" fails on AIX 6.1

I have similar problem to the problem described here: http://grokbase.com/t/apache/dev/11cva03wa7/httpd-2-3-16-beta-make-install-fails

I have coreutils and libtools installed.

I have successfully compiled apr and apr-utils as follows:

# Build and install apr
./configure --prefix=/usr/local/apr-httpd/
make
make install

# Build and install apr-util
./configure --prefix=/usr/local/apr-util-httpd/ --with-apr=/usr/local/apr-httpd/ --with-openssl --with-crypto --with-ldap --with-expat=/usr
make
make install

# Configure httpd
./configure --with-apr=/usr/local/apr-httpd/ --with-apr-util=/usr/local/apr-util-httpd/ \
--with-mpm=prefork \
--enable-auth-basic \
--enable-auth-form \
--enable-authn-anon \
--enable-authn-dbm \
--enable-auth-digest \
--enable-authnz-ldap \
--enable-cern-meta \
--enable-dav \
--enable-dav-fs \
--enable-dbd \
--enable-deflate \
--enable-expires \
--enable-ext-filter \
--enable-headers \
--enable-info \
--enable-ldap \
--enable-mime-magic \
--enable-proxy \
--enable-rewrite \
--enable-session \
--enable-session-cookie \
--enable-session-crypto \
--enable-session-dbd \
--enable-speling \
--enable-ssl \
--enable-unique-id \
--enable-usertrack \
--enable-vhost-alias \
--enable-mods-shared="auth-basic auth-form authn_anon authn_dbm auth_digest authnz-ldap cern_meta dav dav_fs dbd deflate expires ext_filter headers info ldap mime_magic proxy rewrite session session-cookie session-crypto session-dbd ssl speling unique_id usertrack vhost_alias"

make is successful.

make install fails with this error:

Making install in modules
Making install in aaa
rm -f /usr/local/apache2/modules/mod_authn_file.so
/usr/local/apr-httpd//build-1/libtool --silent --mode=install install mod_authn_file.la /usr/local/apache2/modules/
find: bad status-- /usr/local/apache2/modules/mod_authn_file.so
install: File mod_authn_file.so was not found.
make: 1254-004 The error code from the last command is 2.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.

Thanks for assistance.

_____________
The information contained in this message is proprietary and/or confidential. If you are not the intended recipient, please: (i) delete the message and all copies; (ii) do not disclose, distribute or use the message in any manner; and (iii) notify the sender immediately. In addition, please be aware that any message addressed to our domain is subject to archiving and review by persons other than the intended recipient. Thank you.
Re: RE: httpd-2.4.2 "make install" fails on AIX 6.1 [ In reply to ]
It may not have all the options you want installed, but I worked on a set
up scripts in ./build/aix

The idea is that if you run build/aix/buildaix.ksh it does a configure for
you. I also suggested a layout for AIX (look in config.layout).

The layout uses /opt/httpd, /var/httpd and /etc/httpd as the directories to
put the files and puts the man pages in /usr/share/man1

The "difficulity" is with apr and apr-util. As long as these can be found
the configure command should run fine.

Note: if you have already run configure (i.e. Makefile exists) the scripts
do not run configure but run
make
make DESTDIR=xxx install

and then calls a final script that creates an installp installable in
build/aix/xxx.I

This creates both a root part and a usr part (man pages, binaries go in usr
part).

Am very interested in hearing how it works (or where it did not work); what
you like, do not like.

regards,
Michael

note: the script tests for the fileset with the mkinstallp command and
stops if it is not installed.

On Tue, Jun 5, 2012 at 6:26 PM, Brian Gaber
<Brian.Gaber@tpsgc-pwgsc.gc.ca>wrote:

> **
> This suggestion worked.
>
> For the "configure" and "make" I had the PATH have "/usr/bin" before
> "/opt/freeware/bin". Before running "make install" I changed PATH to have
> "/opt/freeware/bin" before "/usr/bin" and this worked.
>
> Having the path with "/opt/freeware/bin" before "/usr/bin" from the
> beginning resulted in a make error.
>
> Thanks.
>
> ------------------------------
> *From:* Reimer, George [mailto:George.Reimer@fisglobal.com]
> *Sent:* Tuesday, June 05, 2012 10:31 AM
> *To:* users@httpd.apache.org
> *Subject:* [users@httpd] RE: httpd-2.4.2 "make install" fails on AIX 6.1
>
> Hi Brian,****
>
> I ran into this same problem just a week ago, if I knew more about
> mailing lists and how to update a Wiki I’d be able to refer you to the
> email I sent In about it.****
>
> ** **
>
> The problem went away for me when I set up my execution path so that
> the ‘which install’ command found the GNU CoreUtils install program in
> /opt/freeware/bin (I think) instead of the AIX one in /usr/bin. You may
> need to re-run the configure script so the GNU install program gets picked
> out then.****
>
> ** **
>
> Yours,****
>
> ** **
>
> George Reimer****
>
> ****
>
> ** **
>
> *From:* Brian Gaber [mailto:Brian.Gaber@tpsgc-pwgsc.gc.ca]
> *Sent:* Tuesday, June 05, 2012 8:31 AM
> *To:* 'users@httpd.apache.org'
> *Subject:* [users@httpd] httpd-2.4.2 "make install" fails on AIX 6.1****
>
> ** **
>
> I have similar problem to the problem described here:
> http://grokbase.com/t/apache/dev/11cva03wa7/httpd-2-3-16-beta-make-install-fails
> ****
>
> ****
>
> I have coreutils and libtools installed.****
>
> ****
>
> I have successfully compiled apr and apr-utils as follows:****
>
> ****
>
> # Build and install apr****
>
> ./configure --prefix=/usr/local/apr-httpd/****
>
> make****
>
> make install****
>
> ****
>
> # Build and install apr-util****
>
> ./configure --prefix=/usr/local/apr-util-httpd/
> --with-apr=/usr/local/apr-httpd/ --with-openssl --with-crypto --with-ldap
> --with-expat=/usr****
>
> make****
>
> make install****
>
> ****
>
> # Configure httpd****
>
> ./configure --with-apr=/usr/local/apr-httpd/
> --with-apr-util=/usr/local/apr-util-httpd/ \****
>
> --with-mpm=prefork \****
>
> --enable-auth-basic \****
>
> --enable-auth-form \****
>
> --enable-authn-anon \****
>
> --enable-authn-dbm \****
>
> --enable-auth-digest \****
>
> --enable-authnz-ldap \****
>
> --enable-cern-meta \****
>
> --enable-dav \****
>
> --enable-dav-fs \****
>
> --enable-dbd \****
>
> --enable-deflate \****
>
> --enable-expires \****
>
> --enable-ext-filter \****
>
> --enable-headers \****
>
> --enable-info \****
>
> --enable-ldap \****
>
> --enable-mime-magic \****
>
> --enable-proxy \****
>
> --enable-rewrite \****
>
> --enable-session \****
>
> --enable-session-cookie \****
>
> --enable-session-crypto \****
>
> --enable-session-dbd \****
>
> --enable-speling \****
>
> --enable-ssl \****
>
> --enable-unique-id \****
>
> --enable-usertrack \****
>
> --enable-vhost-alias \****
>
> --enable-mods-shared="auth-basic auth-form authn_anon authn_dbm
> auth_digest authnz-ldap cern_meta dav dav_fs dbd deflate expires ext_filter
> headers info ldap mime_magic proxy rewrite session session-cookie
> session-crypto session-dbd ssl speling unique_id usertrack vhost_alias"***
> *
>
> ****
>
> make is successful.****
>
> ****
>
> make install fails with this error:****
>
> ****
>
> Making install in modules****
>
> Making install in aaa****
>
> rm -f /usr/local/apache2/modules/mod_authn_file.so****
>
> /usr/local/apr-httpd//build-1/libtool --silent --mode=install install
> mod_authn_file.la /usr/local/apache2/modules/****
>
> find: bad status-- /usr/local/apache2/modules/mod_authn_file.so****
>
> install: File mod_authn_file.so was not found.****
>
> make: 1254-004 The error code from the last command is 2.****
>
> ****
>
> ****
>
> Stop.****
>
> make: 1254-004 The error code from the last command is 1.****
>
> ****
>
> ****
>
> Stop.****
>
> make: 1254-004 The error code from the last command is 1.****
>
> ****
>
> ****
>
> Stop.****
>
> make: 1254-004 The error code from the last command is 1.****
>
> ****
>
> ****
>
> Stop.****
>
> ****
>
> Thanks for assistance.****
>
> ****
> _____________
> The information contained in this message is proprietary and/or
> confidential. If you are not the intended recipient, please: (i) delete the
> message and all copies; (ii) do not disclose, distribute or use the message
> in any manner; and (iii) notify the sender immediately. In addition, please
> be aware that any message addressed to our domain is subject to archiving
> and review by persons other than the intended recipient. Thank you.
>